Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 641938

Summary: sci-libs/scikits_image - switch from deprecated PyQt4 to PyQt5 support
Product: Gentoo Linux Reporter: Andreas Sturmlechner <asturm>
Component: Current packagesAssignee: Gentoo Science Related Packages <sci>
Status: RESOLVED FIXED    
Severity: normal CC: kensington
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 631788    

Description Andreas Sturmlechner gentoo-dev 2017-12-21 14:33:10 UTC
Qt4 is dead and going away, please check if this can be run with PyQt5 instead. Support for it in matplotlib exists.
Comment 1 Michael Palimaka (kensington) gentoo-dev 2018-01-13 01:34:51 UTC
This is an optional runtime-only dependency. I'd just drop the USE flag completely.
Comment 2 Larry the Git Cow gentoo-dev 2018-01-14 13:21:44 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1e8f3957c0a197a0127c0c55f953f4e638053996

commit 1e8f3957c0a197a0127c0c55f953f4e638053996
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-01-14 13:19:30 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-01-14 13:21:29 +0000

    sci-libs/scikits_image: Drop USE=qt4
    
    Closes: https://bugs.gentoo.org/641938
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 sci-libs/scikits_image/scikits_image-0.13.0.ebuild | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)