Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 641826

Summary: app-office/libreoffice - can't find /usr/lib64/jvm during configure (icedtea-bin)
Product: Gentoo Linux Reporter: Derk W te Bokkel <derk.tebokkel>
Component: Current packagesAssignee: Gentoo Office Team <office>
Status: RESOLVED FIXED    
Severity: normal CC: alexander, devurandom, java, leonchik1976, sakaki, xaviermiller
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 506276    

Description Derk W te Bokkel 2017-12-20 15:49:29 UTC
I expect this will be a problem for all versions of libreoffice with USE=java.

a symlink to icedtea-bin is installed into /usr/lib/jvm but not into /usr/lib64/jvm.

Libreoffice configure looks for jvm directory in /usr/lib64 .. thus fails to configure..

I had to symlink from /usr/lib/jvm to /usr/lib64/jvm and then it works..

(even reinstalled icedtea-bin to check)
Comment 1 Andreas Sturmlechner gentoo-dev 2017-12-20 15:56:13 UTC
Which version of libreoffice did you test with?
Comment 2 Derk W te Bokkel 2017-12-20 16:20:12 UTC
currently 44 minutes into the 8 hour emerge of app-office/libreoffice-5.4.4.2
Comment 3 Derk W te Bokkel 2017-12-20 16:22:09 UTC
using dev-java/icedtea-bin-3.6.0 as well fyi
Comment 4 Andreas Sturmlechner gentoo-dev 2017-12-20 16:23:50 UTC
the important difference here being:

  <LO-5.4.4.2 configure: --with-jvm-path="${EPREFIX}/usr/lib/"
 >=LO-5.4.4.2 configure: --with-jvm-path="${EPREFIX}/usr/$(get_libdir)/"
Comment 5 James Le Cuirot gentoo-dev 2017-12-20 16:25:17 UTC
This sounds like bug #549998 but I'll find out when I look into it later.
Comment 6 James Le Cuirot gentoo-dev 2017-12-25 12:22:56 UTC
*** Bug 642112 has been marked as a duplicate of this bug. ***
Comment 7 James Le Cuirot gentoo-dev 2017-12-28 11:18:10 UTC
Okay, I slightly misunderstood this issue because it's been misreported. This has nothing to do with 17.1 profiles as $(get_libdir) will return lib64 on both 17.0 and 17.1.

Bug #549998 therefore isn't as big a deal as I thought it was although I'd still like to move everything to /usr/libexec as /usr/lib will no longer make much sense.

This bug is actually a regression of bug #503624, introduced by asturm on Dec 13th. Before I revert the change, I'd like to check exactly what this flag does as it seems odd to point LO to a directory of various JVMs rather than a specific one.
Comment 8 Chris Smith 2017-12-28 19:11:48 UTC
Same issue with dev-java/oracle-jdk-bin-9.0.1 and app-office/libreoffice-5.4.4.2 using 17.1 profile.
Comment 9 Larry the Git Cow gentoo-dev 2017-12-28 19:35:00 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dc0ab178b2ee72b4503faf897dcbddd6534667ed

commit dc0ab178b2ee72b4503faf897dcbddd6534667ed
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2017-12-28 19:32:30 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2017-12-28 19:34:41 +0000

    app-office/libreoffice: Revert Use $(get_libdir) instead of hardcoded
    
    This reverts commit 5a2580630d7da08361bca09e86df2c2664c2f605.
    Thanks-to: James Le Cuirot <chewi@gentoo.org>
    Bug: https://bugs.gentoo.org/641826

 app-office/libreoffice/libreoffice-5.4.4.2.ebuild  | 2 +-
 app-office/libreoffice/libreoffice-5.4.9999.ebuild | 2 +-
 app-office/libreoffice/libreoffice-6.0.9999.ebuild | 2 +-
 app-office/libreoffice/libreoffice-9999.ebuild     | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)}
Comment 10 Andreas Sturmlechner gentoo-dev 2017-12-28 20:10:42 UTC
*** Bug 642566 has been marked as a duplicate of this bug. ***
Comment 11 James Le Cuirot gentoo-dev 2017-12-28 20:44:44 UTC
Okay, ignore what I said earlier, I had managed to tie my brain in knots while working out a migration plan. This *is* to do with the new profiles. asturm's change just made it break after remerging JVMs. Now he's reverted it, it'll break before remerging JVMs. I'll proceed with fixing bug #503624.
Comment 12 James Le Cuirot gentoo-dev 2018-01-03 23:15:00 UTC
I've decided to leave the jvm symlinks under /usr/lib after all. I'll close this now that the breaking change has been reverted.