Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 637674

Summary: sys-apps/shadow-4.5 - /bin/groups returns supplementary groups doubled
Product: Gentoo Linux Reporter: samurai.no.dojo
Component: Current packagesAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED OBSOLETE    
Severity: normal CC: fturco, pam-bugs+disabled, samurai.no.dojo
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=627338
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info sys-apps/shadow
/etc/nsswitch.conf

Description samurai.no.dojo 2017-11-16 11:47:44 UTC
/bin/groups (sys-apps/shadow-4.5) returns list of supplementary groups doubled.
but /usr/bin/id works as expected.

Reproducible: Always

Steps to Reproduce:
1.run /bin/groups user

Actual Results:  
wheel uucp cdrom video cdrw usb users mail plugdev vboxusers wireshark wheel uucp cdrom video cdrw usb users mail plugdev vboxusers wireshark user

Expected Results:  
wheel uucp cdrom video cdrw usb users mail plugdev vboxusers wireshark user

This also breaks app-admin/puppet-agent which relies on groups for is "user" resource.
I can reproduce this on three machines.
Comment 1 samurai.no.dojo 2017-11-16 11:50:08 UTC
Created attachment 504506 [details]
emerge --info sys-apps/shadow

emerge --info sys-apps/shadow as attachment
Comment 2 Francesco Turco 2017-11-16 13:04:07 UTC
https://github.com/shadow-maint/shadow/issues/87
Comment 3 Thomas Deutschmann gentoo-dev 2017-11-19 15:44:16 UTC
Please show us your /etc/nsswitch.conf.
Comment 4 Francesco Turco 2017-11-19 15:52:22 UTC
Created attachment 504962 [details]
/etc/nsswitch.conf
Comment 5 samurai.no.dojo 2017-11-23 17:38:47 UTC
(In reply to Francesco Turco from comment #4)
Mine /etc/nsswitch.conf is same as is in attachment
Comment 6 Francesco Turco 2018-04-25 12:12:40 UTC
I now have sys-apps/shadow-4.5-r1 and I cannot reproduce this bug anymore.
Comment 7 samurai.no.dojo 2018-04-29 04:28:37 UTC
(In reply to Francesco Turco from comment #6)
I do still have this problem even with sys-apps/shadow-4.5-r1
Comment 8 samurai.no.dojo 2018-08-28 13:27:54 UTC
It does not happen with sys-apps/shadow-4.6
Comment 9 Francesco Turco 2018-08-28 14:32:55 UTC
It's strange but I can now reproduce this bug again with shadow-4.6.
Comment 10 Francesco Turco 2020-03-17 10:25:17 UTC
With sys-apps/shadow-4.8.1-r1 everything seems OK. Can anyone else confirm?
Comment 11 zshzero 2020-03-17 12:32:22 UTC
(In reply to Francesco Turco from comment #10)
> With sys-apps/shadow-4.8.1-r1 everything seems OK. Can anyone else confirm?

With sys-apps/shadow-4.6, I got the following :

user@user ~ $ /bin/groups user
wheel audio cdrom video usb vboxguest user
Comment 12 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2021-05-15 15:28:02 UTC
Reopen if still a problem.