Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 636054

Summary: =dev-python/matplotlib-2.1.2-r1 stabilisation
Product: Gentoo Linux Reporter: Till Schäfer <till2.schaefer>
Component: StabilizationAssignee: Gentoo Science Related Packages <sci>
Status: RESOLVED FIXED    
Severity: normal CC: asturm, dan, frp.bissey, iskatu, kripton, luisav.ferreira, msava, o.freyermuth, python, tb
Priority: Normal Keywords: STABLEREQ
Version: unspecifiedFlags: stable-bot: sanity-check+
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
dev-python/matplotlib-2.1.2-r1 dev-python/cycler-0.10.0 dev-python/versioneer-0.16 dev-python/cairocffi-0.8.0 dev-python/colorspacious-1.1.0 dev-python/xcffib-0.5.1 media-libs/qhull-2015.2 dev-python/subprocess32-3.2.7 dev-python/functools32-3.2.3 dev-python/sphinx-gallery-0.1.12
Runtime testing required: ---
Bug Depends on: 622420, 626878    
Bug Blocks: 571778, 613350, 634952, 638792    
Attachments:
Description Flags
error compile phase with python 2.7 none

Description Till Schäfer 2017-10-31 15:00:56 UTC
Current stable is broken with QT 5.7

see Bug 613350 

and 

https://github.com/matplotlib/matplotlib/issues/6858/


Version 1.5.3-r2 of matplotlib works without issues here.
Comment 1 Till Schäfer 2017-11-28 19:47:10 UTC
The current stable package fails for everybody upgrading to python 3.5 with qt5 enabled. Can you please proceed with the stabilization?
Comment 2 Daniel M. Weeks 2017-12-13 21:46:25 UTC
This version also appears to be unaffected by the ICE from bug # 638792 and could workaround that problem if stabilized.
Comment 3 Sebastian Pucilowski 2017-12-16 06:07:20 UTC
Please stabilise. dev-python/matplotlib-1.4.3 is broken (as above) on the stable non-keyword portage tree.
Comment 4 Mircea Sava 2017-12-16 10:52:55 UTC
This version builds some of the times.

See bug #581550.
Comment 5 Mike Gilbert gentoo-dev 2017-12-18 21:45:27 UTC
If someone could come up with a list of dependencies that need to be stabilized, that would help move this bug along.
Comment 6 Bodo Graumann 2017-12-20 23:01:31 UTC
As far as I can see, we need:

- dev-python/cycler-0.10.0
- dev-python/versioneer-0.16
Comment 7 Mike Gilbert gentoo-dev 2017-12-23 18:26:59 UTC
Well, let's give it a shot.
Comment 8 Stabilization helper bot gentoo-dev 2017-12-23 19:01:36 UTC
An automated check of this bug failed - repoman reported dependency errors (19 lines truncated): 

> dependency.bad dev-python/matplotlib/matplotlib-1.5.3-r2.ebuild: DEPEND: arm(default/linux/arm/13.0) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-1.5.3-r2.ebuild: RDEPEND: arm(default/linux/arm/13.0) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-1.5.3-r2.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/13.0/64bit-userland) ['dev-python/cairocffi[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 9 François Bissey 2017-12-23 19:16:45 UTC
cairocffi-0.8.0 may not need stabilisation (I am not against but it is not the point here), 0.7.2 is quite enough. The message just says there isn't a stable version of cairocffi on two arch - arm and ppc64.

Is there any reason cairocffi-0.7.2 cannot be stabilised on those arch and therefore require 0.8.0?
Comment 10 Mike Gilbert gentoo-dev 2017-12-23 19:22:19 UTC
(In reply to François Bissey from comment #9)

cairocffi-0.8.0 has been in the tree for several months. I see no obvious reason not to stabilize it.
Comment 11 François Bissey 2017-12-23 19:25:03 UTC
Like I said I am not against it. It just felt the wrong answer to the question. Do we know why there is no stable cairocffi on arm and ppc64? Any problems on those arch could very well be still present with 0.8.0.
Comment 12 Mike Gilbert gentoo-dev 2017-12-23 19:31:31 UTC
(In reply to François Bissey from comment #11)

For someone who is not against it, you sure are asking a lot of questions...

Anyway, it's not stable on those archs because nobody asked those arch teams to mark it stable.
Comment 13 François Bissey 2017-12-23 19:37:19 UTC
(In reply to Mike Gilbert from comment #12)
> (In reply to François Bissey from comment #11)
> 
> For someone who is not against it, you sure are asking a lot of questions...
> 

I don't see any contradiction in that. I am a trained scientist, I ask questions about things.

> Anyway, it's not stable on those archs because nobody asked those arch teams
> to mark it stable.

OK.
Comment 14 Mike Gilbert gentoo-dev 2017-12-23 19:49:39 UTC
It turns out that both cairocffi-0.7.2 and cairocffi-0.8.0 have issues that need resolving. Help investigating would be most welcome.
Comment 15 Stabilization helper bot gentoo-dev 2017-12-23 20:01:50 UTC
An automated check of this bug failed - repoman reported dependency errors (19 lines truncated): 

> dependency.bad dev-python/cairocffi/cairocffi-0.8.0.ebuild: DEPEND: arm(default/linux/arm/13.0) ['>=dev-python/xcffib-0.3.2[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/cairocffi/cairocffi-0.8.0.ebuild: RDEPEND: arm(default/linux/arm/13.0) ['>=dev-python/xcffib-0.3.2[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/cairocffi/cairocffi-0.8.0.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/13.0/64bit-userland) ['>=dev-python/xcffib-0.3.2[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 16 Mike Gilbert gentoo-dev 2017-12-23 20:09:28 UTC
(In reply to François Bissey from comment #13)
> I don't see any contradiction in that. I am a trained scientist, I ask
> questions about things.

Please consider that answering your questions takes a little bit of my time, and that's really wasted time on my side. It also kind of seems like you don't think I know what I'm doing, which kind of irks me. I'm guessing that's not your intent, but that's how it came across to me.

To more directly answer the question of "why 0.8.0 instead of 0.7.2": it actually saves work in the long run. This way the arm and ppc64 teams will only have to test 1 version instead of 2.
Comment 17 Stabilization helper bot gentoo-dev 2017-12-23 21:02:12 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 18 Philippe Trottier 2017-12-24 18:47:28 UTC
I also would like this to be stabilized. I have a clean system and will install it soon again. I will let you guys know if it barks with some dependencies.

 Are they any specific use flags someone want to be checked before I give it a go ?

I know that 1.4.3 has similar segfaults, so in my opinion, the random png saved plot segfault while threaded(tk) in 1.5.x and 1.4.x are in all available packages. 1.5.x does solve some issues with threading. And it does compile with the latest batch of stable :)
Comment 19 Mike Gilbert gentoo-dev 2017-12-25 16:32:03 UTC
I can't reproduce the cairocffi-0.8.0 failure on stable.
Comment 20 Andreas Sturmlechner gentoo-dev 2018-01-05 18:33:25 UTC
Since 1.5.3-r1 was removed, let's bump this to 2.1.0-r1.
Comment 21 Stabilization helper bot gentoo-dev 2018-01-05 19:02:52 UTC
An automated check of this bug failed - repoman reported dependency errors (95 lines truncated): 

> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['dev-python/subprocess32[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', '>=media-libs/qhull-2013', 'dev-python/colorspacious[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['dev-python/subprocess32[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', '>=media-libs/qhull-2013']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop) ['dev-python/subprocess32[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', '>=media-libs/qhull-2013', 'dev-python/colorspacious[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 22 Stabilization helper bot gentoo-dev 2018-01-05 23:02:46 UTC
An automated check of this bug failed - repoman reported dependency errors (47 lines truncated): 

> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['dev-python/colorspacious[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop) ['dev-python/colorspacious[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop/gnome) ['dev-python/colorspacious[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 23 Stabilization helper bot gentoo-dev 2018-01-06 00:53:41 UTC
An automated check of this bug failed - repoman reported dependency errors: 

> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: DEPEND: arm(default/linux/arm/13.0) ['dev-python/functools32[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild: RDEPEND: arm(default/linux/arm/13.0) ['dev-python/functools32[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 24 Thomas Deutschmann gentoo-dev Security 2018-01-06 02:10:53 UTC
x86 stopped stabilization due to bug 643626.
Comment 25 Thomas Deutschmann gentoo-dev Security 2018-01-06 05:26:35 UTC
x86 stable
Comment 26 Thomas Deutschmann gentoo-dev Security 2018-01-06 05:29:49 UTC
No, x86 is not stable - I run the wrong script :/
Comment 27 Thomas Deutschmann gentoo-dev Security 2018-01-08 22:51:50 UTC
x86 stable
Comment 28 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-01-09 00:11:15 UTC
amd64 stable
Comment 29 Samuel Bernardo 2018-01-20 12:48:13 UTC
Created attachment 515354 [details]
error compile phase with python 2.7

I'm using gentoo with profile
default/linux/amd64/17.0 (stable)

It compiles with python 2.7 and fails.
Comment 30 David Flogeras 2018-03-09 10:21:53 UTC
I think matplotlib-2.1.0-r1 was accidentally cleaned from the tree, making the only stable in-tree version 1.4.3.  If memory serves, 1.4.3 doesn't currently compile with PIE enabled and/or qt-5.7.  Could it please be added back if this was unintentional?
Comment 31 Andreas Sturmlechner gentoo-dev 2018-03-15 19:58:15 UTC
Raising stabilisation target to dev-python/matplotlib-2.1.2-r1 to follow up changes in bug 622420, re-adding amd64/x86.
Adding dev-python/sphinx-gallery-0.1.12 to obsolete bug 644002.
Comment 32 Andreas Sturmlechner gentoo-dev 2018-03-15 20:00:50 UTC
*** Bug 644002 has been marked as a duplicate of this bug. ***
Comment 33 Sergei Trofimovich gentoo-dev 2018-03-19 23:06:05 UTC
ppc64 stable
Comment 34 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-03-22 15:11:43 UTC
amd64 stable
Comment 35 João P. Teixeira 2018-03-23 08:20:10 UTC
(In reply to Samuel Bernardo from comment #29)
> Created attachment 515354 [details]
> error compile phase with python 2.7
> 
> I'm using gentoo with profile
> default/linux/amd64/17.0 (stable)
> 
> It compiles with python 2.7 and fails.

Same problem, here; the output of emerge is the same. I am using gentoo (stable) with profile 

default/linux/amd64/17.0/desktop/plasma (stable)

Use flags and python targets for matplotlib:
 
cairo examples gtk2 latex qt5 tk wxwidgets -doc -excel -gtk3 -pyside -test 
PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"
Comment 36 François Bissey 2018-03-23 08:43:18 UTC
(In reply to João Paulo Teixeira from comment #35)
> (In reply to Samuel Bernardo from comment #29)
> > Created attachment 515354 [details]
> > error compile phase with python 2.7
> > 
> > I'm using gentoo with profile
> > default/linux/amd64/17.0 (stable)
> > 
> > It compiles with python 2.7 and fails.
> 
> Same problem, here; the output of emerge is the same. I am using gentoo
> (stable) with profile 
> 
> default/linux/amd64/17.0/desktop/plasma (stable)
> 
> Use flags and python targets for matplotlib:
>  
> cairo examples gtk2 latex qt5 tk wxwidgets -doc -excel -gtk3 -pyside -test 
> PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"

It looks like wxgtk needs to be rebuilt:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).

I'd say it has been compiled with an older version of g++ that some other parts tested and matplotlib doesn't like it.
Comment 37 Samuel Bernardo 2018-03-25 12:50:26 UTC
I'm the following error during compilation, that seems to be related to the errors described in previous messages:

Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).
                qt5agg: yes [installing, Qt: 5.9.4, PyQt: 5.9.4; PySide2 not
                        found]
                qt4agg: no  [skipping due to configuration]
               gtk3agg: no  [skipping due to configuration]
             gtk3cairo: no  [skipping due to configuration]
                gtkagg: no  [skipping due to configuration]
                 tkagg: yes [installing; run-time loading from Python Tcl /
                        Tk]
/var/tmp/portage/dev-python/matplotlib-2.1.2-r1/temp/environment: line 1737: 10247 Aborted                 (core dumped) "${@}"
 * ERROR: dev-python/matplotlib-2.1.2-r1::gentoo failed (compile phase):
 *   (no error message)

It seems that matplotlib-2.1.2-r1 revealed a missing compile dependency for wxPython, that need to be recompiled when gcc is upgraded.
Comment 38 Thomas Deutschmann gentoo-dev Security 2018-04-25 20:30:11 UTC
x86 stable
Comment 39 Andreas Sturmlechner gentoo-dev 2018-05-08 06:24:54 UTC
No longer blocking gcc-7-stable.
Comment 40 Andreas Sturmlechner gentoo-dev 2018-05-18 15:31:44 UTC
Superseded by bug 655400.