Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 632562

Summary: app-admin/apache-tools-2.4.27 fails to build with >=dev-libs/openssl-1.1.0
Product: Gentoo Linux Reporter: Markus Wernig <public>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal CC: public
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 592438    
Attachments: Complete build log

Description Markus Wernig 2017-09-30 17:19:11 UTC
Last errors:

libtool: link: x86_64-pc-linux-gnu-gcc -pthread -O2 -pipe -march=native -Wl,-O1 -o logresolve logresolve.o  -L/var/tmp/portage/dev-libs/apr-util-1.5.4-r1/temp -Wl,--as-needed -laprutil-1 /usr/lib64/libdb-6.0.so -lgdbm -lexpat -lapr-1 -luuid -lrt -lcrypt -lpthread -ldl -pthread
ab.o: In function `ssl_print_cert_info':
ab.c:(.text+0x814): undefined reference to `X509_get_notBefore'
ab.c:(.text+0x847): undefined reference to `X509_get_notAfter'
ab.o: In function `main':
ab.c:(.text.startup+0xa11): undefined reference to `SSL_load_error_strings'
ab.c:(.text.startup+0xa18): undefined reference to `SSL_library_init'
collect2: error: ld returned 1 exit status


Reproducible: Always
Comment 1 Markus Wernig 2017-09-30 17:19:43 UTC
Created attachment 497254 [details]
Complete build log
Comment 2 Andreas Sturmlechner gentoo-dev 2017-09-30 17:27:34 UTC
Please use the search function.

*** This bug has been marked as a duplicate of bug 592452 ***