Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 632265

Summary: sci-libs/ogdi-3.2.0_beta2 : /.../ogdi_macro.h:3:21: fatal error: rpc/xdr.h: No such file or directory
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Science Related Packages <sci>
Status: RESOLVED FIXED    
Severity: normal CC: atoth, devurandom
Priority: Normal Keywords: TESTFAILURE
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=649484
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 381391    
Attachments: emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
logs.tbz2
sci-libs:ogdi-3.2.0_beta2:20170928-083155.log
temp.tbz2
Still not solved in the tree

Description Toralf Förster gentoo-dev 2017-09-28 17:36:53 UTC
                 from ../vpf.h:7,
                 from ../vpfselec.c:29:
/var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/work/ogdi-3.2.0.beta2/include/Linux/ogdi_macro.h:3:21: fatal error: rpc/xdr.h: No such file or directory
 #include <rpc/xdr.h>
                     ^
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop_20170905-225247

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
  [5]   pypy (fallback)
  [6]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
1)	IcedTea JDK 7.2.6.11 [icedtea-7]
2)	IcedTea JDK 7.2.6.11 [icedtea-bin-7]
*)	IcedTea JDK 3.5.1 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-7 
  [2]   icedtea-bin-7 
  [3]   icedtea-bin-8  system-vm

emerge -qpv sci-libs/ogdi
[ebuild  N    ] sci-libs/ogdi-3.2.0_beta2  USE="-static-libs"
Comment 1 Toralf Förster gentoo-dev 2017-09-28 17:36:56 UTC
Created attachment 496941 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-09-28 17:36:59 UTC
Created attachment 496943 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-09-28 17:37:02 UTC
Created attachment 496945 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-09-28 17:37:05 UTC
Created attachment 496947 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-09-28 17:37:08 UTC
Created attachment 496949 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-09-28 17:37:11 UTC
Created attachment 496951 [details]
sci-libs:ogdi-3.2.0_beta2:20170928-083155.log
Comment 7 Toralf Förster gentoo-dev 2017-09-28 17:37:13 UTC
Created attachment 496953 [details]
temp.tbz2
Comment 8 Dennis Schridde 2017-11-28 20:19:06 UTC
Duplicate of bug #371389?
Comment 9 Toralf Förster gentoo-dev 2017-11-28 20:22:18 UTC
(In reply to Dennis Schridde from comment #8)
No, it blocks that bug.
Comment 10 Dennis Schridde 2017-11-28 23:26:32 UTC
(In reply to Toralf Förster from comment #9)
> (In reply to Dennis Schridde from comment #8)
> No, it blocks that bug.

I think this is not yet reflected in this bug's properties.  Could you please add bug #371389 to "Blocks:"?
Comment 11 Dennis Schridde 2017-11-28 23:58:40 UTC
Fixed in: https://github.com/devurandom/gentoo-overlay/commit/50c541d78cb02fc2aa7178935fd90a544a9a44f5

There is still a lot that could be done to improve the build-system, but the resulting library can now be used together with sci-libs/gdal.
Comment 12 Dennis Schridde 2017-11-30 07:35:23 UTC
See-Also: https://bugs.gentoo.org/371389
See-Also: https://bugs.gentoo.org/632660
See-Also: https://bugs.gentoo.org/639112
Comment 13 Attila Tóth 2017-12-27 22:09:49 UTC
(In reply to Dennis Schridde from comment #11)
> Fixed in:
> https://github.com/devurandom/gentoo-overlay/commit/
> 50c541d78cb02fc2aa7178935fd90a544a9a44f5
> 
> There is still a lot that could be done to improve the build-system, but the
> resulting library can now be used together with sci-libs/gdal.

Thanks: devurandom's gdal and ogdi works fine here!
Comment 14 Attila Tóth 2018-07-07 09:49:33 UTC
Created attachment 538678 [details, diff]
Still not solved in the tree

Please consider to reopen.
See also this libtirpc bug about header locations:
https://bugs.gentoo.org/660590