Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 630544

Summary: <app-text/texlive-core-2013 no longer installable ( impossible dependency on kpathsea )
Product: Gentoo Linux Reporter: Kent Fredric (IRC: kent\n) (RETIRED) <kentnl>
Component: Current packagesAssignee: Alexis Ballier <aballier>
Status: RESOLVED FIXED    
Severity: normal CC: tex
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 432144    
Bug Blocks:    

Description Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2017-09-09 23:58:41 UTC
Obviously this is non-critical, it just means there's a package that exists in tree, which can no longer be tested for bugs introduced by any in-place upgrades of dependencies ( like perl ).

All versions of texlive-core-2012 depend on dev-libs/kpathsea 

All versions of dev-libs/kpathsea block against <texlive-core-2013

Its kindof amusing portage/repoman/QA lets these sorts of problems exist :)

package: =app-text/texlive-core-2012-r1
  spec:  >=dev-libs/kpathsea-6.1.0_p20120701
    package: =dev-libs/kpathsea-6.2.2_p20160523
      spec: !<app-text/texlive-core-2013
    package: =dev-libs/kpathsea-6.2.3_p20170524
      spec: !<app-text/texlive-core-2013
Comment 1 Alexis Ballier gentoo-dev 2017-09-10 10:25:15 UTC
ahah; well, repoman does only 1 step checking, so that kind of cycle is not detected


pre-2016 versions are just waiting for hppa to stabilize them so that they can all be simply removed
Comment 2 Alexis Ballier gentoo-dev 2018-04-13 10:36:45 UTC
those versions are gone