Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 629734

Summary: dev-libs/nss-3.29.5 : secasn1.h:15:21: fatal error: plarena.h: No such file or directory
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Mozilla Gentoo Team <mozilla>
Status: UNCONFIRMED ---    
Severity: normal CC: spyros_ladon
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge-info.txt
nss-3.42.1 build.log with failure
nss-3.42.1 build.log with success

Description Toralf Förster gentoo-dev 2017-09-03 07:32:14 UTC
x86_64-pc-linux-gnu-gcc -m32 -o Linux2.6_x86_x86_64-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/quickder.o -c  -fPIC -Di386  -pipe -ffunction-sections -fdata-sections -DHAVE_STRERROR -DLINUX -Dlinux -Wall -DNSS_NO_GCC48 -DXP_UNIX -UDEBUG -DNDEBUG -D_REENTRANT -DNSS_NO_INIT_SUPPORT -DUSE_UTIL_DIRECTLY -DNO_NSPR_10_SUPPORT -DSSL_DISABLE_DEPRECATED_CIPHER_SUITE_NAMES -I../../dist/Linux2.6_x86_x86_64-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/include -I../../dist/public/nss -I../../dist/private/nss -I../../dist/Linux2.6_x86_x86_64-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/include/dbm -O2 -pipe -march=native -Wall   quickder.c
In file included from quickder.c:10:0:
secasn1.h:15:21: fatal error: plarena.h: No such file or directory
compilation terminated.
make[2]: *** [../../coreconf/ Linux2.6_x86_x86_64-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/quickder.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/dev-libs/nss-3.29.5/work/nss-3.29.5/nss-abi_x86_32.x86/lib/util'

=== This is an issue at stable ===


  This is an stable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop_stable-abi32+64_20170902-123437


gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems) *

emerge -qpv dev-libs/nss
[ebuild  N    ] dev-libs/nss-3.29.5  USE="nss-pem -cacert -utils" ABI_X86="32 (64) (-x32)"
Comment 1 Toralf Förster gentoo-dev 2017-09-03 07:32:18 UTC
Created attachment 492078 [details]
Comment 2 Toralf Förster gentoo-dev 2017-09-03 07:32:21 UTC
Created attachment 492080 [details]
Comment 3 Toralf Förster gentoo-dev 2017-09-03 07:32:25 UTC
Created attachment 492082 [details]
Comment 4 Toralf Förster gentoo-dev 2017-09-03 07:32:28 UTC
Created attachment 492084 [details]
Comment 5 Toralf Förster gentoo-dev 2017-09-03 07:32:31 UTC
Created attachment 492086 [details]
Comment 6 Spyros Papanastasiou 2019-02-08 10:53:03 UTC
Created attachment 564228 [details]
nss-3.42.1 build.log with failure

The original build log without the change to the CPATH.
Comment 7 Spyros Papanastasiou 2019-02-08 10:55:48 UTC
Created attachment 564230 [details]
nss-3.42.1 build.log with success

The second build log with changed CPATH="/usr/include/nspr:$CPATH".
Comment 8 Spyros Papanastasiou 2019-02-08 10:59:48 UTC
My case was fixed by changing CPATH.

CPATH="/usr/include/nspr:$CPATH" emerge -1 dev-libs/nss

I attached both the failed build.log and the successful one. Sorry, I messed up the comments^..
Comment 9 Nolan Eakins 2019-03-14 23:13:18 UTC
CPATH worked for me.
Comment 10 Jory A. Pratt gentoo-dev 2019-03-31 19:00:42 UTC
(In reply to Nolan Eakins from comment #9)
> CPATH worked for me.

Could you attach the enviroment file when it fails please.
Comment 11 Jory A. Pratt gentoo-dev 2019-07-25 16:28:29 UTC
(In reply to Nolan Eakins from comment #9)
> CPATH worked for me.

The mozilla team has not been able to reproduce this issue. If someone wants to give a detailed breakdown I will attempt to reproduce it again, other wise I am closing as worksforme.
Comment 12 Marek 2019-10-15 02:37:12 UTC
Got the same issue today.

Remerging dev-libs/nspr (which provides the missing header) fixed it.

It's possible that dev-libs/nspr should have been remerged when moving from 17.0 to 17.1 profile but wasn't for some reason. I haven't verified if this is the cause.