Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 628684

Summary: <dev-libs/libmspack-0.5_alpha-r1: heap-based buffer overflow in mspack/lzxd.c (CVE-2017-6419)
Product: Gentoo Security Reporter: Agostino Sarubbo <ago>
Component: VulnerabilitiesAssignee: Gentoo Security <security>
Status: RESOLVED FIXED    
Severity: normal CC: reavertm
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugzilla.redhat.com/show_bug.cgi?id=1483909
Whiteboard: B3 [noglsa cve]
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 649306    

Description Agostino Sarubbo gentoo-dev 2017-08-23 07:59:45 UTC
From ${URL} :

mspack/lzxd.c in libmspack 0.5alpha, as used in ClamAV 0.99.2, allows
remote attackers to cause a denial of service (heap-based buffer
overflow and application crash) or possibly have unspecified other
impact via a crafted CHM file.

Upstream patch:

https://github.com/vrtadmin/clamav-devel/commit/a83773682e856ad6529ba6db8d1792e6d515d7f1


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Maciej Mrozowski gentoo-dev 2017-08-24 20:09:11 UTC
libmspack-0.5_alpha-r1 with patch from clamav in repo.

I would say it's ready for stabilization.
I wonder about relation to bug 625634.
Comment 2 Maciej Mrozowski gentoo-dev 2017-10-19 23:12:39 UTC
libmspack-0.6_alpha in portage. Please stabilize this one instead. Also see bug 625634.
Comment 3 Thomas Deutschmann gentoo-dev 2018-03-02 00:23:09 UTC
Freeing CVE-2017-6419 alias to create a tracker bug.
Comment 4 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2018-03-27 02:40:06 UTC
No PoC for ACE/RCE.  Downgraded to B3.  Cleanup will be tracked in bug #625634