Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 627868

Summary: net-voip/ekiga-4.0.1-r1 (since glibc-2.25?): configure: error: You need the libresolv library to compile Ekiga
Product: Gentoo Linux Reporter: Kobboi <gentoo>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED WONTFIX    
Severity: normal CC: mlspamcb, norbeet, treecleaner, yamadharma
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugzilla.redhat.com/show_bug.cgi?id=1426109
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: config.log
Removes resolve check from Ekiga configure.

Description Kobboi 2017-08-14 18:33:00 UTC
Created attachment 489036 [details]
config.log

...
checking whether the Boost::Signals library is available... yes
checking for exit in -lboost_signals-mt... yes
checking for XML... yes
./configure: line 18360: enable_gconf: command not found
checking for GCONF... yes
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for EDS... yes
checking for NOTIFY... yes
checking for LDAP includes in /usr/include/... 
checking for main in -lldap... yes
checking for LIBSASL2 includes in /usr/include/... 
checking for res_gethostbyaddr in -lresolv... no
configure: error: You need the libresolv library to compile Ekiga
Comment 1 Hamlet 2017-10-02 00:29:15 UTC
Created attachment 497388 [details, diff]
Removes resolve check from Ekiga configure.
Comment 2 Hamlet 2017-10-02 00:30:37 UTC
This is how RedHat resolves the issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1426109

I have attached an equivalent patch for Gentoo ebuild net-voip/ekiga-4.0.1-r1.
Comment 3 Carl Michal 2017-11-15 14:56:29 UTC
The patch in comment 1 does the trick for me.
Comment 4 Max Steel 2017-11-20 10:30:48 UTC
Had the same Issue on my Machine. Patch #1 works for me.

$ emerge --info net-voip/ekiga
Portage 2.3.13 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.4.0, glibc-2.25-r9, 4.12.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-_i5-3470S_CPU_@_2.90GHz-with-gentoo-2.4.1
KiB Swap:   18874364 total,  18874364 free
Timestamp of repository gentoo: Mon, 20 Nov 2017 09:00:01 +0000
Head commit of repository gentoo: ddbbeb1b57c0b08c06d36a36a5adb639c2c42367
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.8::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 

[...]

=================================================================
                        Package Settings
=================================================================

net-voip/ekiga-4.0.1-r1::gentoo was built with the following:
USE="dbus h323 ldap libnotify pulseaudio shm xv -debug -doc -eds -v4l -zeroconf" ABI_X86="(64)" CPU_FLAGS_X86="mmx"
Comment 5 Nico Baggus 2017-12-12 01:53:16 UTC
Current version doesn't build during emerge -e @world  needed for conversion to Gentoo 17.
Comment 6 Pavel Goran 2017-12-27 15:49:01 UTC
Why is it masked and planned for removal?
Comment 7 Pacho Ramos gentoo-dev 2017-12-27 16:09:08 UTC
Apart of its own issues, the issues with the opal and ptlib versions this needs to use like:
https://bugs.gentoo.org/buglist.cgi?quicksearch=ptlib&list_id=3785216

We are waiting years for upstream to finally release ekiga 5 and stop relying on the old versions of this libs (and many other old libs it is also requiring), but that release never comes. I also remember to have reported bugs in the past to it and they fixing it only in the unreleased master branch, not to the ekiga-4 one
Comment 8 Nico Baggus 2017-12-27 20:11:33 UTC
Pitty, as this was the last usable voip client.
Comment 9 Nico Baggus 2017-12-27 20:19:05 UTC
IMHO the project is dead, in 2015 Ekiga 5.0 was announced, last dev 
downloadable prerelease was from sep 19, 2016.
Comment 10 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-01-26 23:05:12 UTC
Gone.