Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 627424

Summary: app-emulation/xen-tools: incorrect mask of USE=ovmf in no-multilib profile
Product: Gentoo Linux Reporter: Spooky Ghost <spookyghost>
Component: Current packagesAssignee: Gentoo Xen Devs <xen>
Status: UNCONFIRMED ---    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---

Description Spooky Ghost 2017-08-09 19:47:21 UTC
This seems to be a continuing propagation of  I didn't notice that hvm is still present in 
profiles/arch/amd64/no-multilib/use.mask as I had a postsync.d script which was commenting it out.  Now a new mask has been added for ovmf in profiles/arch/amd64/no-multilib/package.use.mask which is not necessary.

The missing stubs-32.h which I think should be provided by glibc is solved by this line in the ebuild.  xen-tools builds fine with both hvm and ovmf removed from the masks in the profile.  xen-4.5.2 hvm and ovmf both worked fine, I will report about 4.8.1-r1 once the upgrade I am doing is complete.

touch "${WORKDIR}"/extra-headers/gnu/stubs-32.h || die
Comment 1 Spooky Ghost 2017-08-15 14:35:46 UTC
An instance which includes these configuration options works on Xen 4.8.1

builder = "hvm"
device_model_override = "/usr/bin/qemu-system-x86_64"
device_model_version = "qemu-xen"
bios = "ovmf"

System profile is default/linux/amd64/13.0/no-multilib