Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 626294

Summary: dev-python/qtconsole-4.3.0 fails tests - ImportError: No module named QtTest
Product: Gentoo Linux Reporter: eroen <gentoo>
Component: Current packagesAssignee: Gentoo Science Related Packages <sci>
Status: UNCONFIRMED ---    
Severity: normal CC: jstein, marius.brehler+gentoo
Priority: Normal Keywords: TESTFAILURE
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: dev-python/qtconsole-4.3.0:20170726-194651.log

Description eroen 2017-07-26 20:18:39 UTC
Created attachment 486926 [details]
dev-python/qtconsole-4.3.0:20170726-194651.log

test_dark_style (qtconsole.tests.test_styles.TestStyles) ... ok

======================================================================
ERROR: Failure: ImportError (No module named QtTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/nose/loader.py", line 418, in loadTestsFromName
    addr.filename, addr.module)
  File "/usr/lib64/python2.7/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib64/python2.7/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/var/tmp/portage/dev-python/qtconsole-4.3.0/work/qtconsole-4.3.0/qtconsole/tests/test_completion_widget.py", line 11, in <module>
    QTest = load_qtest()
  File "/var/tmp/portage/dev-python/qtconsole-4.3.0/work/qtconsole-4.3.0/qtconsole/qt_loaders.py", line 392, in load_qtest
    from PyQt5.QtTest import QTest
ImportError: No module named QtTest

======================================================================
ERROR: Failure: ImportError (No module named QtTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/nose/loader.py", line 418, in loadTestsFromName
    addr.filename, addr.module)
  File "/usr/lib64/python2.7/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib64/python2.7/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/var/tmp/portage/dev-python/qtconsole-4.3.0/work/qtconsole-4.3.0/qtconsole/tests/test_console_widget.py", line 10, in <module>
    QTest = load_qtest()
  File "/var/tmp/portage/dev-python/qtconsole-4.3.0/work/qtconsole-4.3.0/qtconsole/qt_loaders.py", line 392, in load_qtest
    from PyQt5.QtTest import QTest
ImportError: No module named QtTest

======================================================================
ERROR: Failure: ImportError (No module named QtTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/nose/loader.py", line 418, in loadTestsFromName
    addr.filename, addr.module)
  File "/usr/lib64/python2.7/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib64/python2.7/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/var/tmp/portage/dev-python/qtconsole-4.3.0/work/qtconsole-4.3.0/qtconsole/tests/test_jupyter_widget.py", line 10, in <module>
    QTest = load_qtest()
  File "/var/tmp/portage/dev-python/qtconsole-4.3.0/work/qtconsole-4.3.0/qtconsole/qt_loaders.py", line 392, in load_qtest
    from PyQt5.QtTest import QTest
ImportError: No module named QtTest

----------------------------------------------------------------------
Ran 20 tests in 7.156s

FAILED (errors=3)
 * ERROR: dev-python/qtconsole-4.3.0::gentoo failed (test phase):
 *   Failed to run 'nosetests --verbosity=2 qtconsole'
 * 
 * Call stack:
 *     ebuild.sh, line  115:  Called src_test
 *   environment, line 2801:  Called distutils-r1_src_test
 *   environment, line  958:  Called _distutils-r1_run_foreach_impl 'python_test'
 *   environment, line  404:  Called python_foreach_impl 'distutils-r1_run_phase' 'python_test'
 *   environment, line 2317:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 1599:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_test'
 *   environment, line 1597:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_test'
 *   environment, line  628:  Called distutils-r1_run_phase 'python_test'
 *   environment, line  889:  Called python_test
 *   environment, line 2681:  Called virtx 'nosetests' '--verbosity=2' 'qtconsole'
 *   environment, line 3443:  Called die
 * The specific snippet of code:
 *       [[ ${retval} -ne 0 ]] && die "Failed to run '$@'";
Comment 1 eroen 2017-07-26 20:19:48 UTC
occam ~ # emerge --info '=dev-python/qtconsole-4.3.0::gentoo'
Portage 2.3.6 (python 3.6.1-final-0, hardened/linux/amd64, gcc-6.3.0, glibc-2.23-r3, 4.9.24-hardened-o0 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.9.24-hardened-o0-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.3
KiB Mem:     8000768 total,   2970548 free
KiB Swap:   16777212 total,  15224284 free
Timestamp of repository gentoo: Tue, 25 Jul 2017 14:30:01 +0000
Timestamp of repository eroen: Sun, 30 Oct 2016 21:58:42 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo, 3.5.3::gentoo, 3.6.1-r1::gentoo
dev-util/ccache:          3.3.4::gentoo
dev-util/cmake:           3.8.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.2::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            5.3.0::gentoo, 5.4.0-r3::gentoo, 6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: --exclude ChangeLog* --exclude /metadata/cache/ --stats --delay-updates -c

eroen
    location: /usr/local/portage
    masters: gentoo
    priority: 0

sapher
    location: /var/lib/overlays/sapher
    sync-type: git
    sync-uri: https://github.com/apinsard/sapher-overlay.git
    masters: gentoo

wiktorb
    location: /var/lib/overlays/wiktorb
    sync-type: git
    sync-uri: https://github.com/wiktor-b/overlay.git
    masters: gentoo

enlightenment
    location: /var/lib/layman/enlightenment
    masters: gentoo
    priority: 50

flora
    location: /var/lib/layman/flora
    masters: gentoo
    priority: 50

gamerlay
    location: /var/lib/layman/gamerlay
    masters: gentoo
    priority: 50

glc
    location: /var/lib/layman/glc
    masters: gentoo
    priority: 50

hardened-development
    location: /var/lib/layman/hardened-development
    masters: gentoo
    priority: 50

haskell
    location: /var/lib/layman/haskell
    masters: gentoo
    priority: 50

hasufell
    location: /var/lib/layman/hasufell
    masters: gentoo
    priority: 50

java
    location: /var/lib/layman/java
    masters: gentoo
    priority: 50

laurentb
    location: /var/lib/layman/laurentb
    masters: gentoo
    priority: 50

roslin
    location: /var/lib/layman/roslin
    masters: gentoo
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

stuff
    location: /var/lib/layman/stuff
    sync-type: git
    sync-uri: https://github.com/istitov/stuff.git
    masters: gentoo
    priority: 50

sunrise
    location: /var/lib/layman/sunrise
    masters: gentoo
    priority: 50

toolchain
    location: /var/lib/layman/toolchain
    masters: gentoo
    priority: 50

v-fox
    location: /var/lib/layman/v-fox
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -pipe -Og -g -gdwarf-4"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7-avx -pipe -Og -g -gdwarf-4"
DISTDIR="/var/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=4 --autounmask --quiet-build --nospinner --verbose-conflicts --verbose-slot-rebuilds"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs binpkg-multi-instance cgroup collision-protect compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles installsources ipc-sandbox merge-sync network-sandbox news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms split-log splitdebug strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=""
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j4 -l10"
PKGDIR="/var/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude ChangeLog* --exclude /metadata/cache/ --stats --delay-updates -c"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl alsa amd64 apng audio audiofile avresample avx bash-completion bdf berkdb bluray bzip2 cairo caps cb cdda cdparanoia cdr cjk cli corefonts cracklib crypt cups curl cxx ddate declarative detex device-mapper dga dia djvu dri dts dvd dvi2tty dvipdfm ebook egl exif fam ffmpeg fftw fits flac fontconfig g3dvl gallium gbm gcrypt gdbm gif gimp git glamor glib glibc-omitfp gmp gnuplot gnutls gold gpm graphics graphviz gs gstreamer gtk gtk3 hardened highlight hscolour iconv icu id3tag idn imagemagick imlib inotify iproute2 ipv6 jbig jpeg jpeg2k jpg json justify kde kde4 kpathsea latex lcms libffi libssh2 libv4l luatex lvm lvm2 lzma lzo man metric mikmod mkv mms mmx mng modules mp3 mpeg mpg123 multilib multimedia musepack ncurses netlink nptl nut ocr odbc offensive ogg opengl openmp openvg optimization optimized-qmake opus pam pango pax_kernel pcre pdf pgf phonon pie png postscript private-headers pstricks pth publishers python3 qt3support qt4 raw readline samba sbsms scanner science sdl seccomp session smp sna sndfile speex spell sqlite sse sse2 sse3 sse4 sse41 sse4_1 sse4_2 ssh ssl ssp ssse3 svg t1lib tcpd tesseract theora threads tiff tls truetype udev unicode urandom usb v4l v4l2 vaapi video vorbis vpx webp wmf x264 xanim xattr xcb xcomposite xetex xft xinerama xkb xml xmlpatterns xorg xosd xpm xrandr xtpax xv xvid xvmc xz zlib zsh-completion" ABI_X86="32 64" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 avx sse3 ssse3 sse4_1 aes avx mmxext popcnt sse3 sse4_1 sse4_2 ssse3" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="mouse keyboard evdev synaptics wacom" KERNEL="linux" L10N="en en-US en-GB eng" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en gb us en_US en_GB eng jbo no nb nn no_NO nb_NO nn_NO nor" LLVM_TARGETS="BPF X86" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" QEMU_SOFTMMU_TARGETS="x86_64 i386" RUBY_TARGETS="ruby22" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="intel i965 ilo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3 3.4"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND

occam ~ # emerge -pqv '=dev-python/qtconsole-4.3.0::gentoo'
[ebuild     U ] dev-python/qtconsole-4.3.0 [4.2.1] USE="{test} -doc" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6%*" 

!!! The following installed packages are masked:
- net-voip/blink-1.4.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (14 Jul 2017)
# Buggy, doesn't compile for a long time, bug #575772. Removal in a month.

- dev-dotnet/xdt-for-monodevelop-2.8.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mikhail Pukhlikov <cynede@gentoo.org> (20 Jul 2017)
# Old mono/dotnet packages (used on GNOME2 stack)
# also some deprecated forks used for monodevelop
# awhile they are very unstable they will live in dotnet overlay

- dev-dotnet/nuget-2.8.7-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Comment 2 Marius Brehler 2017-07-27 07:05:01 UTC
Thats strange, can you please post the output of 'eix PyQt5'. Normally, qtconsole should pull in dev-python/PyQt5[svg,testlib] and therefore the QtTest module should be present.
Comment 3 eroen 2017-07-27 08:09:15 UTC
eroen@occam ~ $ emerge -pvO PyQt4 PyQt5

These are the packages that would be merged, in order:

[ebuild   R    ] dev-python/PyQt4-4.12.1::gentoo  USE="X help sql svg testlib webkit -compat -dbus -debug -declarative -designer -doc -examples -kde -multimedia -opengl -phonon -script -scripttools -xmlpatterns" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 0 KiB
[ebuild   R    ] dev-python/PyQt5-5.8.2::gentoo  USE="gui network printsupport svg webkit widgets -bluetooth -dbus -debug -declarative -designer -doc -examples -gles2 -help -location -multimedia -opengl -positioning -sensors -serialport -sql -testlib -webchannel -webengine -websockets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 0 KiB

Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB



qtconsole-4.3.0.ebuild has this:

DEPEND="${RDEPEND}
    doc? (...)
    test? (
        >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
        || (
            dev-python/pyside[${PYTHON_USEDEP},svg]
            dev-python/PyQt5[${PYTHON_USEDEP},svg,testlib]
            dev-python/PyQt4[${PYTHON_USEDEP},svg,testlib]
        )
    )
    ..."

I do not think this does what the author thought it would do. In my case, I have   PyQt4[testlib] installed, which satisfies the || block.

I would expect the choice of qt4/qt5 to be hardcoded or controlled by a use flag, but looking at the ebuild it appears that the build system currently picks one automagically.
Comment 4 Marius Brehler 2017-11-24 08:56:09 UTC
Is this obsolete as qt4 was dropped with https://bugs.gentoo.org/630786?