Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 624774

Summary: dev-ros/diagnostic_analysis-1.9.0 : 1 - _ctest_diagnostic_analysis_nosetests_test.bag_csv_test.py (Failed)
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Robot Operating System team <ros>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge-info.txt
dev-ros:diagnostic_analysis-1.9.0:20170712-190317.log
emerge-history.txt
environment
etc.portage.tbz2
LastTest.log
logs.tbz2
temp.tbz2
tests.tbz2

Description Toralf Förster gentoo-dev 2017-07-12 19:21:34 UTC
The following tests FAILED:
	  1 - _ctest_diagnostic_analysis_nosetests_test.bag_csv_test.py (Failed)
Errors while running CTest
 * ERROR: dev-ros/diagnostic_analysis-1.9.0::gentoo failed (test phase):
 *   Tests failed. When you file a bug, please attach the following file: 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0_20170706-210712

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python3.5 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
  [2]   ruby22 (with Rubygems)
Comment 1 Toralf Förster gentoo-dev 2017-07-12 19:21:37 UTC
Created attachment 483668 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-07-12 19:21:40 UTC
Created attachment 483670 [details]
dev-ros:diagnostic_analysis-1.9.0:20170712-190317.log
Comment 3 Toralf Förster gentoo-dev 2017-07-12 19:21:43 UTC
Created attachment 483672 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-07-12 19:21:46 UTC
Created attachment 483674 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-07-12 19:21:49 UTC
Created attachment 483676 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-07-12 19:21:52 UTC
Created attachment 483678 [details]
LastTest.log
Comment 7 Toralf Förster gentoo-dev 2017-07-12 19:21:55 UTC
Created attachment 483680 [details]
logs.tbz2
Comment 8 Toralf Förster gentoo-dev 2017-07-12 19:21:58 UTC
*** Bug 624324 has been marked as a duplicate of this bug. ***
Comment 9 Toralf Förster gentoo-dev 2017-07-12 19:21:58 UTC
Created attachment 483682 [details]
temp.tbz2
Comment 10 Toralf Förster gentoo-dev 2017-07-12 19:22:01 UTC
Created attachment 483684 [details]
tests.tbz2
Comment 11 Larry the Git Cow gentoo-dev 2020-08-07 15:52:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e90859179e9931e27a259a6674d336b31cee84c3

commit e90859179e9931e27a259a6674d336b31cee84c3
Author:     Alexis Ballier <aballier@gentoo.org>
AuthorDate: 2020-08-07 15:42:15 +0000
Commit:     Alexis Ballier <aballier@gentoo.org>
CommitDate: 2020-08-07 15:52:23 +0000

    dev-ros/diagnostic_analysis: fix tests
    
    Closes: https://bugs.gentoo.org/624774
    Package-Manager: Portage-3.0.1, Repoman-2.3.23
    Signed-off-by: Alexis Ballier <aballier@gentoo.org>

 dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild | 5 +++++
 dev-ros/diagnostic_analysis/diagnostic_analysis-9999.ebuild  | 5 +++++
 2 files changed, 10 insertions(+)