Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 622644 (kde-apps-17.04.3)

Summary: KDE Applications 17.04 stabilisation
Product: Gentoo Linux Reporter: Andreas Sturmlechner <asturm>
Component: StabilizationAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: flyser42, gentoo, itumaykin+gentoo, kroemmelbein, paolo.pedroni
Priority: Normal Keywords: STABLEREQ
Version: unspecifiedFlags: stable-bot: sanity-check+
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
kde-apps/akonadi-17.04.3-r1 kde-apps/akonadi-calendar-17.04.3 kde-apps/akonadiconsole-17.04.3 kde-apps/akonadi-contacts-17.04.3 kde-apps/akonadi-import-wizard-17.04.3 kde-apps/akonadi-mime-17.04.3 kde-apps/akonadi-notes-17.04.3 kde-apps/akonadi-search-17.04.3 kde-apps/akregator-17.04.3 kde-apps/analitza-17.04.3 kde-apps/ark-17.04.3 kde-apps/artikulate-17.04.3 kde-apps/audiocd-kio-17.04.3 kde-apps/baloo-widgets-17.04.3 kde-apps/blinken-17.04.3 kde-apps/blogilo-17.04.3 kde-apps/bomber-17.04.3 kde-apps/bovo-17.04.3 kde-apps/calendarjanitor-17.04.3 kde-apps/calendarsupport-17.04.3 kde-apps/cantor-17.04.3 kde-apps/cervisia-17.04.3 kde-apps/dolphin-17.04.3 kde-apps/dolphin-plugins-17.04.3 kde-apps/dragon-17.04.3 kde-apps/eventviews-17.04.3 kde-apps/ffmpegthumbs-17.04.3 kde-apps/filelight-17.04.3 kde-apps/granatier-17.04.3 kde-apps/grantlee-editor-17.04.3 kde-apps/grantleetheme-17.04.3 kde-apps/gwenview-17.04.3 kde-apps/incidenceeditor-17.04.3 kde-apps/jovie-17.04.3 kde-apps/juk-17.04.3 kde-apps/k3b-17.04.3-r1 kde-apps/kaccessible-17.04.3 kde-apps/kaccounts-integration-17.04.3 kde-apps/kaccounts-providers-17.04.3 kde-apps/kaddressbook-17.04.3 kde-apps/kalarm-17.04.3 kde-apps/kalarmcal-17.04.3 kde-apps/kalgebra-17.04.3 kde-apps/kalzium-17.04.3 kde-apps/kamera-17.04.3 kde-apps/kanagram-17.04.3 kde-apps/kapman-17.04.3 kde-apps/kapptemplate-17.04.3 kde-apps/kate-17.04.3 kde-apps/katomic-17.04.3 kde-apps/kblackbox-17.04.3 kde-apps/kblocks-17.04.3 kde-apps/kblog-17.04.3 kde-apps/kbounce-17.04.3 kde-apps/kbreakout-17.04.3 kde-apps/kbruch-17.04.3 kde-apps/kcachegrind-17.04.3 kde-apps/kcalc-17.04.3 kde-apps/kcalcore-17.04.3 kde-apps/kcalutils-17.04.3 kde-apps/kcharselect-17.04.3 kde-apps/kcolorchooser-17.04.3 kde-apps/kcontacts-17.04.3 kde-apps/kcron-17.04.3 kde-apps/kdav-17.04.3 kde-apps/kde4-l10n-17.04.3 kde-apps/kdeaccessibility-meta-17.04.3 kde-apps/kdeadmin-meta-17.04.3 kde-apps/kde-apps-meta-17.04.3 kde-apps/kdebase-meta-17.04.3 kde-apps/kdebugsettings-17.04.3 kde-apps/kdecore-meta-17.04.3 kde-apps/kde-dev-scripts-17.04.3 kde-apps/kde-dev-utils-17.04.3 kde-apps/kdeedu-data-17.04.3 kde-apps/kdeedu-meta-17.04.3 kde-apps/kdegames-meta-17.04.3 kde-apps/kdegraphics-meta-17.04.3-r1 kde-apps/kdegraphics-mobipocket-17.04.3 kde-apps/kde-meta-17.04.3 kde-apps/kdemultimedia-meta-17.04.3 kde-apps/kdenetwork-filesharing-17.04.3 kde-apps/kdenetwork-meta-17.04.3 kde-apps/kdenlive-17.04.3 kde-apps/kdepim-addons-17.04.3 kde-apps/kdepim-apps-libs-17.04.3 kde-apps/kdepim-meta-17.04.3 kde-apps/kdepim-runtime-17.04.3 kde-apps/kdesdk-kioslaves-17.04.3 kde-apps/kdesdk-meta-17.04.3 kde-apps/kdesdk-thumbnailers-17.04.3 kde-apps/kdeutils-meta-17.04.3 kde-apps/kdewebdev-meta-17.04.3 kde-apps/kdf-17.04.3 kde-apps/kdialog-17.04.3 kde-apps/kdiamond-17.04.3 kde-apps/keditbookmarks-17.04.3 kde-apps/kfilereplace-17.04.3 kde-apps/kfind-17.04.3 kde-apps/kfloppy-17.04.3 kde-apps/kfourinline-17.04.3 kde-apps/kgeography-17.04.3 kde-apps/kget-17.04.3 kde-apps/kgoldrunner-17.04.3 kde-apps/kgpg-17.04.3 kde-apps/khangman-17.04.3 kde-apps/khelpcenter-17.04.3 kde-apps/kholidays-17.04.3 kde-apps/kidentitymanagement-17.04.3 kde-apps/kig-17.04.3 kde-apps/kigo-17.04.3 kde-apps/killbots-17.04.3 kde-apps/kimagemapeditor-17.04.3 kde-apps/kimap-17.04.3 kde-apps/kio-extras-17.04.3 kde-apps/kiriki-17.04.3 kde-apps/kiten-17.04.3 kde-apps/kjumpingcube-17.04.3 kde-apps/kldap-17.04.3 kde-apps/kleopatra-17.04.3 kde-apps/klettres-17.04.3 kde-apps/klickety-17.04.3 kde-apps/klines-17.04.3 kde-apps/klinkstatus-17.04.3 kde-apps/kmag-17.04.3 kde-apps/kmahjongg-17.04.3 kde-apps/kmail-17.04.3 kde-apps/kmail-account-wizard-17.04.3 kde-apps/kmailtransport-17.04.3 kde-apps/kmbox-17.04.3 kde-apps/kmime-17.04.3 kde-apps/kmines-17.04.3 kde-apps/kmix-17.04.3 kde-apps/kmousetool-17.04.3 kde-apps/kmouth-17.04.3 kde-apps/kmplot-17.04.3 kde-apps/knavalbattle-17.04.3 kde-apps/knetwalk-17.04.3 kde-apps/knotes-17.04.3 kde-apps/kolf-17.04.3 kde-apps/kollision-17.04.3 kde-apps/kolourpaint-17.04.3 kde-apps/kompare-17.04.3 kde-apps/konqueror-17.04.3 kde-apps/konquest-17.04.3 kde-apps/konsole-17.04.3 kde-apps/konsolekalendar-17.04.3 kde-apps/kontact-17.04.3 kde-apps/kontactinterface-17.04.3 kde-apps/kopete-17.04.3 kde-apps/korganizer-17.04.3 kde-apps/kpat-17.04.3 kde-apps/kpimtextedit-17.04.3 kde-apps/kppp-17.04.3 kde-apps/kqtquickcharts-17.04.3 kde-apps/krdc-17.04.3 kde-apps/kremotecontrol-17.04.3 kde-apps/kreversi-17.04.3 kde-apps/krfb-17.04.3 kde-apps/kross-interpreters-17.04.3 kde-apps/kruler-17.04.3 kde-apps/kscd-17.04.3 kde-apps/kshisen-17.04.3 kde-apps/ksirk-17.04.3 kde-apps/ksnakeduel-17.04.3 kde-apps/kspaceduel-17.04.3 kde-apps/ksquares-17.04.3 kde-apps/kstars-17.04.3 kde-apps/ksudoku-17.04.3-r1 kde-apps/ksystemlog-17.04.3 kde-apps/kteatime-17.04.3 kde-apps/ktimer-17.04.3 kde-apps/ktouch-17.04.3 kde-apps/ktp-accounts-kcm-17.04.3 kde-apps/ktp-approver-17.04.3 kde-apps/ktp-auth-handler-17.04.3 kde-apps/ktp-call-ui-17.04.3 kde-apps/ktp-common-internals-17.04.3 kde-apps/ktp-contact-list-17.04.3 kde-apps/ktp-contact-runner-17.04.3 kde-apps/ktp-desktop-applets-17.04.3 kde-apps/ktp-filetransfer-handler-17.04.3 kde-apps/ktp-kded-module-17.04.3 kde-apps/ktp-send-file-17.04.3 kde-apps/ktp-text-ui-17.04.3 kde-apps/ktuberling-17.04.3 kde-apps/kturtle-17.04.3 kde-apps/kubrick-17.04.3 kde-apps/kwalletmanager-17.04.3 kde-apps/kwave-17.04.3 kde-apps/kwordquiz-17.04.3 kde-apps/kwrite-17.04.3 kde-apps/libgravatar-17.04.3 kde-apps/libkcddb-17.04.3 kde-apps/libkcompactdisc-17.04.3 kde-apps/libkdcraw-17.04.3 kde-apps/libkdegames-17.04.3 kde-apps/libkdepim-17.04.3 kde-apps/libkeduvocdocument-17.04.3 kde-apps/libkexiv2-17.04.3 kde-apps/libkface-17.04.3 kde-apps/libkgapi-17.04.3 kde-apps/libkgeomap-17.04.3 kde-apps/libkipi-17.04.3 kde-apps/libkleo-17.04.3 kde-apps/libkmahjongg-17.04.3 kde-apps/libkomparediff2-17.04.3 kde-apps/libksane-17.04.3 kde-apps/libksieve-17.04.3 kde-apps/libktnef-17.04.3 kde-apps/lokalize-17.04.3 kde-apps/lskat-17.04.3 kde-apps/mailcommon-17.04.3 kde-apps/mailimporter-17.04.3 kde-apps/marble-17.04.3 kde-apps/mbox-importer-17.04.3 kde-apps/messagelib-17.04.3 kde-apps/minuet-17.04.3 kde-apps/okteta-17.04.3 kde-apps/okular-17.04.3 kde-apps/palapeli-17.04.3 kde-apps/parley-17.04.3 kde-apps/picmi-17.04.3 kde-apps/pimcommon-17.04.3-r1 kde-apps/pim-data-exporter-17.04.3 kde-apps/pim-sieve-editor-17.04.3 kde-apps/plasma-telepathy-meta-17.04.3 kde-apps/poxml-17.04.3 kde-apps/print-manager-17.04.3 kde-apps/rocs-17.04.3 kde-apps/signon-kwallet-extension-17.04.3 kde-apps/spectacle-17.04.3 kde-apps/step-17.04.3 kde-apps/svgpart-17.04.3 kde-apps/sweeper-17.04.3 kde-apps/syndication-17.04.3 kde-apps/thumbnailers-17.04.3 kde-apps/umbrello-17.04.3 kde-apps/zeroconf-ioslave-17.04.3
Runtime testing required: ---
Bug Depends on: 620334, 622648, 624912, 625920, 625922    
Bug Blocks: 485244, 621550, 621552, 621556, 622592, 623588, 623592    
Attachments:
Description Flags
KDE Applications 17.04.3.tar.gz
none
kdeapps1704.tar.gz
none
kdeapps1704.LastTest.Log.tar.gz none

Description Andreas Sturmlechner gentoo-dev 2017-06-24 20:48:29 UTC
Let's try this time with KDE PIM included. In preparation.
Comment 1 Andreas Sturmlechner gentoo-dev 2017-07-22 01:09:33 UTC
Frank, if you want to test, go ahead please :)

Stabilisation list is not quite set in stone, I'll rather drop kajongg:5 before python-3.5 is blocking us forever.
Comment 2 Frank Krömmelbein 2017-07-25 15:03:41 UTC
Hello Andreas,

the first issues:

1) app-office/kmymoney with useflag pim enabled, has a dependency for kdepimlibs, from kmymoney ebuild:

        pim? ( $(add_kdeapps_dep kdepimlibs) )

This creates an irresolvable conflict between the old KDE PIM and the new. 


2) kde-apps/kde4-l10n-17.04.3 numerous file collisions, please see folder 2 in the attached archiv file.
As a workaround i removed the installed 16.12.3-r1 version to continue.


3) kwave with useflag handbook enabled fails with a very strange error in configure phase see folder 3 in the archiv. As a workaround i installed without handbook useflag to continue.

[ebuild     U ~] kde-apps/kwave-17.04.3:5::gentoo [16.12.3:5::gentoo] USE="alsa flac handbook mp3 qtmedia vorbis -debug -opus -oss -pulseaudio" 0 KiB
update fails 


Except for these 3 points, the update has passed. 
I will start tomorrow then the time-consuming test run with app-portage/tatt.
Let's see what surprises then will show up. ;-)
Comment 3 Frank Krömmelbein 2017-07-25 15:04:22 UTC
Created attachment 486806 [details]
KDE Applications 17.04.3.tar.gz
Comment 4 Frank Krömmelbein 2017-07-25 16:03:45 UTC
4) More kdepimlibs related issues, same as 1) 

app-office/kraft-0.59 no slot 5 version available, last rite or add snapshot release?
kde-misc/basket-1.81, slot 5 snapshot version 2.49a_p20170225 available, needs then stabilization
kde-misc/akonadi-git-resource-0_p20131023 no slot 5 version available, last rite?
app-accessibility/simon-0.4.1 useflag pim, drop useflag?
Comment 5 Andreas Sturmlechner gentoo-dev 2017-07-25 16:05:12 UTC
(In reply to Frank Krömmelbein from comment #2)
> 1) app-office/kmymoney with useflag pim enabled, has a dependency for
> kdepimlibs, from kmymoney ebuild:
Nothing we can do there (same for other pim conflicts). People will need to choose.

(In reply to Frank Krömmelbein from comment #2)
> 2) kde-apps/kde4-l10n-17.04.3 numerous file collisions, please see folder 2
> in the attached archiv file.
Thanks, fixed again (blocker was lost during eclass migration).
Comment 6 Frank Krömmelbein 2017-07-29 18:27:52 UTC
Created attachment 487210 [details]
kdeapps1704.tar.gz
Comment 7 Frank Krömmelbein 2017-07-29 18:47:53 UTC
So here is the additional delivery:

1) FEATURES= test failed for =kde-apps/analitza-17.04.3

2) FEATURES= test failed for =kde-apps/k3b-17.04.3
known for 17.04.0 see https://bugs.gentoo.org/show_bug.cgi?id=616880

3) FEATURES= test failed for =kde-apps/kdepim-apps-libs-17.04.3

4) FEATURES= test failed for =kde-apps/mailimporter-17.04.3

5) FEATURES= test failed for =kde-apps/okteta-17.04.3

6) FEATURES= test failed for =kde-apps/umbrello-17.04.3

7) FEATURES= test failed for =kde-apps/kmail-17.04.3
Note: Test aborted after >10 minutes, seems to be an endless loop.

For all logs please see kdeapps1704.tar.gz.


8) kde-apps/klinkstatus-17.04.3 requires old KDE PIM? Test skipped.
[ebuild  N     ] dev-libs/qjson-0.8.1-r1  USE="{test} -debug -doc" ABI_X86="(64) -32 (-x32)" 
[ebuild  NS    ] kde-apps/akonadi-1.13.1_pre20160203-r1 [17.04.3] USE="mysql sqlite -postgres {-test}" 
[ebuild  N     ] kde-apps/kdepimlibs-4.14.11_pre20160611  USE="handbook ldap (-aqua) -debug -prison {-test}" 
[ebuild  N    ~] kde-apps/klinkstatus-17.04.3  USE="handbook (-aqua) -debug -tidy" 
[blocks B      ] kde-apps/kdepimlibs:4 ("kde-apps/kdepimlibs:4" is blocking kde-apps/kmailtransport-17.04.3, kde-apps/akonadi-mime-17.04.3)
[blocks B      ] kde-apps/kdepimlibs ("kde-apps/kdepimlibs" is blocking kde-apps/akonadi-17.04.3)
[blocks B      ] kde-apps/akonadi:4 ("kde-apps/akonadi:4" is blocking kde-apps/akonadi-17.04.3)

9) kde-apps/kopete-17.04.3 requires old KDE PIM? Test skipped.
[ebuild  N     ] dev-libs/qjson-0.8.1-r1::gentoo  USE="-debug -doc {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] media-libs/qimageblitz-0.0.6-r2::gentoo  USE="(-altivec) -debug" CPU_FLAGS_X86="mmx sse sse2 -3dnow" 0 KiB
[ebuild  NS    ] kde-apps/akonadi-1.13.1_pre20160203-r1:4::gentoo [17.04.3:5::gentoo] USE="mysql sqlite -postgres {-test}" 0 KiB
[ebuild  N     ] kde-apps/kdepimlibs-4.14.11_pre20160611:4/4.14::gentoo  USE="handbook ldap (-aqua) -debug -prison {-test}" 0 KiB
[ebuild  N    ~] kde-apps/kopete-17.04.3:4/17.04::gentoo  USE="addbookmarks autoreplace contactnotes handbook highlight history nowlistening pipes privacy ssl statistics texteffect translator urlpicpreview v4l xmpp (-aqua) -cryptography -debug -gadu -groupwise -jingle -latex -meanwhile -oscar -otr -skype -testbed -webpresence -winpopup -yahoo -zeroconf" 0 KiB
[blocks B      ] kde-apps/akonadi:4 ("kde-apps/akonadi:4" is blocking kde-apps/akonadi-17.04.3)
[blocks B      ] kde-apps/kdepimlibs:4 ("kde-apps/kdepimlibs:4" is blocking kde-apps/akonadi-mime-17.04.3, kde-apps/kmailtransport-17.04.3)
[blocks B      ] kde-apps/kdepimlibs ("kde-apps/kdepimlibs" is blocking kde-apps/akonadi-17.04.3)

10)
kde-apps/kajongg-17.04.3 & kdegames-meta-17.04.3 with useflag python both test skipped because of Python 3.5 issue.

I have filtered out anything related with +systemd, +libav, +gles2 useflags.
Also filtered out all issues which are covered by package.use.mask.
Comment 8 Andreas Sturmlechner gentoo-dev 2017-07-29 18:56:14 UTC
Thanks for your time.

9) kopete is not pulled in by the meta packages so we're fine. Let's hope they finish porting for 17.12...
Comment 9 Andreas Sturmlechner gentoo-dev 2017-08-02 23:53:23 UTC
(In reply to Frank Krömmelbein from comment #2)
> 3) kwave with useflag handbook enabled fails with a very strange error in
> configure phase see folder 3 in the archiv. As a workaround i installed
> without handbook useflag to continue.

That one is a bit puzzling, because the ebuild correctly depends on virtual/imagemagic-tools[png,svg] - do you have image- or graphicsmagick installed?
Comment 10 Frank Krömmelbein 2017-08-03 09:19:34 UTC
(In reply to Andreas Sturmlechner from comment #9)
> (In reply to Frank Krömmelbein from comment #2)
> > 3) kwave with useflag handbook enabled fails with a very strange error in
> > configure phase see folder 3 in the archiv. As a workaround i installed
> > without handbook useflag to continue.
> 
> That one is a bit puzzling, because the ebuild correctly depends on
> virtual/imagemagic-tools[png,svg] - do you have image- or graphicsmagick
> installed?

graphicsmagick - not installed
imagemagick - installed
[ebuild   R    ] virtual/imagemagick-tools-0::gentoo  USE="jpeg png svg tiff -perl" 0 KiB


Funy but the error is no longer reproducible after the latest stable updates including of some deps:

[ebuild     U  ] gnome-base/librsvg-2.40.18:2::gentoo [2.40.17:2::gentoo] USE="introspection -tools -vala" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  r  U  ] media-gfx/imagemagick-6.9.9.0:0/6.9.9.0::gentoo [6.9.8.6:0/6.9.8.6::gentoo] USE="X bzip2 corefonts cxx djvu jpeg jpeg2k lcms lzma openexr openmp pango png postscript raw svg tiff truetype webp wmf xml zlib -fftw -fontconfig -fpx -graphviz -hdri -jbig -lqr (-opencl) -perl -q32 -q8 -static-libs {-test}" 0 KiB

So i would say issue is fixed.
Comment 11 Andreas Sturmlechner gentoo-dev 2017-08-03 18:38:58 UTC
For test failure submissions, LastTest.Log would contain vital information. e.g. I can't reproduce several of the test failures and then depend on more details in the actual test logs.

Btw, kde-apps/kalzium[solver] was unmasked.
Comment 12 Frank Krömmelbein 2017-08-04 07:59:55 UTC
Created attachment 487892 [details]
kdeapps1704.LastTest.Log.tar.gz

Added the requested LastTest.Log files.
Comment 13 Andreas Sturmlechner gentoo-dev 2017-08-05 06:45:26 UTC
Hmmm all these test failures are 'QXcbConnection: Could not connect to display :1' but the ebuilds do correctly set VIRTUALX_REQUIRED="test"...
Comment 14 Andreas Sturmlechner gentoo-dev 2017-08-06 09:52:14 UTC
(In reply to Frank Krömmelbein from comment #7)
> So here is the additional delivery:
> 
> 1) FEATURES= test failed for =kde-apps/analitza-17.04.3
> 3) FEATURES= test failed for =kde-apps/kdepim-apps-libs-17.04.3
> 4) FEATURES= test failed for =kde-apps/mailimporter-17.04.3
> 5) FEATURES= test failed for =kde-apps/okteta-17.04.3
> 6) FEATURES= test failed for =kde-apps/umbrello-17.04.3

Paolo, you have submitted many test failures in the past, can you confirm any of the above? Or do you remember how you fixed similar local issues despite having x11-apps/xhost installed?
Comment 15 Andreas Sturmlechner gentoo-dev 2017-08-06 13:06:08 UTC
-kde-apps/kajongg-17.04.3
-kde-apps/k3b-17.04.3
-kde-apps/pimcommon-17.04.3
+kde-apps/k3b-17.04.3-r2
+kde-apps/pimcommon-17.04.3-r1
Comment 16 Paolo Pedroni 2017-08-07 15:31:58 UTC
(In reply to Andreas Sturmlechner from comment #14)
> (In reply to Frank Krömmelbein from comment #7)
> > So here is the additional delivery:
> > 
> > 1) FEATURES= test failed for =kde-apps/analitza-17.04.3
> > 3) FEATURES= test failed for =kde-apps/kdepim-apps-libs-17.04.3
> > 4) FEATURES= test failed for =kde-apps/mailimporter-17.04.3
> > 5) FEATURES= test failed for =kde-apps/okteta-17.04.3
> > 6) FEATURES= test failed for =kde-apps/umbrello-17.04.3
> 
> Paolo, you have submitted many test failures in the past, can you confirm
> any of the above? Or do you remember how you fixed similar local issues
> despite having x11-apps/xhost installed?

Not yet tried to install them. Just came back from holidays. Give me a few days to catch up.
Comment 17 Andreas Sturmlechner gentoo-dev 2017-08-12 12:38:59 UTC
-kde-apps/k3b-17.04.3-r2
-kde-apps/kdegraphics-meta-17.04.3
-kde-apps/ksaneplugin-17.04.3
+kde-apps/k3b-17.04.3-r1
+kde-apps/kdegraphics-meta-17.04.3-r1

Reverted k3b because of issues with the patch. Dropped ksaneplugin for soon to be expected last-rites.
Comment 18 Stabilization helper bot gentoo-dev 2017-08-12 15:35:04 UTC
An automated check of this bug failed - repoman reported dependency errors (7 lines truncated): 

> dependency.bad kde-apps/kleopatra/kleopatra-17.04.3.ebuild: RDEPEND: x86(default/linux/x86/13.0) ['app-crypt/paperkey']
> dependency.bad kde-apps/kleopatra/kleopatra-17.04.3.ebuild: RDEPEND: x86(default/linux/x86/13.0/desktop) ['app-crypt/paperkey']
> dependency.bad kde-apps/kleopatra/kleopatra-17.04.3.ebuild: RDEPEND: x86(default/linux/x86/13.0/desktop/gnome) ['app-crypt/paperkey']
Comment 19 Paolo Pedroni 2017-08-17 09:17:27 UTC
(In reply to Andreas Sturmlechner from comment #14)
> (In reply to Frank Krömmelbein from comment #7)
> > So here is the additional delivery:
> > 
> > 1) FEATURES= test failed for =kde-apps/analitza-17.04.3
> > 3) FEATURES= test failed for =kde-apps/kdepim-apps-libs-17.04.3
> > 4) FEATURES= test failed for =kde-apps/mailimporter-17.04.3
> > 5) FEATURES= test failed for =kde-apps/okteta-17.04.3
> > 6) FEATURES= test failed for =kde-apps/umbrello-17.04.3
> 
> Paolo, you have submitted many test failures in the past, can you confirm
> any of the above? Or do you remember how you fixed similar local issues
> despite having x11-apps/xhost installed?

kdepim-apps-libs-17.04.3, mailimporter-17.04.3, okteta-17.04.3 work fine for me.

analitza and umbrello are not installed on my system. Will try and check in a few hours.
Comment 20 Paolo Pedroni 2017-08-17 09:28:40 UTC
Even kde-apps/analitza-17.04.3 and kde-apps/umbrello-17.04.3 test fine for me.
Comment 21 Andreas Sturmlechner gentoo-dev 2017-08-17 11:36:50 UTC
Thanks for the follow-up!
Comment 22 Michael Palimaka (kensington) gentoo-dev 2017-08-17 14:11:51 UTC
amd64/x86 stable