Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 621168

Summary: dev-util/kdevelop-5.1.0 crashes on saving files
Product: Gentoo Linux Reporter: Plüss Roland <roland>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Status: RESOLVED TEST-REQUEST    
Severity: major CC: jstein
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Plüss Roland 2017-06-07 21:28:38 UTC
kdevelop-5.1.0 crashes always saving files with a backtrace similar to this one:

Thread 1 (Thread 0x7fc37869a780 (LWP 17867)):
[KCrash Handler]
#6  0x00007fc377f54680 in QStandardItem::rowCount() const () from /usr/lib64/libQt5Gui.so.5
#7  0x00007fc374556e83 in KDevelop::VcsFileChangesModel::fileItemForUrl(QStandardItem*, QUrl const&) const () from /usr/lib64/libKDevPlatformVcs.so.10
#8  0x00007fc374557336 in KDevelop::VcsFileChangesModel::updateState(QStandardItem*, KDevelop::VcsStatusInfo const&) () from /usr/lib64/libKDevPlatformVcs.so.10
#9  0x00007fc3747adb7a in KDevelop::ProjectChangesModel::statusReady(KJob*) () from /usr/lib64/libKDevPlatformProject.so.10
#10 0x00007fc3779462cf in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQt5Core.so.5
#11 0x00007fc3786ded1f in KJob::finished(KJob*, KJob::QPrivateSignal) () from /usr/lib64/libKF5CoreAddons.so.5
#12 0x00007fc3786e07a0 in KJob::finishJob(bool) () from /usr/lib64/libKF5CoreAddons.so.5
#13 0x00007fc30437e6b0 in SvnJobBase::internalJobDone() () from /usr/lib64/qt5/plugins/kdevplatform/27/kdevsubversion.so
#14 0x00007fc37794707a in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#15 0x00007fc37819b314 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#16 0x00007fc3781a08a7 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#17 0x00007fc37791e241 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#18 0x00007fc37792024b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQt5Core.so.5
#19 0x00007fc37796d753 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/libQt5Core.so.5
#20 0x00007fc36ef4c764 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fc36ef4ca45 in g_main_context_iterate.isra () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fc36ef4cb04 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fc37796d7cf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#24 0x00007fc37791d082 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#25 0x00007fc377924b24 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#26 0x000000000040bb85 in main ()

Previous version did not crash. Update to this version crashes.
Comment 1 Plüss Roland 2017-06-08 11:06:42 UTC
It is related to Subversion. If the subversion plugin is disabled the problems stop. I tried so far re-merging kdevelop, kdevelopplatform and subversion but the problem persists.
Comment 2 Plüss Roland 2017-06-08 11:24:07 UTC
Narrowed down the problem. It happens with subversion plugin enabled for projects set to use makefiles. It does not happen if subversion plugin is enabled but project type is custom.
Comment 3 Plüss Roland 2017-06-08 11:30:13 UTC
(In reply to Plüss Roland from comment #2)
> Narrowed down the problem. It happens with subversion plugin enabled for
> projects set to use makefiles. It does not happen if subversion plugin is
> enabled but project type is custom.

Wrong alert... I found a custom build system project which still crashes with subversion plugin enabled. Seems to be related to some other factor triggering this behavior. Maybe project files originally created with an older kdevelop version?
Comment 4 Andreas Sturmlechner gentoo-dev 2017-06-08 18:21:58 UTC
Please try with 5.1.1 which was bumped a few days ago.
Comment 5 Plüss Roland 2017-06-09 13:46:39 UTC
(In reply to Andreas Sturmlechner from comment #4)
> Please try with 5.1.1 which was bumped a few days ago.
It's showing the exact same crash behavior.
Comment 6 Andreas Sturmlechner gentoo-dev 2017-06-24 19:21:03 UTC
(In reply to Plüss Roland from comment #0)
> Previous version did not crash. Update to this version crashes.

Is that a regression over kdevelop-4 or kdevelop-5.0.x?
Comment 7 Plüss Roland 2017-06-25 09:36:31 UTC
(In reply to Andreas Sturmlechner from comment #6)
> (In reply to Plüss Roland from comment #0)
> > Previous version did not crash. Update to this version crashes.
> 
> Is that a regression over kdevelop-4 or kdevelop-5.0.x?
It's of 5.1.0 over the previous version. The exact version I can't tell since portage dev-util/kdevelop only shows 5.1.0 and 5.1.1 and both show the bug.
Comment 8 Johannes Huber gentoo-dev 2017-09-07 20:59:32 UTC
Mask subversion use flag?
Comment 9 Andreas Sturmlechner gentoo-dev 2017-09-09 12:00:40 UTC
Was an upstream bug raised that we can track?
Comment 10 Maciej Mrozowski gentoo-dev 2018-05-23 00:35:55 UTC
Can you still reproduce it with more modern 5.2.1 or 5.2.3?