Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 620826

Summary: <app-misc/anki-2.1 depends on dev-qt/qtwebkit:4 via dev-python/PyQt4[webkit]
Product: Gentoo Linux Reporter: Andreas Sturmlechner <asturm>
Component: Current packagesAssignee: Patrick Lauer <patrick>
Status: RESOLVED WONTFIX    
Severity: normal CC: carlphilippreh, hanno, jakub.panachida, mail, mlen
Priority: Normal Keywords: PMASKED
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://apps.ankiweb.net/docs/beta.html
See Also: https://bugs.gentoo.org/show_bug.cgi?id=562976
https://bugs.gentoo.org/show_bug.cgi?id=649162
Whiteboard: Masked for removal on 2017-12-16
Package list:
Runtime testing required: ---
Bug Depends on: 625258    
Bug Blocks: 620684    
Attachments: anki start traceback "couldn't find web folder"

Description Andreas Sturmlechner gentoo-dev 2017-06-04 17:32:57 UTC
app-misc/anki depends on dev-qt/qtwebkit:4 which is ancient and will never see any security updates.

Apparently upstream master is already using PyQt 5.7+.
Comment 1 Gleb 2017-07-20 18:30:10 UTC
Anki 2.1.0 is now beta (but is not considered stable enough due to possible data loss according to the description), and supports modern library versions. Sadly Qt5.9 is required. [1]

[1]: https://apps.ankiweb.net/docs/beta.html
Comment 2 Andreas Sturmlechner gentoo-dev 2017-10-08 12:43:15 UTC
Qt-5.9.2 is now in tree.

(In reply to Gleb from comment #1)
> Anki 2.1.0 is now beta (but is not considered stable enough due to possible
> data loss according to the description)
"You can be fairly confident the beta will not eat your data. 2.1 has been in alpha status for the last year as we waited for toolkit issues to be resolved, and we have not had any reports of data loss during that time."
Comment 3 Andreas Sturmlechner gentoo-dev 2017-10-15 09:03:25 UTC
Masking of <app-misc/anki-2.1 is being prepared in order to proceed with Qt4WebKit removal.
Comment 4 Larry the Git Cow gentoo-dev 2017-11-16 18:55:40 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7e799631b67e2fc4dab217b90720b3ad7eeaa347

commit 7e799631b67e2fc4dab217b90720b3ad7eeaa347
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2017-11-16 18:52:49 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2017-11-16 18:55:11 +0000

    profiles: Initiate last-rites for Qt4WebKit and remaining rdeps
    
    Bug: https://bugs.gentoo.org/620684
    Bug: https://bugs.gentoo.org/620702
    Bug: https://bugs.gentoo.org/620736
    Bug: https://bugs.gentoo.org/620826

 profiles/package.mask | 30 +++++++++++++++++++-----------
 1 file changed, 19 insertions(+), 11 deletions(-)}
Comment 5 schmittlauch 2017-11-18 19:59:13 UTC
anki requires PyQt5 to be built with the use flags "webengine widgets webchannel":
After upgrading to app-misc/anki-2.1.0_beta25, anki fails to start with the following traceback:

$ anki
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.6/anki", line 6, in <module>
    import aqt
  File "/usr/lib64/python3.6/site-packages/aqt/__init__.py", line 14, in <module>
    from aqt.qt import *
  File "/usr/lib64/python3.6/site-packages/aqt/qt.py", line 17, in <module>
    from PyQt5.QtWebEngineWidgets import QWebEnginePage
ModuleNotFoundError: No module named 'PyQt5.QtWebEngineWidgets'

I wasn't able to test it so far though, as I'm still on Qt-5.7.1 while anki need 5.9
Comment 6 schmittlauch 2017-11-23 17:03:10 UTC
Having compiled Qt5.9 now, anki is still not starting, complaining that it "couldn't find web folder" It looks like some code may just not be ready for anki to be packaged?

I'll attach the traceback I immediately get after starting.
I also asked at the upstream support forum: https://anki.tenderapp.com/discussions/beta-testing/853-anki-210-beta-21#comment_44117668
Comment 7 schmittlauch 2017-11-23 17:04:11 UTC
Created attachment 505904 [details]
anki start traceback "couldn't find web folder"
Comment 8 Julian Gilbey 2017-11-23 22:13:29 UTC
I suggest you have a look at what I've done for the Debian package (which is only in unstable and blocked from transitioning due to the beta status of the software): https://packages.debian.org/sid/anki

You can see how I've packaged it, and the modifications I've made to ensure that it is compatible with the Debian Free Software Guidelines.  (In particular, I don't repackage MathJax and other pre-bundled minimised code; instead, I have modified the Anki source code to look on the system for this javascript code.)

Best wishes, and good luck with your version!

   Julian
Comment 9 Michael Weber (RETIRED) gentoo-dev 2017-12-18 12:41:00 UTC
(In reply to t.schmittlauch+gentoo from comment #5)
> anki requires PyQt5 to be built with the use flags "webengine widgets
> webchannel":
> After upgrading to app-misc/anki-2.1.0_beta25, anki fails to start with the
> following traceback:
> 
> $ anki
> Traceback (most recent call last):
>   File "/usr/lib/python-exec/python3.6/anki", line 6, in <module>
>     import aqt
>   File "/usr/lib64/python3.6/site-packages/aqt/__init__.py", line 14, in
> <module>
>     from aqt.qt import *
>   File "/usr/lib64/python3.6/site-packages/aqt/qt.py", line 17, in <module>
>     from PyQt5.QtWebEngineWidgets import QWebEnginePage
> ModuleNotFoundError: No module named 'PyQt5.QtWebEngineWidgets'
> 
> I wasn't able to test it so far though, as I'm still on Qt-5.7.1 while anki
> need 5.9

Please file new bugs for different issues.
This problem has been handled in bug 639354.
Comment 10 Michael Weber (RETIRED) gentoo-dev 2017-12-18 12:43:17 UTC
(In reply to t.schmittlauch+gentoo from comment #6)
> Having compiled Qt5.9 now, anki is still not starting, complaining that it
> "couldn't find web folder" It looks like some code may just not be ready for
> anki to be packaged?
> 
> I'll attach the traceback I immediately get after starting.
> I also asked at the upstream support forum:
> https://anki.tenderapp.com/discussions/beta-testing/853-anki-210-beta-
> 21#comment_44117668
This is an issue of installing the modules into site-package dirs and not running it directly from source folder. Not an issue of anki and has now been addressed in 2.1.0_beta25 and _beta27.
Comment 11 Andreas Sturmlechner gentoo-dev 2017-12-19 00:30:37 UTC
Old versions have been dropped in git commit c256849563d19e023385ef4cf9f55a550815359a.