Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 61876

Summary: KDE doesn't pass a Ctrl-Alt-Del through to the Citrix ICAClient.
Product: Gentoo Linux Reporter: Dustin Laurence <laurence>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Status: RESOLVED UPSTREAM    
Severity: minor    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Dustin Laurence 2004-08-26 19:17:59 UTC
When I kick up the Citrix ICAClient (wfcmgr) to log into a remote Windows machine, I need to be able to do a Ctrl-Alt-Del in the Citrix window and have it passed through to the Windows machine to get the login screen.  This works in Gnome, but KDE seems to intercept it and pop up an "End session for XXX (Logout/Cancel)" dialog box.

I assume this is probably some configuration issue with KDE, but could find no mention of the problem on the Web, fora, or bugzilla.  I thought for a while and decided it merited "bug" status because anyone who just tried it on KDE would probably only know that Citrix is unusable, and possibly it could be either flagged or the configuration automagically changed when ICAClient is emerged.

While I'm at it, is there any possibility of getting the latest version in portage, or is there not enough demand for it?


Reproducible: Always
Steps to Reproduce:
1. Start a KDE session.
2. Start a Citrix connection to a remote MS-Windows machine set to require a Ctrl-Alt-Del three-finger salute before login.
3. At the MS-Windows start-up screen, salute as requested.

Actual Results:  
A "helpful" dialog box appears asking for confirmation, as described above. 
It's clearly a KDE dialog, with the KDE button style I have set.


Expected Results:  
The remote windows machine should receive the Ctrl-Alt-Del event and pop up the
login dialog.  This is what happens under Gnome, for example, so there is no
problem with the setup or the remote server.


Hmm, Israel just won their first Olympic Gold ever? :-)

Seriously, the above works as described every single time for me.  I don't know
whether I should rate it Normal or Minor--a KDE user with a well-configured
desktop probably wouldn't think to try another WM and would certainly not think
it was "minor" if they had to do this on a regular basis.  The loss of function
on KDE is total, because there is no other way (AFAIK) to log in remotely, which
is pretty much what Citrix is for.  OTOH, I suppose it is an "easy workaround."

My suggestion is that the ebuild make whatever configuration change to KDE
automagically if KDE is installed, or if that is impossible/undesirable it could
just print out a warning and describe the solution (or at the bare minimum,
suggest another WM to save some poor soul the confusion).

Dustin
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2004-08-27 05:39:05 UTC
You need to file this at bugs.kde.org.

Also, by your request for the "latest version", what do you mean?  KDE or the Citrix client?
Comment 2 Dustin Laurence 2004-08-27 07:41:13 UTC
OK, I'll pass it upstream.  I filed it here first because I thought that Gentoo preferred to make that decision, but maybe not.  Also, while the bug exists it would be nice to at least have a warning in the ebuild, as I suggested, for those people who don't think to try another WM.  Assuming anyone else is actually using this package besides me....

By "latest version" I meant the Citrix client.  The version in portage is 7.0, the current download on the Citrix site is 8.0.  A test manual install seemed to work OK, but for now I'm using the portage version.  Yes, I know, I should find a little time and learn to write the ebuild myself.
Comment 3 Mitchell 2004-08-28 18:26:45 UTC
This can be acheived two ways independent of the window/desktop manager.  The first is that the Citrix ICA client allows a shortcut to be configured that will allow you to open the Ctrl-Alt-Del dialog box.  If I remember correctly, that hotkey is alt+f1 or alt+f2.  You can always change it if you go into icaclient and change the setting.

The other way allows you to call Windows Security from the server, which is the formal name for the Ctrl-Alt-Del.  If you are using the "Classic" start menu, it is in to Start > Control Panel, if you are using the one introduced with XP, it is on the right side called Windows Security with an icon of a padlock next to it.
Comment 4 Caleb Tennis (RETIRED) gentoo-dev 2004-12-06 19:45:42 UTC
Closing as UPSTREAM