Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 617896

Summary: dev-qt/qtwebengine-5.7.1-r1 with GCC 7: error: ‘mojo::ScopedMessagePipeHandle {aka class mojo::ScopedHandleBase<mojo::MessagePipeHandle>}’ has no member named ‘Pass’
Product: Gentoo Linux Reporter: fhede <fhede71>
Component: Current packagesAssignee: Qt Bug Alias <qt>
Status: RESOLVED FIXED    
Severity: normal CC: hendrik, jrmalaq, mail, mitaspiotr, orodruinlair, regboxemg
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: All   
See Also: https://bugreports.qt.io/browse/QTBUG-59776
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 617524    
Attachments: qtwebengine-5.7.1-gcc-7-p1.patch
qtwebengine-5.7.1-gcc-7-p2.patch

Description fhede 2017-05-08 21:20:07 UTC
I got this build error with gcc 7.1.0

ninja: build stopped: subcommand failed.
make[3]: *** [Makefile.gyp_run:306: invoke_ninja] Error 1
make[3]: Leaving directory '/var/tmp/portage/dev-qt/qtwebengine-5.7.1-r1/work/qtwebengine-opensource-src-5.7.1/src/core'
make[2]: *** [Makefile:116: sub-gyp_run-pro-make_first] Error 2
make[2]: Leaving directory '/var/tmp/portage/dev-qt/qtwebengine-5.7.1-r1/work/qtwebengine-opensource-src-5.7.1/src/core'
make[1]: *** [Makefile:50: sub-core-make_first] Error 2
make[1]: Leaving directory '/var/tmp/portage/dev-qt/qtwebengine-5.7.1-r1/work/qtwebengine-opensource-src-5.7.1/src'
make: *** [Makefile:45: sub-src-make_first] Error 2
 [31;01m*[0m ERROR: dev-qt/qtwebengine-5.7.1-r1::gentoo failed (compile phase):
 [31;01m*[0m   emake failed




emerge --info
Portage 2.3.5 (python 3.6.1-final-0, default/linux/amd64/13.0/no-multilib, gcc-7.1.0, glibc-2.24-r1, 4.11.0-gentoo x86_64)
=================================================================
System uname: Linux-4.11.0-gentoo-x86_64-Intel-R-_Core-TM-_i5-3570K_CPU_@_3.40GHz-with-gentoo-2.3
KiB Mem:    32898488 total,   4999288 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 08 May 2017 13:42:11 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.6.1-r1::gentoo
dev-util/ccache:          3.3.4::gentoo
dev-util/cmake:           3.8.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.25::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            7.1.0::tamiko
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: git://github.com/gentoo-mirror/gentoo.git
    priority: -1000

fhede
    location: /usr/local/portage
    masters: gentoo

tamiko
    location: /var/lib/layman/tamiko
    masters: gentoo
    priority: 50

xfce-dev
    location: /var/lib/layman/xfce-dev
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=ivybridge -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=ivybridge -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/ http://trumpetti.atm.tut.fi/gentoo/ ftp://mirror.mdfnet.se/gentoo/"
INSTALL_MASK="COPYING* /etc/systemd /lib/systemd /usr/lib/systemd"
LANG="en_US.utf8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bzip2 cli consolekit cracklib crypt cxx dbus dri dvdr fortran freetype gdbm gif gtk3 iconv icu ipv6 jpeg lock modules ncurses nls nptl openmp pam pcre png policykit raw readline seccomp session ssl svg tcpd thunar truetype udev unicode xattr xscreensaver zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput" KERNEL="linux" L10N="sv" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="sv_SE" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 fhede 2017-05-10 03:29:53 UTC
error: ‘mojo::ScopedMessagePipeHandle {aka class mojo::ScopedHandleBase<mojo::MessagePipeHandle>}’ has no member named ‘Pass’
       handle_ = other.handle_.Pass();

Looks more like this 
https://bugreports.qt.io/browse/QTBUG-59776
Comment 2 Arfrever Frehtes Taifersar Arahesis 2017-05-11 05:54:36 UTC
*** Bug 618082 has been marked as a duplicate of this bug. ***
Comment 3 Mark Wright gentoo-dev 2017-05-13 13:30:28 UTC
Created attachment 472498 [details, diff]
qtwebengine-5.7.1-gcc-7-p1.patch

Workaround is to save the 2 patches obtained by hacking the patched applied by upstream to the directory:
/etc/portage/patches/dev-qt/qtwebengine-5.7.1-r1/
Comment 4 Mark Wright gentoo-dev 2017-05-13 13:31:54 UTC
Created attachment 472500 [details, diff]
qtwebengine-5.7.1-gcc-7-p2.patch

Second patch (both patches are required).
Comment 5 Ivan 2017-05-14 13:29:34 UTC
Patches proposed by Mark Wright above do work for me.

emerge --info
Portage 2.3.5 (python 3.5.3-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-7.1.0, glibc-2.24-r1, 4.4.67 x86_64)
=================================================================
System uname: Linux-4.4.67-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.3
KiB Mem:    16358284 total,   5276984 free
KiB Swap:          0 total,         0 free
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo, 3.5.3::gentoo
dev-util/cmake:           3.8.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.1::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.3.0::gentoo, 7.1.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo
Comment 6 Arfrever Frehtes Taifersar Arahesis 2017-05-16 11:54:45 UTC
*** Bug 618212 has been marked as a duplicate of this bug. ***
Comment 7 Vasco Gervasi 2017-05-17 18:54:11 UTC
The attached patches work for me.

Thanks.
Comment 8 Michael Palimaka (kensington) gentoo-dev 2017-06-04 11:55:39 UTC
In overlay:
https://gitweb.gentoo.org/proj/qt.git/commit/?id=8a778f2b0396c2f4415d92bc688ec8fc55d83991
Comment 9 Michael Palimaka (kensington) gentoo-dev 2017-06-04 13:21:50 UTC
Thanks, fixed in git.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=90f45d0172ad22d6b8a6e77025499156b704dcc9