Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 617886

Summary: games-sports/trigger-0.6.1-r1 with sys-devel/gcc-6.3.0 - src/pengine/tinyxmlparser.cpp:329:12: error: cannot convert ‘bool’ to ‘const char*’ in return
Product: Gentoo Linux Reporter: raffaele <ralfconn>
Component: Current packagesAssignee: Gentoo Games <games>
Status: RESOLVED FIXED    
Severity: normal CC: plevine457, toralf
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=632546
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: emerge --info
build.log
environment
emerge-info.txt
emerge-history.txt
environment
etc.portage.tbz2
games-sports:trigger-0.6.1-r1:20170615-024139.log
logs.tbz2
temp.tbz2

Description raffaele 2017-05-08 18:54:23 UTC
trigger fails build with gcc-6.3.0
It built fine with gcc-5.4.0
Verified with MAKEOPTS=-j1 and -j7

Reproducible: Always

Steps to Reproduce:
1. emerge -1 games-sports/trigger

Actual Results:  
build fails, see logs

Expected Results:  
package installed
Comment 1 raffaele 2017-05-08 18:56:17 UTC
Created attachment 472014 [details]
emerge --info
Comment 2 raffaele 2017-05-08 19:00:16 UTC
Created attachment 472016 [details]
build.log
Comment 3 raffaele 2017-05-08 19:55:57 UTC
Created attachment 472020 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-06-15 16:12:19 UTC
same issue with games-sports/trigger-0.6.1-r1 at the unstable amd64 chroot image desktop-libressl_20170604-185115 at the tinderbox
Comment 5 Toralf Förster gentoo-dev 2017-06-15 16:12:22 UTC
Created attachment 476540 [details]
emerge-info.txt
Comment 6 Toralf Förster gentoo-dev 2017-06-15 16:12:25 UTC
Created attachment 476542 [details]
emerge-history.txt
Comment 7 Toralf Förster gentoo-dev 2017-06-15 16:12:28 UTC
Created attachment 476544 [details]
environment
Comment 8 Toralf Förster gentoo-dev 2017-06-15 16:12:31 UTC
Created attachment 476546 [details]
etc.portage.tbz2
Comment 9 Toralf Förster gentoo-dev 2017-06-15 16:12:34 UTC
Created attachment 476548 [details]
games-sports:trigger-0.6.1-r1:20170615-024139.log
Comment 10 Toralf Förster gentoo-dev 2017-06-15 16:12:36 UTC
Created attachment 476550 [details]
logs.tbz2
Comment 11 Toralf Förster gentoo-dev 2017-06-15 16:12:39 UTC
Created attachment 476552 [details]
temp.tbz2
Comment 12 Peter Levine 2017-07-07 07:04:42 UTC
PR: https://github.com/gentoo/gentoo/pull/5059
Comment 13 David Seifert gentoo-dev 2017-07-30 09:15:13 UTC
commit 205a71b38f3f2e18a0bc5f7dc3031b2ff8ad3156
Author: Peter Levine <plevine457@gmail.com>
Date:   Fri Jul 7 03:02:29 2017 -0400

    games-sports/trigger: Fix building with GCC-6
    
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=617886
Comment 14 raffaele 2017-08-21 21:15:14 UTC
The fix works, thanks
Comment 15 Michael Palimaka (kensington) gentoo-dev 2017-10-01 12:25:15 UTC
*** Bug 625216 has been marked as a duplicate of this bug. ***