Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 617768

Summary: games-action/armagetronad-0.2.8.3.3-r1 with sys-devel/gcc-6.3.0 - gCycle.cpp:(.text+0x66ef): undefined reference to `tOutput::operator<<(tOutput const&)'
Product: Gentoo Linux Reporter: raffaele <ralfconn>
Component: Current packagesAssignee: Gentoo Games <games>
Status: RESOLVED FIXED    
Severity: normal CC: mail, plevine457, toralf
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=632544
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: emerge --info
build log
environment

Description raffaele 2017-05-07 20:10:29 UTC
armagetronad fails to build with gcc-6.3.0
Tested also with MAKEOPTS=-j1, same result

Reproducible: Always

Steps to Reproduce:
1.emerge -1 games-action/armagetronad

Actual Results:  
build fails

Expected Results:  
Application built and installed

The program build fine with previous gcc versions up to sys-devel/gcc-5.4.0-r3
Comment 1 raffaele 2017-05-07 20:11:52 UTC
Created attachment 471900 [details]
emerge --info
Comment 2 raffaele 2017-05-07 20:13:05 UTC
Created attachment 471902 [details]
build log
Comment 3 raffaele 2017-05-07 20:14:46 UTC
Created attachment 471904 [details]
environment
Comment 4 Denis Descheneaux 2017-05-08 06:59:51 UTC
Confirm also does not build with 6.3 but ok with 5.4
Comment 5 raffaele 2017-05-08 20:04:08 UTC
Seems a duplicate of

https://bugs.gentoo.org/show_bug.cgi?id=610844
Comment 6 Peter Levine 2017-07-19 08:17:30 UTC
PR: https://github.com/gentoo/gentoo/pull/5133
Comment 7 David Seifert gentoo-dev 2017-07-30 09:14:32 UTC
commit 85673de37c260f353160cc32452383eea2406a13
Author: Peter Levine <plevine457@gmail.com>
Date:   Wed Jul 19 04:14:31 2017 -0400

    games-action/armagetronad: Fix building with GCC-6
    
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=617768
Comment 8 raffaele 2017-08-14 21:09:09 UTC
works for me, thanks
Comment 9 Michael Palimaka (kensington) gentoo-dev 2017-10-01 12:33:11 UTC
*** Bug 610844 has been marked as a duplicate of this bug. ***