Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 616014

Summary: Chromium-58.0.3029.19: InitializeSandbox called with multiple threads in process gpu-process
Product: Gentoo Linux Reporter: fhede <fhede71>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: chromium.log output from terminal

Description fhede 2017-04-19 14:03:37 UTC
Created attachment 470392 [details]
chromium.log output from terminal

I installed chromium and at first run i got this output in terminal.
I build chromium only with ccache.

GLib:ERROR:/var/tmp/portage/dev-libs/glib-2.50.3-r1/work/glib-2.50.3/glib/gvarianttypeinfo.c:163:g_variant_type_info_check: assertion failed: (info->alignment == 0 || info->alignment == 1 || info->alignment == 3 || info->alignment == 7)
Received signal 6
#0 0x55566ce44656 <unknown>
#1 0x55566ce44a19 <unknown>
#2 0x7fd2d1b92110 <unknown>
#3 0x7fd2c7aa5054 gsignal
#4 0x7fd2c7aa64ba abort
#5 0x7fd2d0e27145 g_assertion_message
#6 0x7fd2d0e271ca g_assertion_message_expr
#7 0x7fd2d0e42478 <unknown>
#8 0x7fd2d0e425ab g_variant_type_info_get_type_string
#9 0x7fd2cd21ee98 <unknown>
#10 0x7fd2cd221610 g_dbus_message_to_blob
#11 0x7fd2cd21605e <unknown>
#12 0x7fd2cd217401 <unknown>
#13 0x7fd2cd21a213 g_dbus_connection_send_message_with_reply
#14 0x7fd2cd21a5b4 <unknown>
#15 0x7fd2cd21cc45 g_dbus_connection_call
#16 0x7fd2b0ec4673 <unknown>
#17 0x7fd2cd1d8117 g_simple_async_result_complete
#18 0x7fd2cd1d8179 <unknown>
#19 0x7fd2d0e0102a g_main_context_dispatch
#20 0x7fd2d0e013a8 <unknown>
#21 0x7fd2d0e016c2 g_main_loop_run
#22 0x7fd2b0ebd14b <unknown>
#23 0x7fd2b0ebd3bc <unknown>
#24 0x55566dcf8515 <unknown>
#25 0x55566cba164d <unknown>
#26 0x55566cb65d70 <unknown>
#27 0x55566e5122f1 <unknown>
#28 0x55566e512ccb <unknown>
#29 0x55566ced7549 <unknown>
#30 0x55566ce66000 <unknown>
#31 0x55566ce67c7d <unknown>
#32 0x55566ce68118 <unknown>
#33 0x55566ce68ea9 <unknown>
#34 0x55566ce650d5 <unknown>
#35 0x55566ce8b46a <unknown>
#36 0x55566b9e8318 <unknown>
#37 0x55566b9e8ba3 <unknown>
#38 0x55566cea93b0 <unknown>
#39 0x55566cea4ea2 <unknown>
#40 0x7fd2d1b88404 start_thread
#41 0x7fd2c7b5a63f clone
  r8: 0000000000000000  r9: 00007fd2b814de80 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007fd2d10c9340 r13: 00007fd2d0ea7230 r14: 00007fd2b814e0c0 r15: 00007fd2b814e1c0
  di: 0000000000000002  si: 00007fd2b814de80  bp: 00000000000000ed  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007fd2c7aa5054  sp: 00007fd2b814def8
  ip: 00007fd2c7aa5054 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
->>[13343:13343:0419/] InitializeSandbox() called with multiple threads in process gpu-process.

Tried with chromium --no-sandbox and got this output.

[13721:13721:0100/] Invalid node channel message
[13719:13719:0419/] InitializeSandbox() called with multiple threads in process gpu-process

emerge --info
Portage 2.3.5 (python 3.4.6-final-0, default/linux/amd64/13.0/no-multilib, gcc-6.3.0, glibc-2.24-r1, 4.10.11-gentoo x86_64)
System uname: Linux-4.10.11-gentoo-x86_64-Intel-R-_Core-TM-_i5-4200U_CPU_@_1.60GHz-with-gentoo-2.3
KiB Mem:     8058684 total,   6426516 free
KiB Swap:    8191996 total,   8191996 free
Timestamp of repository gentoo: Wed, 19 Apr 2017 05:02:27 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo
dev-util/ccache:          3.3.4::gentoo
dev-util/cmake:           3.8.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.25::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo

    location: /usr/portage
    sync-type: git
    sync-uri: git://
    priority: -1000

    location: /usr/local/portage
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=haswell -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=haswell -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X acl alsa amd64 berkdb bzip2 cli consolekit cracklib crypt cxx dbus dri egl fortran freetype gdbm glamor iconv icu ipv6 jpeg lock modules ncurses nls nptl opengl openmp pam pcre png policykit readline seccomp session ssl startup-notification svg tcpd thunar truetype udev unicode xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput" KERNEL="linux" L10N="sv" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="sv_SE" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="intel nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 fhede 2017-04-20 04:18:31 UTC
I add this here to but im not sure if related. I have this in dmesg.
xfce4-session-s[10886]: segfault at 0 ip 000000000040d91c sp 00007ffe30e84760 error 4 in xfce4-session-settings[400000+26000]

That i got after i tried to add things to session and startup in xfce.
Wonder if dev-libs/glib-2.50.3-r1 is the cause to this.
Comment 2 fhede 2017-04-21 11:01:36 UTC
Very strange i removed all useflags from chromium. And update to chromium58.0.3029.81 an have the same problem. Not start at all.
So i dont know where to look on this,so i throw chromium ut the window for now.
And close this report.