Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 613246

Summary: Removal of kde-base/kdelibs causing "Could not find KDE4 kde4-config"
Product: Gentoo Linux Reporter: ganthore <ganthore>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Status: RESOLVED INVALID    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description ganthore 2017-03-19 18:56:20 UTC
ERROR: Could not find KDE4 kde4-config

kde-base/kdelibs was recently removed from portage. Removing the software causes the reported error for installing packages such as kget and kdebase-kioslaves due to the kde4-config command no longer being present on the system. Ebuilds should be updated to us new build system tooling as part of the newer KDE framework.

It may be a good idea to audit the following ebuilds to ensure that this doesn't impact other related software:

grep -R kde4-base_src_configure ./
./app-office/calligra-l10n/calligra-l10n-2.9.11-r1.ebuild:      [[ -n ${A} ]] && kde4-base_src_configure
./app-office/calligra-l10n/calligra-l10n-2.9.11.ebuild: [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
./app-office/calligra/calligra-2.9.11.ebuild:   kde4-base_src_configure
./app-office/calligra/calligra-2.9.11-r1.ebuild:        kde4-base_src_configure
./app-office/kmymoney/kmymoney-4.7.2.ebuild:    kde4-base_src_configure
./app-office/kmymoney/kmymoney-4.8.0.ebuild:    kde4-base_src_configure
./app-office/libalkimia/libalkimia-4.3.2-r1.ebuild:     kde4-base_src_configure
./dev-util/kdevelop-qmake/kdevelop-qmake-1.7.0.ebuild:  kde4-base_src_configure
./dev-util/kdevelop/kdevelop-4.7.2.ebuild:      kde4-base_src_configure
./dev-util/kdevelop/kdevelop-4.7.4.ebuild:      kde4-base_src_configure
./dev-util/kdevplatform/kdevplatform-1.7.2-r1.ebuild:   kde4-base_src_configure
./dev-util/kdevplatform/kdevplatform-1.7.4.ebuild:      kde4-base_src_configure
./eclass/kde4-base.eclass:# @FUNCTION: kde4-base_src_configure
./eclass/kde4-base.eclass:kde4-base_src_configure() {
./eclass/kde4-base.eclass:      # Override this value, set in kde4-base_src_configure()
./eclass/kde4-meta.eclass:      kde4-base_src_configure
./games-mud/kmuddy/kmuddy-1.0.1-r3.ebuild:      kde4-base_src_configure
./kde-apps/audiocd-kio/audiocd-kio-16.08.3.ebuild:      kde4-base_src_configure
./kde-apps/gpgmepp/gpgmepp-4.14.11_pre20160211.ebuild:  kde4-base_src_configure
./kde-apps/juk/juk-16.08.3.ebuild:      kde4-base_src_configure
./kde-apps/juk/juk-16.12.3.ebuild:      kde4-base_src_configure
./kde-apps/k3b/k3b-2.0.3-r5.ebuild:     kde4-base_src_configure
./kde-apps/kaccessible/kaccessible-16.08.3.ebuild:      kde4-base_src_configure
./kde-apps/kaccessible/kaccessible-16.12.3.ebuild:      kde4-base_src_configure
./kde-apps/kalzium/kalzium-16.08.3.ebuild:      kde4-base_src_configure
./kde-apps/kdegraphics-mobipocket/kdegraphics-mobipocket-16.08.3.ebuild:        kde4-base_src_configure
./kde-apps/kdepim-l10n/kdepim-l10n-4.14.3-r1.ebuild:    [[ -n ${A} ]] && kde4-base_src_configure
./kde-apps/kdepim-l10n/kdepim-l10n-4.4.11.1-r2.ebuild:  [[ -n ${A} ]] && kde4-base_src_configure
./kde-apps/kdepim-runtime/kdepim-runtime-4.14.11_pre20160211.ebuild:    kde4-base_src_configure
./kde-apps/kdepimlibs/kdepimlibs-4.14.10-r3.ebuild:     kde4-base_src_configure
./kde-apps/kdepimlibs/kdepimlibs-4.14.11_pre20160211-r3.ebuild: kde4-base_src_configure
./kde-apps/kdesdk-kioslaves/kdesdk-kioslaves-16.08.3.ebuild:    kde4-base_src_configure
./kde-apps/kdesdk-kioslaves/kdesdk-kioslaves-16.12.3.ebuild:    kde4-base_src_configure
./kde-apps/kget/kget-16.08.3.ebuild:    kde4-base_src_configure
./kde-apps/kget/kget-16.12.3.ebuild:    kde4-base_src_configure
./kde-apps/klinkstatus/klinkstatus-16.12.3.ebuild:      kde4-base_src_configure
./kde-apps/konsolepart/konsolepart-4.14.3.ebuild:       kde4-base_src_configure
./kde-apps/kopete/kopete-16.12.2-r2.ebuild:     kde4-base_src_configure
./kde-apps/kopete/kopete-16.12.3.ebuild:        kde4-base_src_configure
./kde-apps/krfb/krfb-15.08.3.ebuild:    kde4-base_src_configure
./kde-apps/ksudoku/ksudoku-16.08.3.ebuild:      kde4-base_src_configure
./kde-apps/ksudoku/ksudoku-16.12.3.ebuild:      kde4-base_src_configure
./kde-apps/kwalletd/kwalletd-16.04.3-r1.ebuild: kde4-base_src_configure
./kde-apps/kwalletd/kwalletd-16.04.3.ebuild:    kde4-base_src_configure
./kde-apps/libkcddb/libkcddb-16.08.3.ebuild:    kde4-base_src_configure
./kde-apps/libkcompactdisc/libkcompactdisc-16.08.3.ebuild:      kde4-base_src_configure
./kde-apps/okular/okular-16.08.3.ebuild:        kde4-base_src_configure
./kde-apps/pykde4/pykde4-4.14.3-r1.ebuild:              kde4-base_src_configure
./kde-apps/pykde4/pykde4-4.14.3-r3.ebuild:              kde4-base_src_configure
./kde-frameworks/kactivities/kactivities-4.13.3-r2.ebuild:      kde4-base_src_configure
./kde-frameworks/kdelibs/kdelibs-4.14.29-r1.ebuild:     kde4-base_src_configure
./kde-frameworks/kfilemetadata/kfilemetadata-4.14.3.ebuild:     kde4-base_src_configure
./kde-misc/basket/basket-1.81.ebuild:   kde4-base_src_configure
./kde-misc/kdiff3/kdiff3-0.9.97-r2.ebuild:              kde4-base_src_configure
./kde-misc/kdiff3/kdiff3-0.9.98-r1.ebuild:              kde4-base_src_configure
./kde-misc/krename/krename-4.0.9-r3.ebuild:     kde4-base_src_configure
./kde-misc/krename/krename-4.0.9-r4.ebuild:     kde4-base_src_configure
./kde-misc/tellico/tellico-2.3.10.ebuild:       kde4-base_src_configure
./kde-misc/tellico/tellico-2.3.11.ebuild:       kde4-base_src_configure
./media-sound/amarok/amarok-2.8.0-r3.ebuild:    kde4-base_src_configure
./media-sound/amarok/amarok-2.8.90-r2.ebuild:   kde4-base_src_configure
./media-sound/k4guitune/k4guitune-1.1.1.ebuild: kde4-base_src_configure
./media-sound/kmidimon/kmidimon-0.7.5.ebuild:   kde4-base_src_configure
./media-sound/konvertible/konvertible-1.0.1.ebuild:     kde4-base_src_configure
./media-sound/kradio/kradio-4.0.8.ebuild:       kde4-base_src_configure
./net-p2p/kmldonkey/kmldonkey-2.0.7.ebuild:     kde4-base_src_configure
./sci-mathematics/rkward/rkward-0.6.1.ebuild:   kde4-base_src_configure
./sci-mathematics/rkward/rkward-0.6.5.ebuild:   kde4-base_src_configure
./net-vpn/kvpnc/kvpnc-0.9.6a-r2.ebuild: kde4-base_src_configure

Reproducible: Always

Steps to Reproduce:
1. Upgrade to latest KDE Plasma
2. Remove kde-base/kdelibs since it's no longer a portage ebuild
3. Attempt to rebuild kget or kdebase-kioslaves
Actual Results:  
Apps fail to compile

Expected Results:  
Software to compile correctly
Comment 1 Andreas Sturmlechner gentoo-dev 2017-03-19 19:03:24 UTC
kde-base/kdelibs was not removed but renamed to kde-frameworks/kdelibs.

# eshowkw kdelibs
Keywords for kde-frameworks/kdelibs:                                                                                                                                
           |                                 |   u        |                                                                                                         
           | a a         p s   a     n r     |   n        |  
           | l m   h i   p p   r m m i i s   | e u s      | r
           | p d a p a p c a x m i 6 o s 3   | a s l      | e
           | h 6 r p 6 p 6 r 8 6 p 8 s c 9 s | p e o      | p
           | a 4 m a 4 c 4 c 6 4 s k 2 v 0 h | i d t      | o
-----------+---------------------------------+------------+-------
4.14.29-r1 | o + ~ o o ~ ~ o + o o o o o o o | 6 o 4/4.14 | gentoo
Comment 2 Johannes Huber gentoo-dev 2017-03-19 19:05:06 UTC
kde-base/kdelibs was moved to kde-frameworks/kdelibs. Portage does this for you.
Comment 3 ganthore 2017-03-19 19:38:37 UTC
Hey everyone,

Probably worth noting that my installation is big and old, so upgrades are always a frustrating problem when it comes to resolving conflicts after packages get removed/renamed/etc.

I suspect that this happened in a weird order and I think this is how it happened:
1) kde-base/kdelibs and kde-frameworks/kdelibs may have both been registered as installed packages. 
2) When I removed kde-base/kdelibs, I suspect that took kde4-config with it.

I'm rebuilding kde-frameworks/kdelibs to confirm.

Thanks for the review. At least I know now that kde-frameworks/kdelibs is supposed to provide the file. :-)
Comment 4 ganthore 2017-03-19 19:43:14 UTC
Yep... The binary is now present after rebuilding kde-frameworks/kdelibs. 

I'm confident that kde-base/kdelibs was still somehow registered on the system at the same time as kde-frameworks/kdelibs and so it removed the binary when I removed the older package.