Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 611682

Summary: net-wireless/gnuradio-3.7.10.1 fails to build with gcc 6.3.0
Product: Gentoo Linux Reporter: Oleg Korsak <kamikaze.is.waiting.you>
Component: Current packagesAssignee: Radio Herd <radio>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: jstein, plevine457, zerochaos
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: ~arch only
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: build.log.gz

Description Oleg Korsak 2017-03-04 02:37:47 UTC
Created attachment 465910 [details]
build.log.gz

Portage 2.3.4 (python 2.7.13-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-6.3.0, glibc-2.24-r1, 4.9.9-gentoo x86_64)
=================================================================
System uname: Linux-4.9.9-gentoo-x86_64-Intel-R-_Core-TM-_i7-4710HQ_CPU_@_2.50GHz-with-gentoo-2.3
KiB Mem:    16331064 total,  11466048 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 04 Mar 2017 00:30:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.5.3::gentoo, 3.6.0::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

hnaparst
    location: /var/lib/layman/hnaparst
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -mtune=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="lv_LV.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="7zip X a52 aac acl acpi alsa amd64 ao audiofile avx avx2 berkdb bluetooth branding bzip2 cairo cdda cdr clang cli consolekit cracklib crypt cuda cups curl cxx dbus declarative dhcpcd dri dts dvd dvdr emboss encode exif extraengine fam fat fbcon ffmpeg firefox flac gd gdbm gif gimp git glamor glut gmp gnuplot gnutls gpg gpm gsl gtk gtk3 gudev gzip hddtemp iconv icu ieee1394 inotify ipv6 javascript jemalloc jpeg jpeg2k kde kipi kwallet lame lcms legacy-systray libnotify lm_sensors lzma lzo mad matroska mdnsresponder-compat memlimit mhash mime minizip mmap mmx mng modules mozilla mp3 mp4 mpeg mpi mplayer mtp multilib multitarget ncurses networkmanager nls nocd nptl nsplugin ntfs ogg openal opencl opengl openmp oss pam pango pch pcntl pcre pdf pie plasma plotutils png policykit portaudio posix postgres ppds profile pulseaudio python qml qt3support qt5 quicktime raw rdesktop readline recode resolvconf sasl sdl sdl2 seccomp session sharedmem slang smp sockets sound spell sqlite sqlite3 sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification steamruntime suid svg symlink syslog sysvipc szip tcmalloc tcpd theora threads tiff truetype udev udisks unicode upower usb v4l vaapi vdpau vhosts videos vnc vorbis vulkan wavpack wayland webkit widgets wifi wxwidgets x264 xattr xcb xcomposite xinerama xml xmp xmpp xosd xpm xscreensaver xsl xv xvid zeroconf zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev synaptics libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" LLVM_TARGETS="AMDGPU BPF NVPTX ARM X86 AArch64 Hexagon MSP430 Mips PowerPC Sparc SystemZ XCore" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-7" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i965 nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="3.5 2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 imese 2017-03-08 19:53:41 UTC
Oleg, have exactly the same problem.

I am using gcc-6.3.0 as well with graphite and lto. gnuradio will not compile with lto. So I have it compiling without. This is a new install I am working on. At least one program would not compile because one of it's dependencies was compiled with lto. I don't know how to discern this for gnuradio.

I am able to post any log or configs if necessary.

Thanks
Comment 2 Peter Levine 2017-07-21 06:55:16 UTC
The relevant build.log error message is:

> /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.0/../../../../lib64/libuhd.so: undefined reference to `boost::re_detail_106300::cpp_regex_traits_implementation<char>::transform_primary(char const*, char const*) const'
> /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.0/../../../../lib64/libuhd.so: undefined reference to `boost::re_detail_106300::cpp_regex_traits_implementation<char>::transform(char const*, char const*) const'

This looks like some kind of boost C++98/14 ABI mismatch.

I can't reproduce it for net-wireless/gnuradio but if I switch to gcc-5.4.0 and try building net-wireless/uhd-3.9.6, I get a build failure with a similar message:

> ../lib/libuhd.so.003.009: undefined reference to `boost::re_detail_106300::cpp_regex_traits_implementation<char>::transform_primary(char const*, char const*) const'
> ../lib/libuhd.so.003.009: undefined reference to `boost::re_detail_106300::cpp_regex_traits_implementation<char>::transform(char const*, char const*) const'
Comment 3 Rick Farina (Zero_Chaos) gentoo-dev 2017-08-28 02:00:02 UTC
boost and uhd both have to be rebuilt when the c++ abi changes.  Can you please try that?