Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 611082

Summary: app-admin/tenshi init script uses runscript instead of openrc-run
Product: Gentoo Linux Reporter: Hanno Böck <hanno>
Component: Current packagesAssignee: Brian De Wolf <bldewolf>
Status: RESOLVED FIXED    
Severity: normal CC: atj, esigra, jstein, mjo, proxy-maint
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 573846    

Description Hanno Böck gentoo-dev 2017-02-27 10:39:59 UTC
When installed you'll get this warning:
 * QA Notice: #!/sbin/runscript is deprecated, use #!/sbin/openrc-run instead:
 *    //etc/init.d/tenshi

The problem is that the init script uses the deprecated runscript shebang, should be converted to openrc-run.
Comment 1 Michael Orlitzky gentoo-dev 2017-07-26 19:57:37 UTC
This is fixed upstream already, and I sent some more init script improvements:

  https://github.com/inversepath/tenshi/pull/5

If that pull request gets merged, the following code in the ebuild will become unnecessary:

  dodir /var/lib/tenshi
  fowners tenshi:root /var/lib/tenshi
  ...
  keepdir /var/lib/tenshi

The new init script writes the PID file to /run/tenshi/tenshi.pid, and creates that location on-the-fly with the correct permissions.
Comment 2 Jonas Stein gentoo-dev 2018-08-11 18:22:14 UTC
abarisani merged commit 2e637b5 into inversepath:master on Jul 27, 2017
Comment 3 Michael Orlitzky gentoo-dev 2018-08-11 21:22:30 UTC
Whoops, I forgot about this one. It's been fixed for a while. Thanks for the ping Jonas.