Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 610608

Summary: media-libs/libepoxy-1.3.1 - missing RDEPEND on media-libs/mesa (virtual/opengl?)
Product: Gentoo Linux Reporter: William Throwe <wtt6>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: normal CC: devurandom, leio
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description William Throwe 2017-02-22 21:22:51 UTC
Fails (when run with any argument list) with "Couldn't open libGL.so.1: libGL.so.1: cannot open shared object file: No such file or directory".  It's not linked against libGL, so I assume it is dlopening it.
Comment 1 Mart Raudsepp gentoo-dev 2017-02-22 22:13:32 UTC
mesa isn't the only provider of libGL.so.1, however.
virtual/opengl maybe. And something might be trying to open it instead of zathura itself
Comment 2 William Throwe 2017-02-23 00:09:57 UTC
Good points.  By running grep over the libraries zathura links against, it looks likely that media-libs/libepoxy-1.3.1 is the actual culprit.  Looking at the libepoxy ebuild, I see that it DEPENDs on media-libs/mesa, which also seems suspicious.  A quick search through the libepoxy source turns up the line

src/dispatch_common.c:    /** dlopen() return value for libGL.so.1. */


So I think I'll change this to a libepoxy bug.
Comment 3 Matt Turner gentoo-dev 2017-03-04 07:58:38 UTC
libepoxy is to be used by applications *already* using OpenGL.

gtk+ (a dependency of zathura) depends on libepoxy, but not an OpenGL implementation. Either gtk+ or libepoxy needs to depend on OpenGL.

media-libs/glew depends on virtual/opengl, so I guess that's what libepoxy should do as well.

leio, what do you think?
Comment 4 Larry the Git Cow gentoo-dev 2018-05-29 19:08:11 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a5a91b5dc7b24a8ddf2d295e796aeffb0d85b3ed

commit a5a91b5dc7b24a8ddf2d295e796aeffb0d85b3ed
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2018-05-29 19:04:45 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2018-05-29 19:07:57 +0000

    media-libs/libepoxy: RDEPEND on media-libs/mesa
    
    The .pc file installed by libepoxy says it requires gl, which is
    installed by Mesa.
    
    Closes: https://bugs.gentoo.org/610608

 media-libs/libepoxy/libepoxy-1.5.2.ebuild | 4 ++--
 media-libs/libepoxy/libepoxy-9999.ebuild  | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 5 William Throwe 2018-06-03 17:08:21 UTC
*** Bug 657176 has been marked as a duplicate of this bug. ***