Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 605364

Summary: dev-libs/kpathsea-6.2.1_p20150521-r2 : installs into paths that should be created at runtime
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Alexis Ballier <aballier>
Status: RESOLVED FIXED    
Severity: normal CC: jstein, mail, tex
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 520404    

Description Toralf Förster gentoo-dev 2017-01-11 09:21:13 UTC
QA: preinst
QA Notice: Symbolic link /usr/share/texmf-dist/web2c/texmf.cnf points to /etc/texmf/web2c/texmf.cnf which does not exist.
QA Notice: Symbolic link /usr/share/texmf-dist/web2c/fmtutil.cnf points to /etc/texmf/web2c/fmtutil.cnf which does not exist.
QA: other
QA Notice: This ebuild installs into paths that should be created at runtime.
 To fix, simply do not install into these directories.  Instead, your package
 should create dirs on the fly at runtime as needed via init scripts/etc...

  var/cache
  var/cache/fonts
Comment 1 Toralf Förster gentoo-dev 2017-01-11 09:36:22 UTC
*** Bug 605366 has been marked as a duplicate of this bug. ***
Comment 2 Jonas Stein gentoo-dev 2017-06-11 10:48:10 UTC
This QA problem is still in kpathsea-6.2.3_p20170524
Comment 3 Toralf Förster gentoo-dev 2019-06-28 17:53:24 UTC
*** Bug 677180 has been marked as a duplicate of this bug. ***
Comment 4 Toralf Förster gentoo-dev 2019-06-28 17:54:43 UTC
*** Bug 670434 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2019-09-28 15:48:37 UTC
*** Bug 647310 has been marked as a duplicate of this bug. ***
Comment 6 Francesco Turco 2020-03-05 15:38:59 UTC
I can still reproduce this bug with dev-libs/kpathsea-6.3.1_p20190410.
Comment 7 Larry the Git Cow gentoo-dev 2021-04-02 07:25:12 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6c71f0cce20b1ba654b8ab81515231ce5796b24d

commit 6c71f0cce20b1ba654b8ab81515231ce5796b24d
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2021-04-02 07:19:48 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2021-04-02 07:20:37 +0000

    dev-libs/kpathsea: Use tmpfiles for runtime dirs
    
    Closes: https://bugs.gentoo.org/605364
    Package-Manager: Portage-3.0.17, Repoman-3.0.2
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 dev-libs/kpathsea/kpathsea-6.3.2_p20200406.ebuild | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)