Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 602820

Summary: media-plugins/vdr-xineliboutput-2.0.0_p20150220 : xine_frontend_cec.c:236:3: error: unknown field ‘CBCecKeyPress’ specified in initializer
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Matthias Schwarzott <zzam>
Status: RESOLVED FIXED    
Severity: normal CC: josef64, mgorny, plevine457, treecleaner, vdr
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: ~arch only
Package list:
Runtime testing required: ---
Deadline: 2017-07-05   
Attachments: emerge-history.txt
environment
etc.portage.tbz2
media-plugins:vdr-xineliboutput-2.0.0_p20150220:20161216-101110.log
build.log
emerge --info

Description Toralf Förster gentoo-dev 2016-12-16 12:53:39 UTC
x86_64-pc-linux-gnu-gcc -march=native -O2 -pipe -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include  -DUSE_PLUGINMISSING -c -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"xineliboutput"' -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DVIDEODIR='"/"' -DXINELIBOUTPUT_VERSION='"2.0.0-cvs"' -Wall     -o xine_frontend_kbd.o xine_frontend_kbd.c
x86_64-pc-linux-gnu-gcc -march=native -O2 -pipe -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include  -DUSE_PLUGINMISSING -c -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"xineliboutput"' -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DVIDEODIR='"/"' -DXINELIBOUTPUT_VERSION='"2.0.0-cvs"' -Wall     -o xine_frontend_cec.o xine_frontend_cec.c
xine_frontend_cec.c:236:3: error: unknown field ‘CBCecKeyPress’ specified in initializer
   .CBCecKeyPress             = cec_keypress_cb,
   ^
xine_frontend_cec.c:236:32: warning: initialization from incompatible pointer type [-Wincompatible-pointer-types]


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-hardened-no-multilib-unstable_20161213-135840) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp alisp alsa avformat corefonts egl gtkstyle gui ibus -lua -lvm -nss opengl -openmpi -pam pcre16 perl -pulseaudio sasl sdl -smartcard -svg swscale -system-harfbuzz usbredir -vorbis wav webgl ziffy"
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.2.0 *
llvm-config --version:
3.9.0

Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4
  [3]   python3.5 (fallback)
  [4]   pypy3 (fallback)

java-config:
The following VMs are available for generation-2:
  -----------------------------------------------------------------

Portage 2.3.3 (python 2.7.12-final-0, hardened/linux/amd64/no-multilib, gcc-6.2.0, glibc-2.23-r3, 4.8.14-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.14-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   3000624 free
KiB Swap:   67108860 total,  67108860 free
Timestamp of repository gentoo: Fri, 16 Dec 2016 07:42:19 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 99

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-Werror=terminate -march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl alisp alsa amd64 avformat berkdb bzip2 cli corefonts cracklib crypt cxx dri egl gdbm gtkstyle gui hardened ibus iconv ipv6 justify mmx mmxext modules ncurses nls nptl opengl openmp pax_kernel pcre pcre16 perl pie readline sasl sdl seccomp session sse sse2 ssl ssp swscale tcpd unicode urandom usbredir wav webgl xattr xtpax ziffy zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="ca es-CL hu ks xh" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-12-16 12:53:42 UTC
Created attachment 456378 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-12-16 12:53:45 UTC
Created attachment 456380 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-12-16 12:53:47 UTC
Created attachment 456382 [details]
etc.portage.tbz2
Comment 4 Toralf Förster gentoo-dev 2016-12-16 12:53:50 UTC
Created attachment 456384 [details]
media-plugins:vdr-xineliboutput-2.0.0_p20150220:20161216-101110.log
Comment 5 Pacho Ramos gentoo-dev 2017-01-07 11:44:53 UTC
CCing treecleaners
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-06-05 17:58:00 UTC
# Michał Górny <mgorny@gentoo.org> (05 Jun 2017)
# (on behalf of Treecleaner project)
# Unmaintained in Gentoo. The current Gentoo version no longer builds.
# Removal in 30 days. Bug #602820.
media-plugins/vdr-xineliboutput
Comment 7 josef.95 2017-06-06 03:38:43 UTC
Created attachment 475320 [details]
build.log
Comment 8 josef.95 2017-06-06 03:39:52 UTC
Created attachment 475322 [details]
emerge --info

Hm, builds and works here fine.

emerge -pvq media-plugins/vdr-xineliboutput::gentoo
[ebuild   R   ] media-plugins/vdr-xineliboutput-2.0.0_p20150220  USE="X dbus jpeg nls opengl vdpau vdr xine xinerama -bluray -caps -fbcon -libextractor"

Please don't remove this ebuild - it works fine.
thanks
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-06-06 08:31:37 UTC
(In reply to josef.95 from comment #8)
> Please don't remove this ebuild - it works fine.
> thanks

If you want it to stay, you should take it and fix at least some of the 8 bugs open for it.
Comment 10 josef.95 2017-06-06 14:26:26 UTC
Is not reproducible here, builds fine with
gcc-6.3.0
and
gcc-7.1.0
Comment 11 Sebastian Schreier 2017-06-06 21:39:36 UTC
Sorry but all unconfirmed bugs seems to be fixed and i can´t reproduce any of the confirmed ones
Comment 12 Matthias Schwarzott gentoo-dev 2017-07-02 09:24:57 UTC
I will take this package.
Please do not tree-clean it.

There is a new upstream version 2.0.0
Comment 13 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-08-03 16:52:00 UTC
I see that you've actually working on it, so removing treecleaners.
Comment 14 Pacho Ramos gentoo-dev 2017-08-04 08:53:47 UTC
But I don't see anything related with fixing the bugs that caused the mask to happen :/
Comment 15 Matthias Schwarzott gentoo-dev 2017-08-06 11:12:39 UTC
Commited an ebuild for version 2.0.0
I hope this one fixes the issue.
Comment 16 josef.95 2017-08-06 13:17:02 UTC
[ebuild   R    ] media-plugins/vdr-xineliboutput-2.0.0::gentoo  USE="X dbus jpeg nls opengl vdpau vdr xine xinerama -bluray -caps -fbcon -libextractor" 0 KiB

builds and works here fine.

Thanks
Comment 17 Peter Levine 2017-10-25 03:43:43 UTC
This is not a gcc-6 issue.  The bug can be reproduced with:

> emerge -1 =dev-libs/libcec-4.0.2 =vdr-xineliboutput-2.0.0_pre20150220

Though the ebuild doesn't address it, the configure script does recognize "--disable-libcec" and "--enable-libcec".  And trying to build it against dev-libs/libcec-3.1.0-r1, it fails with 'error: ‘CEC_CLIENT_VERSION_CURRENT’ undeclared'.  It looks likely that vdr-xineliboutput-2.0.0_pre20150220 depends on libcec-2* for libcec support, which is not in portage.  It would make sense to force "--disable-libcec" in the configure phase.
Comment 18 Virgil Dupras gentoo-dev 2018-10-08 12:06:24 UTC
Not masked anymore.
Comment 19 Pacho Ramos gentoo-dev 2018-10-10 21:44:41 UTC
(In reply to josef.95 from comment #16)
> [ebuild   R    ] media-plugins/vdr-xineliboutput-2.0.0::gentoo  USE="X dbus
> jpeg nls opengl vdpau vdr xine xinerama -bluray -caps -fbcon -libextractor"
> 0 KiB
> 
> builds and works here fine.
> 
> Thanks