Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 597928

Summary: dev-java/icedtea-bin-3.1.0 does not support JavaFX
Product: Gentoo Linux Reporter: aditsu <aditsu>
Component: Current packagesAssignee: Java team <java>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: minimal JavaFX application

Description aditsu 2016-10-23 23:03:22 UTC
Created attachment 451216 [details]
minimal JavaFX application

I have both oracle-jdk-bin-1.8.0.112 and icedtea-bin-3.1.0 installed. They are both Java 8 JDK's, but the former supports JavaFX applications (JavaFX is an integral part of Java 8) while the latter does not.

I'm attaching an example program (Test.java)

If I compile it with Oracle's JDK, it compiles successfully with no message.
But with icedtea-bin-8 (selected with eselect), I get:

Test.java:1: error: package javafx.application does not exist
import javafx.application.Application;
                         ^
Test.java:2: error: package javafx.stage does not exist
import javafx.stage.Stage;
                   ^
[etc]
Comment 1 aditsu 2016-10-23 23:06:05 UTC
# emerge --info icedtea-bin:8
Portage 2.3.0 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-Intel-R-_Core-TM-_i5-6500_CPU_@_3.20GHz-with-gentoo-2.2
KiB Mem:    32807756 total,   1814160 free
KiB Swap:   33554428 total,  29802996 free
Timestamp of repository gentoo: Sun, 23 Oct 2016 02:00:01 +0000
sh bash 4.3_p48
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p48::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21.7::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

aditsu
    location: /usr/local/portage
    masters: gentoo

proaudio
    location: /var/lib/layman/proaudio
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA google-chrome Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.aditsu.net http://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bittorrent branding bzip2 cairo cdda cdr cjk cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam fat ffmpeg firefox flac fortran gdbm gif gimp glamor gpm gtk iconv icu ipv6 jack jpeg kde kipi lcms libnotify mad mdadm mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ntfs ogg opengl openmp pam pango pch pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline samba sdl seccomp session source spell sse sse2 ssl startup-notification svg symlink tcpd theora threads tiff truetype udev udisks unicode upower usb vnc vorbis vpx widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-java/icedtea-bin-3.1.0::gentoo was built with the following:
USE="alsa cups gtk nsplugin source webstart -doc -examples -headless-awt -multilib -pulseaudio (-selinux)" ABI_X86="64 -32 -x32"
Comment 2 James Le Cuirot gentoo-dev 2016-10-24 07:51:36 UTC
JavaFX is not a core part of the JRE and there's no great reason why IcedTea should include it. Oracle bundle tons of crap with theirs, which is why their tarball is about 175MB and icedtea-bin's is about 60MB. OpenJFX needs to be packaged and we probably need a java-virtual for it.

*** This bug has been marked as a duplicate of bug 547918 ***
Comment 3 aditsu 2016-10-25 04:41:11 UTC
(In reply to James Le Cuirot from comment #2)
> JavaFX is not a core part of the JRE and there's no great reason why IcedTea
> should include it.

I disagree, JavaFX is becoming (if not already) the main Java GUI framework.
If its open-source version is being developed as a separate project (OpenJFX), then I guess it's fine to package it separately, but there should at least be a javafx USE flag for IcedTea to pull it as a dependency.
Comment 4 James Le Cuirot gentoo-dev 2016-10-28 22:23:48 UTC
(In reply to aditsu from comment #3)
> (In reply to James Le Cuirot from comment #2)
> > JavaFX is not a core part of the JRE and there's no great reason why IcedTea
> > should include it.
> 
> I disagree, JavaFX is becoming (if not already) the main Java GUI framework.
> If its open-source version is being developed as a separate project
> (OpenJFX), then I guess it's fine to package it separately, but there should
> at least be a javafx USE flag for IcedTea to pull it as a dependency.

I'm not downplaying JavaFX's importance. Almost nothing in the tree currently requires it though that probably says more about the state of the tree. What I mean is IcedTea's upstream is OpenJDK, not Oracle, and I consider OpenJDK to be the canonical Java source in spite of what some other people have to say about it. A flag wouldn't hurt but the most important thing is for packages to put the virtual in (R)DEPEND when we have it.

As well as packaging OpenJFX, we should check to see what things will look like in Java 9. On the one hand, JavaFX is indeed becoming the de facto framework, but on the other hand, Java 9 is supposed to be modular thanks to Project Jigsaw.