Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 597912

Summary: net-p2p/transmission-2.92-r1 with gcc6 /.../cstdlib:75:25: fatal error: stdlib.h: No such file or directory
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Mike Gilbert <floppym>
Status: RESOLVED FIXED    
Severity: normal CC: josef64, plevine457
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
https://bugreports.qt.io/browse/QTBUG-53367
https://github.com/pkgconf/pkgconf/issues/99
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 627040    
Bug Blocks: 582084    
Attachments: config.log
emerge-history.txt
environment
net-p2p:transmission-2.92-r1:20161023-192800.log

Description Toralf Förster gentoo-dev 2016-10-23 19:53:35 UTC
                 from /usr/include/qt5/QtWidgets/QApplication:1,
                 from AboutDialog.cc:10:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:75:25: fatal error: stdlib.h: No such file or directory
 #include_next <stdlib.h>
                         ^
compilation terminated.


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-gnome-systemd-unstable_20161015-114150) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp alisp cairo cdb consolekit -dot ecc exif -fitz freetds gnuplot graphtft gstreamer gtk gtkstyle imap imlib -inifile javascript javaxml ldap libkms lvm minimal mta mysql nss -objc opus osc pam plasma plotutils -png postgres pwquality qemu qt3support -qt4 qt5 scrypt ssp system-libvpx -szip tcpd theora threads tools udisks ufed uml vaapi vdpau vpx wav wma wxwidgets xcb xinerama xml -xvfb"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      mta ssl
  net-misc/wget       ssl
  app-editors/xemacs  -nopie
  dev-db/sqlite           secure-delete
  dev-lang/python         sqlite
  dev-qt/qtsql            sqlite
  mail-client/thunderbird -pulseaudio system-icu
  media-libs/libvpx       postproc
  media-libs/libpng       apng
  media-sound/pulseaudio  alsa
  media-video/ffmpeg      sdl
  sys-libs/ntdb           python
  sys-libs/tdb            python
  sys-libs/tevent         python
  x11-libs/cairo          X
  x11-libs/libxcb         xkb
  www-client/firefox      -pulseaudio system-icu
  app-crypt/mit-krb5      -pkinit
  media-video/ffmpeg      -sdl
  sys-devel/llvm          clang
  sys-libs/zlib           minizip
  x11-base/xorg-server    glamor -minimal
  app-crypt/pinentry  -qt4
  app-editors/emacs   -dbus -gtk -gtk3 -ssl -svg
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-lang/python     threads
  dev-qt/qtgui        egl eglfs
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -gtk -perl
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi
  net-nds/openldap    -sasl
  sys-apps/kmod       tools
  sys-libs/ncurses    -gpm
  x11-libs/gtk+       -cups

  entries in /etc/portage/package.unmask/*:
  ~sys-apps/sandbox-2.11
  ~dev-libs/botan-1.11.32
  sys-devel/gcc:6.2.0
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-4.9.3
 [2] x86_64-pc-linux-gnu-6.2.0 *
llvm-config --version:
3.8.1
Available Java Virtual Machines:
  [1]   icedtea-bin-7  system-vm
  [2]   icedtea-bin-8 
  [3]   jamvm 
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
  [3]   jython2.7 (fallback)
Available Ruby profiles:
  (none found)
  -----------------------------------------------------------------

Portage 2.3.2 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-6.2.0, glibc-2.23-r2, 4.7.10-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.10-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285608 total,  35084264 free
KiB Swap:   67108860 total,  67108860 free
Timestamp of repository gentoo: Sun, 23 Oct 2016 19:04:11 +0000
sh bash 4.4-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.2::gentoo
sys-apps/sandbox:         2.11-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /usr/lib64/fax /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/lib/i2pd/certificates /var/spool/fax/etc /var/spool/munin-async/.ssh /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alisp alsa amd64 berkdb bluetooth branding bzip2 cairo cdb cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr ecc eds emboss encode evo exif fam firefox flac fortran freetds gdbm gif glamor gnome gnome-keyring gnome-online-accounts gnuplot gpm graphtft gstreamer gtk gtkstyle iconv imap imlib introspection ipv6 javascript javaxml jpeg lcms ldap libkms libnotify libsecret lvm mad minimal mmx mmxext mng modules mp3 mp4 mpeg mta multilib mysql nautilus ncurses nls nptl nss ogg opengl openmp opus osc pam pango pax_kernel pcre pdf plasma plotutils policykit postgres ppds pulseaudio pwquality qemu qt3support qt5 readline scrypt sdl seccomp session spell sse sse2 ssl ssp startup-notification svg system-libvpx systemd tcpd theora threads tiff tools tracker truetype udev udisks ufed uml unicode upower usb vaapi vdpau vorbis vpx wav wma wxwidgets x264 xattr xcb xinerama xml xtpax xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="bo ff hi hsb nds" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-10-23 19:53:41 UTC
Created attachment 451202 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-10-23 19:53:44 UTC
Created attachment 451204 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-10-23 19:53:47 UTC
Created attachment 451206 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-10-23 19:53:50 UTC
Created attachment 451208 [details]
net-p2p:transmission-2.92-r1:20161023-192800.log
Comment 5 Mike Gilbert gentoo-dev 2016-12-12 00:57:29 UTC
I believe this failure was triggered by pkg-config as provided by dev-util/pkgconf.

% pkg-config --cflags freetype2
-I/usr/include/freetype2  -I/usr/include

The "-I/usr/include" causes qmake to emit -isystem /usr/include, which causes problems with gcc-6.

This was resolved in the newest version of pkgconf.
Comment 6 Andreas K. Hüttel gentoo-dev 2017-09-30 17:25:25 UTC
(In reply to Mike Gilbert from comment #5)
> I believe this failure was triggered by pkg-config as provided by
> dev-util/pkgconf.
> 
> % pkg-config --cflags freetype2
> -I/usr/include/freetype2  -I/usr/include
> 
> The "-I/usr/include" causes qmake to emit -isystem /usr/include, which
> causes problems with gcc-6.
> 
> This was resolved in the newest version of pkgconf.

OK. That was 1.0.2, according to the git timeline. So there's nothing to be done here anymore, and we depend for gcc-6-stable on the 1.3.7 stabilization.
Comment 7 Peter Levine 2017-10-15 03:21:57 UTC
I can confirm that I'm not able to reproduce this bug and the place in the log file where '-isystem /usr/include' had been emitted, now no longer does so.
Comment 8 Toralf Förster gentoo-dev 2017-10-15 09:22:33 UTC
yep, fixed