Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 597108 (CVE-2016-8669)

Summary: <app-emulation/qemu-2.7.0-r5: two divide-by-zero (CVE-2016-8669)
Product: Gentoo Security Reporter: Agostino Sarubbo <ago>
Component: VulnerabilitiesAssignee: Gentoo Security <security>
Status: RESOLVED FIXED    
Severity: minor CC: qemu
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: B3 [glsa cve]
Package list:
Runtime testing required: ---

Description Agostino Sarubbo gentoo-dev 2016-10-14 13:54:25 UTC
From https://bugzilla.redhat.com/show_bug.cgi?id=1384909:

Quick Emulator(Qemu) built with the 16550A UART emulation support is vulnerable
to a divide by zero issue. It could occur while updating serial device
parameters in 'serial_update_parameters'.

A privileged guest user could use this flaw to crash the Qemu process instance
on the host, resulting in DoS.

Upstream patch:
---------------
  -> https://lists.gnu.org/archive/html/qemu-devel/2016-10/msg02461.html


From https://bugzilla.redhat.com/show_bug.cgi?id=1384874:

Quick Emulator(Qemu) built with the JAZZ RC4030 chipset emulation support is
vulnerable to a divide by zero issue. It could occur while computing its
periodic timer's next tick value.

A privileged guest user could use this flaw to crash the Qemu process instance
on the host resulting in DoS.

Upstream patch:
---------------
  -> https://lists.gnu.org/archive/html/qemu-devel/2016-10/msg02577.html


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Matthias Maier gentoo-dev 2016-10-26 21:53:56 UTC
Stabilization on bug #598046

commit 5a981e9d23127c779dc8ecb1d05ef08fe4d3a011
Author: Matthias Maier <tamiko@gentoo.org>
Date:   Wed Oct 26 16:47:50 2016 -0500

    app-emulation/qemu: multiple security fixes for 2.7.0-r5
    
      CVE-2016-7907, bug 596048
      CVE-2016-7908, bug 596048
      CVE-2016-7909, bug 596048
      CVE-2016-7994, bug 596738
      CVE-2016-7994, bug 596738
      CVE-2016-8576, bug 596752
      CVE-2016-8577, bug 596776
      CVE-2016-8578, bug 596774
      CVE-2016-8668, bug 597110
      CVE-2016-8669, bug 597108
      CVE-2016-8669, bug 597108
      CVE-2016-8909, bug 598044
      CVE-2016-8910, bug 598046
    
    Package-Manager: portage-2.3.0
Comment 2 Matthias Maier gentoo-dev 2016-10-27 13:23:53 UTC
2.7.0-r5 is stable, all vulnerable versions dropped.

Security, please vote.
Comment 3 GLSAMaker/CVETool Bot gentoo-dev 2016-11-18 23:13:17 UTC
This issue was resolved and addressed in
 GLSA 201611-11 at https://security.gentoo.org/glsa/201611-11
by GLSA coordinator Aaron Bauman (b-man).