Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 595410

Summary: dev-qt/qtcore-4.8.6-r2: qglobal.h:1539:22: error: throw will always call terminate() [-Werror=terminate]
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Qt Bug Alias <qt>
Status: RESOLVED INVALID    
Severity: normal CC: jkt
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: dev-qt:qtcore-4.8.6-r2:20160928-075801.log
emerge-history.txt
environment

Description Toralf Förster gentoo-dev 2016-09-28 17:04:45 UTC
DB2 auto-detection... ()
x86_64-pc-linux-gnu-g++ -c -Werror=terminate -march=native -O2 -pipe -Wall -W  -I/var/tmp/portage/dev-qt/qtcore-4.8.6-r2/work/qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++ -I/var/tmp/portage/dev-qt/qtcore-4.8.6-r2/work/qt-everywhere-opensource-src-4.8.6/config.tests/unix/db2 -I/var/tmp/portage/dev-qt/qtcore-4.8.6-r2/work/qt-everywhere-opensource-src-4.8.6/config.tests/unix/db2 -I. -o db2.o /var/tmp/portage/dev-qt/qtcore-4.8.6-r2/work/qt-everywhere-opensource-src-4.8.6/config.tests/unix/db2/db2.cpp
/var/tmp/portage/dev-qt/qtcore-4.8.6-r2/work/qt-everywhere-opensource-src-4.8.6/config.tests/unix/db2/db2.cpp:42:20: fatal error: sqlcli.h: No such file or directory
 #include <sqlcli.h>
                    ^
compilation terminated.


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-desktop-unstable_20160926-212503) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp -alsa bzip2 -compat designer dot -egl emacs exif ext4 -extraengine ftp -gd gnuplot graphtft isag mad mpeg2 -mpg123 mssql mysqli -nls nss opengl openssl pcre16 plotutils policykit postscript qml qt5 scripts sddm sdl server ssl swscale system-icu system-jpeg timidity -traceroute vdpau vorbis -xml xmlreader xmp xvmc"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      ssl mta
  net-misc/wget       ssl
  app-crypt/pinentry  -qt4
  app-editors/emacs   -dbus -svg -ssl -gtk -gtk3
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-lang/python     threads
  dev-qt/qtgui        egl eglfs
  net-nds/openldap    -sasl
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -perl
  media-libs/mesa     -vaapi
  sys-apps/kmod       tools
  <=net-misc/openssh-7.3_p1-r2    -hpn
  net-misc/iputils -caps -filecaps
  >=dev-lang/python-2.7.12:2.7 xml
  >=dev-lang/python-3.4.5:3.4 xml
  >=media-libs/mesa-12.0.3 egl

  entries in /etc/portage/package.unmask/*:
  media-video/ffmpeg
  sys-devel/gcc:6.2.0
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-4.9.3
 [2] x86_64-pc-linux-gnu-6.2.0 *
llvm-config --version:
3.8.1

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)

  -----------------------------------------------------------------

Portage 2.3.1 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop, gcc-6.2.0, glibc-2.23-r2, 4.7.4-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.4-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285480 total,   1402952 free
KiB Swap:   67108860 total,  67100668 free
Timestamp of repository gentoo: Wed, 28 Sep 2016 06:09:16 +0000
sh bash 4.3_p46-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46-r1::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Werror=terminate -march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus designer dot dri dts dvd dvdr emacs emboss encode exif ext4 fam firefox flac fortran ftp gdbm gif glamor gnuplot gpm graphtft gtk iconv ipv6 isag jpeg lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mpeg2 mssql multilib mysqli ncurses nptl nss ogg opengl openmp openssl pam pango pax_kernel pcre pcre16 pdf plotutils png policykit postscript ppds qml qt3support qt4 qt5 readline scripts sddm sdl seccomp server session spell sse sse2 ssl ssp startup-notification svg swscale system-icu system-jpeg tcpd tiff timidity truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xattr xcb xmlreader xmp xtpax xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="la sco si te" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-qt/qtcore-4.8.7-r2::gentoo was built with the following:
USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -libressl -pch" ABI_X86="64 -32 -x32"
CXXFLAGS="-march=native -O2 -pipe"


dev-qt/qtcore-5.6.1::gentoo was built with the following:
USE="-debug -icu -systemd -test" ABI_X86="64"
CXXFLAGS="-march=native -O2 -pipe"
Comment 1 Toralf Förster gentoo-dev 2016-09-28 17:04:48 UTC
Created attachment 448302 [details]
dev-qt:qtcore-4.8.6-r2:20160928-075801.log
Comment 2 Toralf Förster gentoo-dev 2016-09-28 17:04:51 UTC
Created attachment 448304 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-09-28 17:04:53 UTC
Created attachment 448306 [details]
environment
Comment 4 Davide Pesavento gentoo-dev 2016-09-30 09:13:12 UTC
Caused by CXXFLAGS="-Werror=terminate". You're not supposed to add this kind of things to your build flags.
Comment 5 David Seifert gentoo-dev 2016-09-30 17:24:12 UTC
(In reply to Davide Pesavento from comment #4)
> Caused by CXXFLAGS="-Werror=terminate". You're not supposed to add this kind
> of things to your build flags.

I purposely told Toralf to add this flag, in order to catch cases where throw/noexcept semantics have changed (silently) between GCC 5 and GCC 6: https://gcc.gnu.org/gcc-6/porting_to.html If you're willing to ignore this, you risk runtime failures, as the exceptions won't be caught anymore and std::terminate() will be called. Your choice, tread carefully.
Comment 6 Jan Kundrát (RETIRED) gentoo-dev 2016-09-30 22:09:44 UTC
My TL;DR: code which triggers this is already broken.

(In reply to David Seifert from comment #5)
> I purposely told Toralf to add this flag, in order to catch cases where
> throw/noexcept semantics have changed (silently) between GCC 5 and GCC 6:
> https://gcc.gnu.org/gcc-6/porting_to.html If you're willing to ignore this,
> you risk runtime failures, as the exceptions won't be caught anymore and
> std::terminate() will be called. Your choice, tread carefully.

The warning in question comes from a QObject::~QObject where it attempts to catch exceptions thrown by slots connected to QObject::destroyed. In my humble opinion (I'm a mere Qt contributor with no upstream affiliation except a few patches), doing that *and* expecting the destructors to propagate exceptions through ~QObject is... futile. Any code which does that is effectively broken (and would be broken by USE=-exceptions, anyway).

The GCC change is a change from one C++ standard to another. My professional opinion is that it is a bad idea to compile ancient code designed with an old standard in mind against a new standard. There is always a chance to see breakage, and if upstream doesn't care about newer GCC standards, maybe we shouldn't force that upon them. This is *not* a distro-wide choice (unlike the choice of the libstdc++'s ABI).

You might want to patch this, sure. However, please note that this bug doesn't mean "ZOMG undefined behavior". It means that the application will now suddenly terminate() if and only if the following criteria are met:

- a slot connected to QObject::terminate throws an exception,
- the original object is not destroyed during stack unwinding as a result of another exception,
- USE=exceptions.

In my professional experience, code doing that is broken.
Comment 7 Davide Pesavento gentoo-dev 2016-10-01 11:32:55 UTC
(In reply to David Seifert from comment #5)
> (In reply to Davide Pesavento from comment #4)
> > Caused by CXXFLAGS="-Werror=terminate". You're not supposed to add this kind
> > of things to your build flags.
> 
> I purposely told Toralf to add this flag, in order to catch cases where
> throw/noexcept semantics have changed (silently) between GCC 5 and GCC 6:
> https://gcc.gnu.org/gcc-6/porting_to.html If you're willing to ignore this,
> you risk runtime failures, as the exceptions won't be caught anymore and
> std::terminate() will be called. Your choice, tread carefully.

We're going to force building Qt4 with -std=gnu++98 because it fails with C++11/14 in any case, so the above doesn't apply.