Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 595010

Summary: app-text/cuneiform-1.1.0-r1 with sys-devel/gcc-6.2.0-r1: error: call of overloaded 'abs(uint32_t)' is ambiguous
Product: Gentoo Linux Reporter: eroen <gentoo>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: normal CC: bircoph, ceamac.paragon, gentoo, kingjon3377, plevine457, proxy-maint, randy-andy-, rich0, rose, treecleaner, yaleks
Priority: Normal Keywords: PMASKED
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: masked only
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: build.log
patch for gcc-6.4.0
patch for strings.h

Description eroen 2016-09-24 10:40:56 UTC
Created attachment 447748 [details]
build.log

[ 65%] Building CXX object cuneiform_src/Kern/rimage/CMakeFiles/rimage.dir/sources/main/cricontrol.cpp.o
cd /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-1.1.0_build/cuneiform_src/Kern/rimage && /usr/bin/x86_64-pc-linux-gnu-g++  -D_USE_RVERLINE_ -D__RIMAGE__ -Drimage_EXPORTS -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/kronrod -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/deza -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/include -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/h -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hh -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hhh -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hdebug -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hrk -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hrkint -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hrstr -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/fon/src -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/usage -I/usr/include/ImageMagick-6 -I/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-1.1.0_build/cuneiform_src/Kern/include   -DNDEBUG -O2 -pipe  -fPIC   -fvisibility=hidden -DHAVE_GCCVISIBILITY -o CMakeFiles/rimage.dir/sources/main/cricontrol.cpp.o -c /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp
/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp: In member function 'Bool32 CRIControl::CreateDestinatonDIB(uint32_t)':
/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp:597:80: error: call of overloaded 'abs(uint32_t)' is ambiguous
  = (mbMarginsFlag ? abs(mrMargins.rmBottomMarg - mrMargins.rmTopMarg) : mpSourceDIB->GetLinesNumber());
                                                                     ^
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:75:0,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/stdlib.h:36,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cridefines.h:83,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.h:67,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp:66:
/usr/include/stdlib.h:774:12: note: candidate: int abs(int)
 extern int abs (int __x) __THROW __attribute__ ((__const__)) __wur;
            ^~~
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/stdlib.h:36:0,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cridefines.h:83,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.h:67,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp:66:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:185:3: note: candidate: __int128 std::abs(__int128)
   abs(__GLIBCXX_TYPE_INT_N_0 __x) { return __x >= 0 ? __x : -__x; }
   ^~~
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:180:3: note: candidate: long long int std::abs(long long int)
   abs(long long __x) { return __builtin_llabs (__x); }
   ^~~
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:172:3: note: candidate: long int std::abs(long int)
   abs(long __i) { return __builtin_labs(__i); }
   ^~~
/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp:598:79: error: call of overloaded 'abs(uint32_t)' is ambiguous
  = (mbMarginsFlag ? abs(mrMargins.rmLeftMarg - mrMargins.rmRightMarg) : mpSourceDIB->GetLineWidth());
                                                                     ^
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:75:0,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/stdlib.h:36,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cridefines.h:83,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.h:67,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp:66:
/usr/include/stdlib.h:774:12: note: candidate: int abs(int)
 extern int abs (int __x) __THROW __attribute__ ((__const__)) __wur;
            ^~~
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/stdlib.h:36:0,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cridefines.h:83,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.h:67,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rimage/sources/main/cricontrol.cpp:66:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:185:3: note: candidate: __int128 std::abs(__int128)
   abs(__GLIBCXX_TYPE_INT_N_0 __x) { return __x >= 0 ? __x : -__x; }
   ^~~
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:180:3: note: candidate: long long int std::abs(long long int)
   abs(long long __x) { return __builtin_llabs (__x); }
   ^~~
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/cstdlib:172:3: note: candidate: long int std::abs(long int)
   abs(long __i) { return __builtin_labs(__i); }
   ^~~
cuneiform_src/Kern/rimage/CMakeFiles/rimage.dir/build.make:182: recipe for target 'cuneiform_src/Kern/rimage/CMakeFiles/rimage.dir/sources/main/cricontrol.cpp.o' failed
make[2]: *** [cuneiform_src/Kern/rimage/CMakeFiles/rimage.dir/sources/main/cricontrol.cpp.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-1.1.0_build'
CMakeFiles/Makefile2:2081: recipe for target 'cuneiform_src/Kern/rimage/CMakeFiles/rimage.dir/all' failed
make[1]: *** [cuneiform_src/Kern/rimage/CMakeFiles/rimage.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/app-text/cuneiform-1.1.0-r1/work/cuneiform-1.1.0_build'
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: app-text/cuneiform-1.1.0-r1::gentoo failed (compile phase):
 *   emake failed
Comment 1 eroen 2016-09-24 10:41:24 UTC
localhost ~ # emerge --info '=app-text/cuneiform-1.1.0-r1::gentoo'
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0, gcc-6.2.0, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     4043380 total,   3149408 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 24 Sep 2016 00:45:01 +0000
sh bash 4.3_p46-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46-r1::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21.7::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 6.2.0-r1::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bindist bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx mmxext modules multilib ncurses nls nptl openmp pam pcre readline seccomp session sse sse2 ssl tcpd unicode xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

localhost ~ # emerge -pqv '=app-text/cuneiform-1.1.0-r1::gentoo'
[ebuild  N    ] app-text/cuneiform-1.1.0-r1  USE="imagemagick -debug -graphicsmagick" 

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.
Comment 2 Torsten Kurbad 2017-01-23 18:15:43 UTC
I can confirm this for gcc 6.3.0.
Comment 3 Richard Freeman gentoo-dev 2017-01-23 18:34:58 UTC
This is essentially unmaintained software at this point.  If somebody offers a patch I don't mind merging it, but if this becomes a blocker for the toolchain team I will probably allow treecleaning/etc.
Comment 4 Pacho Ramos gentoo-dev 2017-08-03 13:03:50 UTC
*** Bug 619574 has been marked as a duplicate of this bug. ***
Comment 5 Peter Levine 2017-10-11 02:02:12 UTC
The patch from http://bazaar.launchpad.net/~f0ma/cuneiform-linux/devel/revision/537 applies cleanly with 'patch -p0' and fixes the problem but is 20.74 KB.
Comment 6 Juergen Rose 2018-02-12 06:36:34 UTC
(In reply to Peter Levine from comment #5)
> The patch from
> http://bazaar.launchpad.net/~f0ma/cuneiform-linux/devel/revision/537 applies
> cleanly with 'patch -p0' and fixes the problem but is 20.74 KB.

If I add 537_536.diff getting from http://bazaar.launchpad.net/~f0ma/cuneiform-linux/devel/diff/537?context=3 to PATCHES in cuneiform-1.1.0-r2.ebuild, 'emerge -v1 cuneiform' fails with:
...
 * Applying 537_536.diff ...
2 out of 2 hunks FAILED -- saving rejects to file CMakeLists.txt.rej
The text leading up to this was:
--------------------------
|
|=== modified file 'cuneiform_src/Kern/dif/src/stick.h'
|--- cuneiform_src/Kern/dif/src/stick.h 2009-09-19 15:08:05 +0000
|+++ cuneiform_src/Kern/dif/src/stick.h 2017-06-01 17:55:52 +0000
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
The text leading up to this was:
--------------------------
|
|=== modified file 'cuneiform_src/Kern/fon/src/p2_clu.c'
|--- cuneiform_src/Kern/fon/src/p2_clu.c        2010-02-08 10:34:20 +0000
|+++ cuneiform_src/Kern/fon/src/p2_clu.c        2017-06-01 17:55:52 +0000
...
Comment 7 Viorel 2018-05-10 04:40:00 UTC
Created attachment 530668 [details, diff]
patch for gcc-6.4.0

It compiles with gcc 6.4.0.
Comment 8 Juergen Rose 2018-07-14 11:34:16 UTC
(In reply to Viorel from comment #7)
> Created attachment 530668 [details, diff] [details, diff]
> patch for gcc-6.4.0
> 
> It compiles with gcc 6.4.0.

Using the patch of comment #7 'MAKEOPTS=-j1 emerge -v1 cuneiform' failed with:

cd /var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-1.1.0_build/cuneiform_src/Kern/rblock && /usr/bin/x86_64-pc-linux-gnu-gcc -D_USE_RVERLINE_ -D__RBLOCK__ -Drblock_EXPORTS -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh/h -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/sources/main -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/sources/h -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/include -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/h -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hh -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hhh -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hdebug -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hrk -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hrkint -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/hrstr -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/fon/src -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/usage -I/usr/include/ImageMagick-7 -I/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-1.1.0_build/cuneiform_src/Kern/include   -DNDEBUG -march=native -O2 -pipe -fPIC   -fvisibility=hidden -DHAVE_GCCVISIBILITY -o CMakeFiles/rblock.dir/sources/new_c/_debug.c.o -c /var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/sources/new_c/_debug.c
In file included from /usr/include/string.h:431:0,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh/h/c_types.h:82,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh/h/iolib.h:65,
                 from /var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/sources/new_c/_debug.c:57:
/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh/h/strings.h:113:12: error: unknown type name uchar’
            uchar     language; // Pit 02-??-94
            ^~~~~
/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh/h/strings.h:122:12: error: unknown type name uint16_t’
            uint16_t     wFirst;
            ^~~~~~~~
/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh/h/strings.h:123:12: error: unknown type name uint16_t’
            uint16_t     wLast;
            ^~~~~~~~
/var/tmp/portage/app-text/cuneiform-1.1.0-r2/work/cuneiform-linux-1.1.0/cuneiform_src/Kern/rblock/../hhh/tigerh/h/strings.h:150:8: error: unknown type name ‘Bool’
 extern Bool bNeedFreeString;
        ^~~~
make[2]: *** [cuneiform_src/Kern/rblock/CMakeFiles/rblock.dir/build.make:89: cuneiform_src/Kern/rblock/CMakeFiles/rblock.dir/sources/new_c/_debug.c.o] Error 1



root@lynxold:/usr/local/portage/app-text/cuneiform(68)# emerge --info '=app-text/cuneiform-1.1.0-r2::local'
Portage 2.3.42 (python 3.6.6-final-0, default/linux/amd64/17.0/desktop, gcc-7.3.0, glibc-2.27-r5, 4.17.4-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.17.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-3630QM_CPU_@_2.40GHz-with-gentoo-2.6
KiB Mem:    16097892 total,   1184632 free
KiB Swap:   50331644 total,  49883644 free
Timestamp of repository gentoo: Sat, 14 Jul 2018 00:30:02 +0000
Head commit of repository gentoo: 8557fb2cb6bd978404b6ca3dccbdf4580a892060
sh bash 4.4_p23
ld GNU ld (Gentoo 2.30 p3) 2.30.0
distcc[5833] (dcc_trace_version) distcc 3.2rc1 x86_64-pc-linux-gnu; built Jan  5 2018 08:52:50 [disabled]
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.5.5-r1::gentoo, 3.6.6::gentoo, 3.7.0::gentoo
dev-util/cmake:           3.11.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r3::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r5::gentoo
Repositories:

gentoo
    location: /usr/portage_lynxold
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

imaging
    location: /var/lib/layman/imaging
    masters: gentoo
    priority: 0

local
    location: /usr/local/portage
    masters: gentoo
    priority: 1

g-cpan
    location: /var/lib/cpan
    masters: gentoo
    priority: 2

g-octave
    location: /var/lib/g-octave
    masters: gentoo
    priority: 3

ago
    location: /var/lib/layman/ago
    masters: gentoo
    priority: 50

sage-on-gentoo
    location: /var/lib/layman/sage-on-gentoo
    masters: gentoo science
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

tlp
    location: /var/lib/layman/tlp
    masters: gentoo
    priority: 50

x11
    location: /var/lib/layman/x11
    masters: gentoo
    priority: 50

Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA NVIDIA-CUDA Nero-AAC-EULA GIMPS"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en fr ru"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 amr ao apache2 apng applet archive armadillo arpack asf aspell assistant atlas audiofile aufs automap automount barcode bash-completion berkdb blas blast bluetooth bluray boost branding btrfs bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cilk clang cli cmake collada consolekit contrib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia digitalradio djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evdev evo examples excel exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx ftp fuse gcj gd gdal gdbm gedit geoip geolocation geos gfortran gif gimp git glade glamor glib glpk gml gmp gnome gnome-keyring gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile hdaps hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jadetex java jbig jit john jpeg jpeg2k kate kde kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack latex lcms ldap lensfun libffi libgda libkms libnotify libsamplerate libtirpc lirc live lm_sensors lua lzma lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mpi-threads mplayer mtp multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg opencv openexr opengl openmp openvg pam pango pcre pda pdf pdl2 perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds ppp preview-latex proj projectm pstricks pulseaudio python q16 q32 qemu qhull qml qt5 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool rtlsdr sage samba sasl schroedinger science sdk sdl seccomp secure-delete server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite ssl startup-notification stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tbb tcl tcpd tex tex4ht theora thesaurus thinkpad threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb utempter v4l v4l2 vaapi vala valgrind vdpau video vim-syntax virt-network virtualbox visio vorbis vpx vtk wav wayland webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xen xetex xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zsh-completion zvbi" ABI_X86="64" ALSA_CARDS="intel8x0" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="karbon plan sheets stage words" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog sensors thermal" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="aivdm ashtech earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 navcom ntrip oceanserver oncore rtcm104v2 rtcm104v3 sirf superstar2 tnt tripmate tsip ublox nmea0183 nmea2000 passthrough" GRUB_PLATFORMS="emu efi-64 pc xen" INPUT_DEVICES="keyboard mouse evdev synaptics void" KERNEL="linux" L10N="de en fr ru" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd SureElec" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LIRC_DEVICES="devinput" LLVM_TARGETS="NVPTX X86" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5 python3_6" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="nouveau intel i965 displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



root@lynxold:/usr/local/portage/app-text/cuneiform(69)# emerge -pqv '=app-text/cuneiform-1.1.0-r2::local'
[ebuild  N    ] app-text/cuneiform-1.1.0-r2  USE="-debug -graphicsmagick"
Comment 9 Viorel 2018-07-14 19:44:05 UTC
Created attachment 539576 [details, diff]
patch for strings.h

System provided string.h includes strings.h, but somehow ends up including a file also named strings.h that comes with cuneiform instead of the one in /usr/include.  I think this should be fixed from cmake (or even glibc), but as a quick workaround I moved cttypes.h above string.h and it compiles.

The previous patch (gcc-6.4) is still needed for gcc 7.3.0.
Comment 10 Juergen Rose 2018-07-15 15:25:46 UTC
(In reply to Viorel from comment #9)
> Created attachment 539576 [details, diff] [details, diff]
> patch for strings.h
> 
> System provided string.h includes strings.h, but somehow ends up including a
> file also named strings.h that comes with cuneiform instead of the one in
> /usr/include.  I think this should be fixed from cmake (or even glibc), but
> as a quick workaround I moved cttypes.h above string.h and it compiles.
> 
> The previous patch (gcc-6.4) is still needed for gcc 7.3.0.

Thanks Viorel, now I was again able to emerge cuneiform.
Comment 11 Larry the Git Cow gentoo-dev 2018-11-14 22:32:28 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a8519bd2c58428d730f61140cd4a843ce68033b3

commit a8519bd2c58428d730f61140cd4a843ce68033b3
Author:     Pacho Ramos <pacho@gentoo.org>
AuthorDate: 2018-11-14 22:30:33 +0000
Commit:     Pacho Ramos <pacho@gentoo.org>
CommitDate: 2018-11-14 22:32:15 +0000

    app-text/cuneiform: Bugfixes from Fedora
    
    Closes: https://bugs.gentoo.org/421717
    Closes: https://bugs.gentoo.org/595010
    Closes: https://bugs.gentoo.org/670656
    Signed-off-by: Pacho Ramos <pacho@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 app-text/cuneiform/cuneiform-1.1.0-r3.ebuild       |  59 +++++++
 .../cuneiform-1.1.0-fix_buffer_overflow.patch      |  27 ++++
 .../cuneiform-1.1.0-fix_buffer_overflow_2.patch    |  18 +++
 .../cuneiform/files/cuneiform-1.1.0-gcc6.patch     | 177 +++++++++++++++++++++
 .../cuneiform/files/cuneiform-1.1.0-gcc7.patch     | 102 ++++++++++++
 .../cuneiform/files/cuneiform-1.1.0-typos.patch    |  54 +++++++
 6 files changed, 437 insertions(+)