Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 593070

Summary: =dev-libs/nss-3.27.2 stabilization
Product: Gentoo Linux Reporter: Uwe Sauter <uwe>
Component: Current packagesAssignee: Mozilla Gentoo Team <mozilla>
Status: RESOLVED FIXED    
Severity: normal CC: pacho
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
=dev-libs/nss-3.27.2
Runtime testing required: ---
Bug Depends on: 604916    
Bug Blocks: 604500    

Description Uwe Sauter 2016-09-07 17:28:30 UTC
Firefox 48 is out since Aug. 3rd but depends on >=dev-libs/nss-3.24.

Please stabilize one of the available versions greater than 3.23.
Comment 1 Uwe Sauter 2016-09-22 17:06:33 UTC
Firefox 49 is out since Sep. 20th but depends on >=dev-libs/nss-3.25.

Please stabilize one of the available versions greater than 3.24.
Comment 2 Ian Stakenvicius (RETIRED) gentoo-dev 2016-09-22 17:23:35 UTC
Not that I'm against stabilizing nss-3.25 , I just wanted to make sure it's known that firefox-49 will not go stable and so this is not a requirement for stabilizing any mozilla packages.

As to the specifics, I don't know if nss-3.25-r1 or nss-3.26 should be the stable candidate; will confirm and CC arches.
Comment 3 Uwe Sauter 2016-09-22 18:24:40 UTC
Out of curiosity: what do you mean firefox 49 won't go stable?
Comment 4 Ian Stakenvicius (RETIRED) gentoo-dev 2016-09-23 12:47:07 UTC
(In reply to Uwe Sauter from comment #3)
> Out of curiosity: what do you mean firefox 49 won't go stable?

Firefox releases a new major version every 6 weeks, and each major version fixes security vulnerabilities that were in the previous major version.  As stabilizing generaly takes 4 out of those 6 weeks, we would have 2 weeks of stabilization and then be stuck with 4 weeks of a known-vunlerable version being stable when the next release comes out.

Instead, we stabilize the "ESR" versions, which at this time are the 45.x series.  Minor updates contain the same security fixes while not changing functionality and therefore not requiring the same duration for stabilization.
Comment 5 Uwe Sauter 2016-09-23 15:44:14 UTC
I wans't aware of this practice. Thanks for pointing out.
Comment 6 charles17 2016-10-06 09:42:21 UTC
Please stabilize dev-libs/nss-3.25-r1
Comment 7 Pacho Ramos gentoo-dev 2016-12-05 20:25:25 UTC
what version should be stabilized? (if any finally) 

or maybe we should simply close this and wait for the next firefox stabilization?
Comment 8 Lars Wendler (Polynomial-C) gentoo-dev 2016-12-23 10:07:15 UTC
I'd say, let's go with =dev-libs/nss-3.27.2

@mozilla team: Any objections?
Comment 9 Jory A. Pratt gentoo-dev 2016-12-23 21:35:36 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #8)
> I'd say, let's go with =dev-libs/nss-3.27.2
> 
> @mozilla team: Any objections?

that is what is needed.
Comment 10 Lars Wendler (Polynomial-C) gentoo-dev 2017-01-03 12:25:11 UTC
Arches please test and mark stable =dev-libs/nss-3.27.2 with target KEYWORDS:

alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris

This is required for =www-client/seamonkey-2.46 stabilization.
Comment 11 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2017-01-04 14:37:41 UTC
amd64 stable
Comment 12 Agostino Sarubbo gentoo-dev 2017-01-04 15:35:19 UTC
x86 stable
Comment 13 Tobias Klausmann (RETIRED) gentoo-dev 2017-01-06 14:33:14 UTC
Stable on alpha.
Comment 14 Markus Meier gentoo-dev 2017-01-08 18:17:30 UTC
arm stable
Comment 15 Thomas Deutschmann gentoo-dev 2017-01-08 21:48:50 UTC
Superseded by bug 604916.