Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 592840

Summary: www-client/firefox-48.0.1 with gcc-6 needs -flifetime-dse=1 or it segfaults
Product: Gentoo Linux Reporter: Martin Väth <martin>
Component: Current packagesAssignee: Mozilla Gentoo Team <mozilla>
Status: RESOLVED FIXED    
Severity: normal CC: josef64, laine.gholson, robink
Priority: Normal Keywords: InOverlay
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: emerge --info firefox
gdb bt
append proper support flags for gcc6

Description Martin Väth 2016-09-04 06:40:12 UTC
If firefox-48.0.1 is compiled with gcc-6.2.0, it segfaults at startup even with an empty profile. Adding -flifetime-dsa=1 fixes the problem.
Comment 1 Jory A. Pratt gentoo-dev 2016-09-04 08:07:01 UTC
(In reply to Martin Väth from comment #0)
> If firefox-48.0.1 is compiled with gcc-6.2.0, it segfaults at startup even
> with an empty profile. Adding -flifetime-dsa=1 fixes the problem.

emerge info and a backtrace is required before mozilla team will be able to do anything please.
Comment 2 Martin Väth 2016-09-04 13:14:42 UTC
Created attachment 444948 [details]
emerge --info firefox
Comment 3 Martin Väth 2016-09-04 13:18:08 UTC
Created attachment 444950 [details]
gdb bt

The backtrace corresponds to emerge --info (USE=-gtk2),
but the segfault occurs also with USE=gtk2
Comment 4 Peter Levine 2016-09-21 21:41:37 UTC
Possibly related to:

https://bugzilla.mozilla.org/show_bug.cgi?id=1232696
Comment 5 Martin Väth 2016-09-27 17:46:31 UTC
Just for the records: Same issue with firefox-49.0
Comment 6 Jory A. Pratt gentoo-dev 2016-10-09 14:11:18 UTC
Created attachment 449664 [details, diff]
append proper support flags for gcc6

Feel free to test this, you should exclude the included gcc-6 support patch from the build
Comment 7 Jory A. Pratt gentoo-dev 2016-10-16 16:22:26 UTC
>=Firefox-49 is now supported via tree with gcc-6 thanks for reporting.