Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 592588

Summary: app-text/fbreader-0.99.4-r2: building w/gcc-6: OleStorage.cpp:62:83: error: narrowing conversion of '208' from 'int' to 'char' inside { } [-Wnarrowing]
Product: Gentoo Linux Reporter: Francesco Turco <mail>
Component: Current packagesAssignee: Andrey Grozin <grozin>
Status: RESOLVED FIXED    
Severity: normal Keywords: PATCH
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://github.com/geometer/FBReader/issues/289
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: build log for fbreader-0.99.4-r2 using gcc-6.2.0
emerge --info
fixes narrowing conversion problem

Description Francesco Turco 2016-08-31 12:58:20 UTC
Created attachment 444632 [details]
build log for fbreader-0.99.4-r2 using gcc-6.2.0

After upgrading to GCC 6.2.0 the following package cannot be built anymore: app-text/fbreader-0.99.4-r2. It used to work with GCC 5.4.0

-----------

# emerge -pv fbreader

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-text/fbreader-0.99.4-r2::gentoo  USE="-debug" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Comment 1 Francesco Turco 2016-08-31 12:58:39 UTC
Created attachment 444634 [details]
emerge --info
Comment 2 Francesco Turco 2016-08-31 15:18:33 UTC
https://github.com/geometer/FBReader/issues/289
Comment 3 Francesco Turco 2016-08-31 15:36:58 UTC
Created attachment 444648 [details, diff]
fixes narrowing conversion problem
Comment 4 Andrey Grozin gentoo-dev 2016-09-01 03:18:55 UTC
Thanks, applied

commit 8f57005559c5aa0c9596f9ded42186b7e82410f2
Author: Andrey Grozin <grozin@gentoo.org>
Date:   Thu Sep 1 10:17:16 2016 +0700

    app-text/fbreader: make gcc6 happy
    
    Bug: 592588
    
    Package-Manager: portage-2.3.0