Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 5918

Summary: postgresql and non-working ant
Product: Gentoo Linux Reporter: David Rose <doppler>
Component: Current packagesAssignee: Ryan Phillips (RETIRED) <rphillips>
Severity: normal CC: esigra, jnials, karltk, mkennedy, mmc
Priority: High    
Version: unspecified   
Hardware: PPC   
OS: Linux   
Package list:
Runtime testing required: ---

Description David Rose 2002-08-02 12:40:39 UTC
# emerge --pretend --update world

These are the packages that I would merge, in order.

Calculating world dependencies |
!!! Error: couldn't find match for =dev-lang/python-2.1* in
adding a stub for python-2.1 did not fix the problem, nor did removing
dependencies cache.

masking <=postgresql-7.1.3-r4 results in 
Error: couldn't find match for =dev-db/postgresql-7.1.3* in
so I'm afraid of ending up in RPM-like hell :-/
Comment 1 Richard Seymour 2002-08-09 10:28:34 UTC
the postgresql-7.2.1-r2.ebuild seems to be broken in a couple places:
line 19:
  tcltk? ( >=dev-lang/tcl-8 )
should be:
  tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )

same issue on line 28.

The exact release of tk doesn't have to be so high, but whatever.

Also, the java line, is there any reason to have a * after jdk-1.3?

That doesn't seem necessary or syntactically correct to me.

If I had cvs rights I would commit my fixes now, but I'm probably missing
something anyway.

Comment 2 Mark Guertin 2002-08-25 18:05:42 UTC
I was just assigned this and know nothing at all of postgres, and am extremely 
tied up making new release, can anyone in the know of postgres look at this?   
Comment 3 Mark Guertin 2002-08-26 12:01:37 UTC
doppler: can you test the new release ( from the GLSA this morning) that was
posted to see if there are still problems?  THere is no PPC keyword in it yet so
you'll have to merge it directly.
Comment 4 David Rose 2002-08-26 13:50:38 UTC
The problem exists with postgresql-7.2.2 as well as 7.2.1-r2 and probably lower
versions, too. The ./configure fails at

configure: error: ant does not work

I imagine the bug is actually in dev-java/ant
Comment 5 Ryan Phillips (RETIRED) gentoo-dev 2002-08-28 13:13:57 UTC
the fixes to the dependencies were committed.
Comment 6 Jon Nials 2002-08-31 09:08:57 UTC
There seems to be an additional problem here, it probably should be a separate
bug.  Ant seems to not process the buildfile properly, not generating the
classfile when passed the buildfile.  Here is the relevant section from the

configure:1879: checking for ant
configure:1916: checking whether /usr/bin/ant works
configure:1939: /usr/bin/ant -buildfile conftest.xml 1>&2
Buildfile: conftest.xml
configure: failed java program was:
public class conftest {
    int testmethod(int a, int b) {
        return a + b;
configure: failed build file was:
<project name="conftest" default="conftest">
 <target name="conftest">
  <javac srcdir="." includes="">
Comment 7 Karl Trygve Kalleberg (RETIRED) gentoo-dev 2002-09-01 12:02:32 UTC
I fail to be able to reproduce this problem here. 

Please make certain you have run java-config --set-system-vm=blackdown-jdk-1.3.1
(or any other VM you have installed) before you try to merge postgresql-7.2.2
Comment 8 Jon Nials 2002-09-01 17:47:45 UTC
Yup.  I have tried with three different jdk's.  Here is my current:

gentoo root # java-config --java-version
java version "1.3.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1)
Classic VM (build 1.3.1, J2RE 1.3.1 IBM build cxia32131-20020410 (JIT enabled:

I have tried with the Sun JDK 1.3.1 and with the Sun 1.4.0 JDK.

I have also extracted the code and run it by hand.  Ant still fails to generate
the file.  
Comment 9 Dominik Westner 2002-09-27 05:40:09 UTC
this fixed the problem for me:

changing /usr/bin/ant from:

JAVA_HOME=`grep "^JAVA_HOME" $envfile | sed "s/JAVA_HOME=//"`


JAVA_HOME=`java-config --jdk-home`

Now I am stuck when compiling postgresql:
distcc gcc -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2
-march=pentiu../src/include   -c -o heaptuple.o heaptuple.c -MMD
cp: cannot stat `heaptuple.d': No such file or directory
Comment 10 Lars Weiler (RETIRED) gentoo-dev 2004-02-15 11:10:03 UTC
Old, old, old bug...  Why is it still a reminder?
Comment 11 Ryan Phillips (RETIRED) gentoo-dev 2004-02-15 17:26:35 UTC
Does anyone still have this bug?  I think it can be closed.
Comment 12 Lars Weiler (RETIRED) gentoo-dev 2005-03-30 04:21:39 UTC
Just changing from REMIND to CLOSED.
Comment 13 Aaron W. Swenson gentoo-dev 2011-05-15 19:41:27 UTC
Closing this for real now.