Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 590630

Summary: media-gfx/shotwell-0.23.4: Improper LINGUAS conversion
Product: Gentoo Linux Reporter: Ulrich Müller <ulm>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: graphics+disabled, hwoarang, mgorny
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 586734    

Description Ulrich Müller gentoo-dev 2016-08-06 12:39:11 UTC
shotwell-0.23.4.ebuild uses L10N instead of LINGUAS now, which appears to be incorrect. AFAICS, the only localisation installed by shotwell are *.mo files which should be controlled by LINGUAS not L10N.
Comment 1 Pacho Ramos gentoo-dev 2016-08-07 09:43:35 UTC
?

When should we then use LINGUAS uses or L10N? I thought LINGUAS USEs were going to be replaced by L10N...

Or are you referring that all that crappy linguas handling (inherited from older ebuilds) need to be dropped entirely?
Comment 2 Ulrich Müller gentoo-dev 2016-08-07 11:53:50 UTC
(In reply to Pacho Ramos from comment #1)
> When should we then use LINGUAS uses or L10N? I thought LINGUAS USEs were
> going to be replaced by L10N...

The rule of thumb is if LINGUAS is supported upstream then the ebuild should use it too.

> Or are you referring that all that crappy linguas handling (inherited from
> older ebuilds) need to be dropped entirely?

In the ideal case the LINGUAS variable should simply be passed to the upstream build system. So the only thing the ebuild should do (during the transition time until LINGUAS is removed as an USE_EXPAND variable) is to add the relevant linguas_* flags to IUSE.
Comment 3 Pacho Ramos gentoo-dev 2016-08-07 14:41:57 UTC
if I don't misremember, in this case linguas wasn't supported by upstream, but the previous maintainers of the ebuild started to use downstream linguas_ USE flags to remove the installation of some locales. Now upstream is moving to a more standard "autotools" build system, but that custom handling of linguas is still used.

I would simply kill all the linguas handling and leave the package what he wants (in this case I think it will install all locales as it's still not honoring the LINGUAS variable as other projects under gnome umbrella are doing)... then we will hit some reporters sending bugs because they don't want to "waste" their previous space on unwanted locales and neither want to run localepurge... but I guess I will simply ignore that requests :S
Comment 4 Ulrich Müller gentoo-dev 2016-08-07 19:05:38 UTC
(In reply to Pacho Ramos from comment #3)
> I would simply kill all the linguas handling and leave the package what he
> wants (in this case I think it will install all locales as it's still not
> honoring the LINGUAS variable as other projects under gnome umbrella are
> doing)... then we will hit some reporters sending bugs because they don't
> want to "waste" their previous space on unwanted locales and neither want to
> run localepurge... but I guess I will simply ignore that requests :S

Any such requests should be reported upstream. If the build system doesn't handle LINGUAS as intended, then this a general problem of the package, not something we should be bothered with on the distro level.
Comment 5 Pacho Ramos gentoo-dev 2016-08-07 20:38:43 UTC
I know, and upstream is still migrating to a more standard buildsystem, but we are now like in an "intermediate" situation between the completely custom build system previous versions had and this one
Comment 6 Pacho Ramos gentoo-dev 2016-08-07 20:41:43 UTC
Anyway, in the next bump I will probably simply drop our linguas handling completely
Comment 7 Pacho Ramos gentoo-dev 2016-09-17 12:23:44 UTC
[master 734c8c6] media-gfx/shotwell: Version bump, stop building static, itstool is needed (#592132), stop hacking linguas support (#590630)
 2 files changed, 62 insertions(+)
 create mode 100644 media-gfx/shotwell/shotwell-0.23.7.ebuild