Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 589182

Summary: sci-libs/vtk-6.1.0-r1 will not build error: 'Open' is not a member of 'OGRSFDriverRegistrar'
Product: Gentoo Linux Reporter: deference
Component: Current packagesAssignee: Gentoo Science Related Packages <sci>
Status: UNCONFIRMED ---    
Severity: normal CC: deference, java
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log
emerge --info

Description deference 2016-07-19 20:06:59 UTC
Created attachment 441156 [details]
build.log

[ebuild   R   ] sci-libs/vtk-6.1.0-r1  USE="R X boost doc ffmpeg gdal imaging java json mpi mysql odbc postgres python qt4 rendering smp tbb tcl theora tk views xdmf2 -all-modules (-aqua) -cg (-examples) -kaapi -offscreen {-test} -web" PYTHON_TARGETS="python2_7" VIDEO_CARDS="-nvidia"
Comment 1 deference 2016-07-19 20:07:45 UTC
Created attachment 441160 [details]
emerge --info
Comment 2 Patrice Levesque 2016-12-30 06:52:08 UTC
Had the same problem, emerging =sci-libs/vtk-6.1.0-r3 fixed it for me (via vtk-6.1.0-gdal2.patch that gets applied from that revision on).