Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 588494

Summary: sys-devel/binutils-2.26.1: version bump request
Product: Gentoo Linux Reporter: Cănărău Constantin <canarauc>
Component: Current packagesAssignee: Gentoo Toolchain Maintainers <toolchain>
Severity: normal CC: franz.trischberger, ua_gentoo_bugzilla
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Cănărău Constantin 2016-07-10 07:46:43 UTC
binutils-2.26.1 was released on 1 Jul 2016 and it seems to be in a better shape than ver. 2.26 was back in January.

I bumped it in my local overlay, vanilla version, no gentoo patches was applied and I was able to recompile all world packages without any issues. However, I miss official gentoo patches so please bump it if you think is ready.

Thank you!

My emerge --info
Portage 2.3.0 (python 3.5.1-final-0, default/linux/amd64/13.0/no-multilib, gcc-6.1.0, glibc-2.23-r2, 4.6.3-gentoo-costel x86_64)
System uname: Linux-4.6.3-gentoo-costel-x86_64-Intel-R-_Core-TM-_i7-6700K_CPU_@_4.00GHz-with-gentoo-2.2
KiB Mem:    31854964 total,  20957476 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sun, 10 Jul 2016 04:45:01 +0000
sh bash 4.3_p46
ld GNU ld (Gentoo 2.26.1) 2.26.1
app-shells/bash:          4.3_p46::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.5.1-r3::gentoo
dev-util/cmake:           3.6.0::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2-r1::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.26.1-r1::newer
sys-devel/gcc:            6.1.0::newer
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-extra-opts: --human-readable --delete-before --progress
    sync-rsync-vcs-ignore: true

    location: /usr/portage/local/added
    masters: gentoo
    priority: 30

    location: /usr/portage/local/newer
    masters: gentoo
    priority: 30

    location: /usr/portage/local/python
    masters: gentoo
    priority: 30

    location: /usr/portage/local/mv
    sync-type: laymansync
    sync-uri: git://
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=native -mtune=skylake -w -flto=8 -fuse-linker-plugin -ffat-lto-objects -fuse-ld=gold -fgraphite-identity -floop-interchange -floop-strip-mine -floop-block"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -mtune=skylake -w -flto=8 -fuse-linker-plugin -ffat-lto-objects -fuse-ld=gold -fgraphite-identity -floop-interchange -floop-strip-mine -floop-block -fno-delete-null-pointer-checks -flifetime-dse=1"
EMERGE_DEFAULT_OPTS="--jobs=3 --load-average=12 --keep-going --with-bdeps=y --complete-graph --quiet-build=n --autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy cgroup collision-protect config-protect-if-modified distlocks fail-clean fixlafiles ipc-sandbox merge-sync news nodoc noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-filter unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1,--sort-common,--hash-style=gnu,--as-needed,-z,now -O2 -pipe -march=native -mtune=skylake -w -flto=8 -fuse-linker-plugin -ffat-lto-objects -fuse-ld=gold -fgraphite-identity -floop-interchange -floop-strip-mine -floop-block -fno-delete-null-pointer-checks -flifetime-dse=1"
MAKEOPTS="-j8 --load-average=16"
PORTAGE_RSYNC_EXTRA_OPTS="--human-readable --delete-before --progress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi aes alsa amd64 avx avx2 berkdb branding bzip2 cairo cdda cdr cli colord cracklib crypt cups custom-cflags custom-optimization cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fma3 gdbm gif glamor gmp gnome gnome-keyring gpm gstreamer gtk gtk3 iconv icu introspection ipv6 jemalloc jpeg lcms libnotify libsecret logrotate lz4 mad mmx mmxext mng modules mp3 mp4 mpeg mysql nautilus ncurses networkmanager nls nptl ogg opengl openmp pam pango pch pcre pdf png policykit popcnt ppds pulseaudio python readline sdl seccomp server session spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upower usb vaapi vdpau vhosts vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" L10N="ro en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ro en" NETBEANS_MODULES="apisupport extide php webcommon" NGINX_MODULES_HTTP="access addition auth_basic autoindex browser cache_purge charset dav dav_ext echo empty_gif fancyindex fastcgi flv geo geoip gunzip gzip headers_more image_filter limit_conn limit_req map memc memcached metrics mp4 naxsi perl random_index realip referer rewrite scgi secure_link split_clients ssi sticky stub_status sub upload_progress upstream_ip_hash userid uwsgi xslt" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-0" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.5"
Comment 1 Cănărău Constantin 2016-07-13 12:06:31 UTC
Thank you! 

It can be closed.
Comment 2 SpanKY gentoo-dev 2016-07-20 04:43:50 UTC
the version bump posted was premature.  i'll close this when the fixed 2.26.1-r1 is out.
Comment 3 Joshua Kinard gentoo-dev 2016-09-04 07:47:13 UTC
(In reply to SpanKY from comment #2)
> the version bump posted was premature.  i'll close this when the fixed
> 2.26.1-r1 is out.

Mike, it looks like 2.27 is out now.  Is a 2.26.1-r1 needed, or would it make sense to go to 2.27?
Comment 4 Cănărău Constantin 2016-09-04 08:40:50 UTC
In case it is useful, I am using 2.27-r1 from poly-c overlay and there are no issue.
Comment 5 Franz Trischberger 2016-09-05 10:51:11 UTC
(In reply to SpanKY from comment #2)
> the version bump posted was premature.  i'll close this when the fixed
> 2.26.1-r1 is out.

Could you please mask that buggy version? I ran into issues after a simple emerge --sync yesterday (no packages installed, updated, uninstalled, ...) with linking, e.g. libpng:
error: .libs/pngwrite.o: unsupported reloc 42 against global symbol png_sRGB_delta
It took me hours, then I simply set binutils in eselect binutils to 2.26.1 and the issues were solved. Now I face different issues with llvm-3.9.0 + lto, no idea if that's related...
Comment 6 SpanKY gentoo-dev 2016-11-12 08:06:53 UTC
2.26.1 is in the tree and it's been too long to bother redoing it since 2.27 is out now.  handling 2.27 via bug 595148 instead.