Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 58597

Summary: sys-darwin/bootstrap_cmds-44.ebuild (New Package)
Product: Gentoo Linux Reporter: Kito (RETIRED) <kito>
Component: New packagesAssignee: osx porters <osx>
Status: VERIFIED FIXED    
Severity: enhancement CC: gongloo, pvdabeel, strattbo
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 59994, 60025    
Attachments: bootstrap_cmds.ebuild Initial Submission
bootstrap_cmds initial submission r2
updated bootstrap_cmds ebuild
bootstrap_cmds initial submission

Description Kito (RETIRED) gentoo-dev 2004-07-27 16:24:06 UTC
Hello =)

Attaching bootstrap_cmds.ebuild for Darwin/OSX

Darwin bootstrap_cmds(including relpath) required for building xnu

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



PoBo:/usr/portage/sys-darwin/bootstrap_cmds keetz$ emerge info
Password:
!!! Using `which gcc` to gcc locate version, this may break
!!! DISTCC, installing gcc-config and setting your current gcc
!!! profile will fix this
Portage 20040726 (default-macos-10.3, gcc-3.3, unavailable, 7.4.0 Power Macintosh powerpc)
===============================================================
==
System uname: 7.4.0 Power Macintosh powerpc
macos-20040726
distcc 2.0.1-zeroconf powerpc-apple-darwin7.0 (protocol 1) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.57,sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.6.3,sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.3-r3
ACCEPT_KEYWORDS="macos ~macos"
AUTOCLEAN="yes"
CFLAGS="-mcpu=7450 -mabi=altivec -maltivec -O2 -pipe "
CHOST="powerpc-apple-darwin"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/
qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=7450 -mabi=altivec -maltivec -O2 -pipe "
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect cvs keepwork"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/Users/keetz/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="macos altivec berkdb ldap mysql perl python ruby"

PoBo:/usr/portage/sys-darwin/bootstrap_cmds keetz$ emerges
app-editors/nano-1.3.3-r1
app-portage/gentoolkit-0.2.0_pre8
app-portage/gentoolkit-dev-0.2.0_pre3
dev-python/python-fchksum-1.6.1-r1
dev-util/dialog-0.9_beta20031207
media-sound/lame-3.96
net-im/naim-0.11.7.2
net-misc/wget-1.9.1-r2
sys-apps/debianutils-1.16.7-r4
sys-apps/help2man-1.33.1
sys-darwin/bootstrap_cmds-44
sys-devel/autoconf-2.59-r4
sys-devel/automake-1.8.5-r1
sys-devel/binutils-2.15.90.0.3-r3
sys-devel/gnuconfig-20040214
sys-libs/libsystem-7.1
Comment 1 Kito (RETIRED) gentoo-dev 2004-07-27 16:25:24 UTC
Created attachment 36288 [details]
bootstrap_cmds.ebuild Initial Submission
Comment 2 Kito (RETIRED) gentoo-dev 2004-08-03 13:48:35 UTC
Created attachment 36711 [details]
bootstrap_cmds initial submission r2

Added NEXTSTEP_INSTALLDIR in the install to correct installation if relpath in
/usr/local/bin.
All subprojects(decomment,migcom, config, ver_string) now succesfully build and
install
Comment 3 Kito (RETIRED) gentoo-dev 2004-08-10 11:59:59 UTC
Created attachment 37158 [details]
updated bootstrap_cmds ebuild
Comment 4 Kito (RETIRED) gentoo-dev 2004-08-10 12:01:05 UTC
sys-darwin/bootstrap_cmds should be taken out of the default macos profile
Comment 5 Thomas Stratmann 2004-08-23 13:32:43 UTC
This installs temp files in /tmp during compilation. See bug 61287 as well.
Comment 6 Kito (RETIRED) gentoo-dev 2004-08-23 14:07:13 UTC
Created attachment 38049 [details]
bootstrap_cmds initial submission
Comment 7 Thomas Stratmann 2004-08-23 14:18:47 UTC
*** Bug 61287 has been marked as a duplicate of this bug. ***
Comment 8 Kito (RETIRED) gentoo-dev 2004-09-27 11:49:45 UTC
in CVS
Comment 9 Hasan Khalil (RETIRED) gentoo-dev 2005-02-06 13:33:30 UTC
Closing out bugs that've been resolved for a while now...