Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 582618

Summary: dev-qt/qtxmlpatterns-4.8.7 fails to build with gcc-6
Product: Gentoo Linux Reporter: Peter Levine <plevine457>
Component: Current packagesAssignee: Qt Bug Alias <qt>
Status: RESOLVED FIXED    
Severity: normal CC: carlphilippreh, jrmalaq, mail, plevine457, toralf
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 582084    
Attachments: qtxmlpatterns-5.6.0:20160502-050831.log.gz
emerge --info
qtxmlpatterns-4.8.7-gcc6.patch

Description Peter Levine 2016-05-10 03:00:39 UTC
Using gcc-6* to compile dev-qt/qtxmlpatterns-4.8.7 fails with

/var/tmp/portage/dev-qt/qtxmlpatterns-4.8.7/work/qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h:74:59: error: shift expression '(1048575 << 20)' overflows [-fpermissive]'
Comment 1 Peter Levine 2016-05-10 03:02:06 UTC
Created attachment 433810 [details]
qtxmlpatterns-5.6.0:20160502-050831.log.gz
Comment 2 Peter Levine 2016-05-10 03:04:46 UTC
Created attachment 433812 [details]
emerge --info
Comment 3 Peter Levine 2016-05-10 03:06:53 UTC
Created attachment 433814 [details, diff]
qtxmlpatterns-4.8.7-gcc6.patch

Patch for qtxmlpatterns-4.8.7 to effectively compile with gcc-6*.

Taken from http://pkgs.fedoraproject.org/cgit/rpms/qt.git/tree/qt-everywhere-opensource-src-4.8.7-gcc6.patch
Comment 4 Davide Pesavento gentoo-dev 2016-09-22 17:32:38 UTC
*** Bug 594784 has been marked as a duplicate of this bug. ***
Comment 5 Michael Palimaka (kensington) gentoo-dev 2016-09-23 18:17:07 UTC
*** Bug 594932 has been marked as a duplicate of this bug. ***
Comment 6 Michael Palimaka (kensington) gentoo-dev 2016-10-07 14:44:16 UTC
*** Bug 596456 has been marked as a duplicate of this bug. ***