Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 580768

Summary: dev-db/mongodb-3.2.5 : src/.../mmap_v1_engine.cpp:170:70: error: 'major' was not declared in this scope
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Ultrabug <ultrabug>
Status: RESOLVED FIXED    
Severity: normal CC: hydrapolic, johannes.hirte, julien, keeperofdakeys, proxy-maint, x
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 575232    
Attachments: dev-db:mongodb-3.2.5:20160421-194647.log
emerge-history.txt
environment
mongodb-3.4.4-glibc.2.25.patch

Description Toralf Förster gentoo-dev 2016-04-21 22:00:12 UTC
This bug report feeds bug #575232 (sys-libs/glibc-2.23-r1 breakage).


x86_64-pc-linux-gnu-g++ -o build/opt/mongo/db/storage/mmap_v1/mmap_v1_engine.o -c -pipe -std=c++11 -fno-omit-frame-pointer -fPIC -fno-strict-aliasing -pthread -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -O2 -Wno-unused-local-typedefs -Wno-unused-function -Wno-deprecated-declarations -Wno-unused-but-set-variable -Wno-missing-braces -fno-builtin-memcmp -DNDEBUG -DBOOST_THREAD_VERSION=4 -DBOOST_THREAD_DONT_PROVIDE_VARIADIC_THREAD -DBOOST_SYSTEM_NO_DEPRECATED -Isrc/third_party/asio-asio-1-11-0/asio/include -Isrc/third_party/s2 -Ibuild/opt -Isrc src/mongo/db/storage/mmap_v1/mmap_v1_engine.cpp
src/mongo/db/storage/mmap_v1/mmap_v1_engine.cpp: In function 'void mongo::{anonymous}::checkReadAhead(const string&)':
src/mongo/db/storage/mmap_v1/mmap_v1_engine.cpp:170:70: error: 'major' was not declared in this scope
         string path = str::stream() << "/sys/dev/block/" << major(dev) << ':' << minor(dev)
                                                                      ^


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-kde-unstable_20160403-233402) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="mmx sse sse2 pax_kernel -cdinstall -oci8 -bindist -apache cgoups consolekit csc egl ffmpeg -ftp gstreamer gui kerberos -libkms -mng mod multimedia multitarget mysql mysqli openexr opengl pdo postscript qemu scrypt server -sockets sse4_2 ssl svg system-cairo system-libvpx tcl -theora tools uml v4l -vaapi xvmc"

  -----------------------------------------------------------------
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/kde, gcc-5.3.0, glibc-2.23-r1, 4.4.8-hardened x86_64)
=================================================================
System uname: Linux-4.4.8-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,   2327972 free
KiB Swap:   16777212 total,  16766456 free
Timestamp of repository gentoo: Thu, 21 Apr 2016 18:24:21 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
ccache version 3.2.4 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.3.5-r7::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.5.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /etc/stunnel/stunnel.conf /opt/openfire/resources/security/ /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/qpsmtpd/plugins /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb /var/lib/redmine/config /var/rancid/.cloginrc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cgoups cli consolekit cracklib crypt csc cups cxx dbus declarative dri dts dvd dvdr egl emboss encode exif fam ffmpeg firefox flac fortran gdbm gif glamor gpm gstreamer gtk gui iconv ipv6 jpeg kde kerberos kipi lcms ldap libnotify mad mmx mmxext mod modules mp3 mp4 mpeg multilib multimedia multitarget mysql mysqli ncurses nls nptl ogg openexr opengl openmp pam pango pax_kernel pcre pdf pdo phonon plasma png policykit postscript ppds qemu qt3support qt4 readline scrypt sdl seccomp semantic-desktop server session spell sse sse2 sse4_2 ssl startup-notification svg system-cairo system-libvpx tcl tcpd tiff tools truetype udev udisks uml unicode upower usb v4l vorbis wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-04-21 22:00:18 UTC
Created attachment 431472 [details]
dev-db:mongodb-3.2.5:20160421-194647.log
Comment 2 Toralf Förster gentoo-dev 2016-04-21 22:00:21 UTC
Created attachment 431474 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-04-21 22:00:24 UTC
Created attachment 431476 [details]
environment
Comment 4 Ultrabug gentoo-dev 2016-08-19 12:16:54 UTC
ok since glibc-2.23-r2.ebuild has been introduced this bug can be closed, thanks !
Comment 5 SpanKY gentoo-dev 2016-11-12 06:56:12 UTC
(In reply to Ultrabug from comment #4)

no, that's not how it works.  packages need to fix their source.  the change is coming eventually, but dragging your heels is only causing that to be delayed.
Comment 6 Johannes Hirte 2017-04-07 19:50:25 UTC
Now again with dev-db/mongodb-3.4.3 and sys-libc/glibc-2.25
Comment 7 Johannes Hirte 2017-04-07 19:51:07 UTC
(In reply to Johannes Hirte from comment #6)
> Now again with dev-db/mongodb-3.4.3 and sys-libc/glibc-2.25

Sorry, meant sys-libs/glibc-2.25
Comment 8 Johannes Hirte 2017-05-02 10:36:12 UTC
Created attachment 471490 [details, diff]
mongodb-3.4.4-glibc.2.25.patch

fix build with glibc-2.25
Comment 9 Yukio Usuzumi 2017-08-14 08:01:34 UTC
Still running into this bug with sys-libc/glibc-2.25-r3 and dev-db/mongodb-3.4.6.
Comment 10 keeperofdakeys 2017-08-16 14:59:51 UTC
After applying the patch provided by Johannes Hirte, I was able to build mongodb 3.4.6 with glibc 2.25-r3.
Comment 11 Tomáš Mózes 2017-08-24 06:21:07 UTC
*** Bug 628584 has been marked as a duplicate of this bug. ***
Comment 12 Tomáš Mózes 2017-08-25 11:27:34 UTC
https://github.com/gentoo/gentoo/pull/5527
Comment 13 Patrice Clement gentoo-dev 2017-09-21 19:54:01 UTC
commit 4fb6b5123a834fbb1d1726aaeebee2ec3ad79fa4 (HEAD -> master, origin/master, origin/HEAD)
Author:     Tomas Mozes <hydrapolic@gmail.com>
AuthorDate: Tue Sep 5 18:09:31 2017 +0200
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: Thu Sep 21 21:50:01 2017 +0200

dev-db/mongodb: fix building with newer libpcre/glibc.

Gentoo-Bug: https://bugs.gentoo.org/580768
Gentoo-Bug: https://bugs.gentoo.org/625148
Gentoo-Bug: https://bugs.gentoo.org/626342

Package-Manager: Portage-2.3.8, Repoman-2.3.2

...6-Replace-string-with-explicit-std-string.patch | 283 +++++++++++++++++++++
dev-db/mongodb/mongodb-3.2.16.ebuild               |  23 +-
2 files changed, 294 insertions(+), 12 deletions(-)
create mode 100644 dev-db/mongodb/files/mongodb-3.2.16-Replace-string-with-explicit-std-string.patch