Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 579546

Summary: sys-apps/dbus-1.10.8-r1: kde apps cannot connect to dbus, plasma session reset after prelink run
Product: Gentoo Linux Reporter: Stefan Huber <shuber>
Component: [OLD] KDEAssignee: Freedesktop bugs <freedesktop-bugs>
Status: RESOLVED DUPLICATE    
Severity: major CC: 8an, darkdexter, egorov_egor, gentoo, gentoo, kde, toolchain
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Stefan Huber 2016-04-10 21:09:38 UTC
When updating dbus from 1.10.6 to 1.10.8-r1 and restarting KDE, plasma starts with a clean desktop, forgetting all plasmoids. Applications like kaddressbook, korganizer, systemsettings, (and probably some more), fail to start with "KUniqueApplication: Pipe closed unexpectedly".

Downgrading to dbus-1.10.8-r1 and restarting KDE restores the old plasma desktop and makes korganizer etc. work again.

Reproducible: Always

Steps to Reproduce:
1. Upgrade to dbus-1.10.8-r1
2. Start korganizer, plasma, etc.
Comment 1 Dan Goodliffe 2016-04-11 09:53:30 UTC
Exactly the same problem for me.

Portage 2.2.26 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/kde/systemd, gcc-4.9.3, glibc-2.22-r4, 4.4.5-gentoo x86_64)
=================================================================
System uname: Linux-4.4.5-gentoo-x86_64-Intel-R-_Core-TM-_i5-2400S_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     8073204 total,   4958028 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of repository gentoo: Sun, 10 Apr 2016 13:30:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.4 [disabled]
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.4.7::gentoo, 4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://portage@randomdan.homeip.net/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: -e 'ssh -x'
                                                                                                                                                
RandomLAN                                                                                                                                       
    location: /var/lib/layman/RandomLAN                                                                                                                                         
    masters: gentoo                                                                                                                                                             
    priority: 0                                                                                                                                                                 
                                                                                                                                                                                
ACCEPT_KEYWORDS="amd64"                                                                                                                                                         
ACCEPT_LICENSE="* -@EULA"                                                                                                                                                       
CBUILD="x86_64-pc-linux-gnu"                                                                                                                                                    
CFLAGS="-Os -march=native -pipe"                                                                                                                                                
CHOST="x86_64-pc-linux-gnu"                                                                                                                                                     
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"                                                                                                                                                              
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"     
CXXFLAGS="-Os -march=native -pipe"                                                                                                                                              
DISTDIR="/usr/portage/distfiles"                                                                                                                                                
FCFLAGS="-O2 -pipe"                                                                                                                                                             
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"                                                                           
FFLAGS="-O2 -pipe"                                                                                                                                                              
GENTOO_MIRRORS="http://sys.randomdan.homeip.net/ http://ftp.linux.org.tr/gentoo"                                                                                                
LANG="en_GB.UTF-8"                                                                                                                                                              
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                                               
MAKEOPTS="-j3"                                                                                                                                                                  
PKGDIR="/usr/portage/packages"                                                                                                                                                  
PORTAGE_CONFIGROOT="/"                                                                                                                                                          
PORTAGE_RSYNC_EXTRA_OPTS="-e 'ssh -x'"                                                                                                                                          
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                                                                
PORTAGE_TMPDIR="/var/tmp"                                                                                                                                                       
USE="X a52 aac acl acpi ads alsa amd64 apache2 apng apulse autoupdate bash-completion berkdb branding bzip2 c++0x cairo cdda clang classic cli cracklib crypt cscope cups custom-cflags custom-optimization cvs cxx dbus declarative designer device-mapper dot dotnet dri drm dts dvd dvdr emboss encode exif fam firefox firmware flac fontconfig fortran fuse g3dvl gbm gdbm gif git glamor gnome-keyring gpm gtk htmlreport iconv icu idea-ultimate informix ipv6 java jpeg json kde kipi lcms ldap libkms libnotify llvm lvmboot lvmroot lzma mad man minizip mmx mmxext mng modules mp3 mp4 mpeg mssql multilib mysql ncurses net45 networkmanager nls nohourlyupdate nptl nscd nsplugin offensive ogg opengl openmp openvg opus osmesa pam pango pcre pdf phonon png policykit postgres postproc ppds python qt3support qt4 qtcurve rdesktop readline rtmp samba savedconfig sdl seccomp secure-delete session sna spell sqlite sse sse2 ssl ssse3 startup-notification svg system-sqlite systemd tcpd thin tiff truetype udev udisks unicode unlock-notify upcall upower usb uxa vim-syntax vnc vorbis winbind wxwidgets x264 xa xattr xcb xcomposite xinerama xml xscreensaver xv xvfb xvid xvmc zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel" APACHE2_MODULES="alias filter authz_core auth_basic authz_user authn_core unixd authz_host cgid mime_magic mime autoindex vhost_alias dav dir deflate log_config env rewrite cache socache_shmcb cache_disk status expires http2" CALLIGRA_FEATURES="braindump flow karbon stage sheets words tables" CAMERAS="sony_dscf1 sony_dscf55" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" DVB_CARDS="none" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="none" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"                    
USE_PYTHON="2.7 3.4"                                                                                                                                                            
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS                                


I've since masked that version and all is well again.
Comment 2 Dan Goodliffe 2016-04-12 12:59:03 UTC
I've suddenly (like just now) starting getting this problem with 1.10.6... so I've upgraded to 1.10.8-r1 and that's fixed it.
I don't understand.
Comment 3 Pacho Ramos gentoo-dev 2016-04-12 19:00:20 UTC
(In reply to Dan Goodliffe from comment #2)
> I've suddenly (like just now) starting getting this problem with 1.10.6...
> so I've upgraded to 1.10.8-r1 and that's fixed it.
> I don't understand.

I don't understand, what version was failing and what was failing? Please provide "emerge -pv dbus" when running the failing dbus version and the same with the proper one. And try to reboot just after changing dbus version to really ensure you are running the version you think

Thanks
Comment 4 Erik Quaeghebeur 2016-04-13 12:16:44 UTC
I can confirm this bug and that downgrading dbus to 1.10.6 fixed things (up until now).

See also: https://forums.gentoo.org/viewtopic-p-7905916.html
Comment 5 Alexander Miller 2016-04-13 15:29:01 UTC
Actually both dbus versions (1.10.8-r1 and 1.10.6) seem to be affected.
My current theory is that the issue is triggered by an update to
sys-libs/glibc-2.22-r4 and is related to prelink. (Can the other
users confirm this?)

I haven't had time to dig deeper, but this is what I observed:
The day after my last world update (which upgraded to dbus-1.10.8-r1)
I experienced the breakage described in comment #1. Downgrading to
dbus-1.10.6 seemed to fix the issue, but the next day the problems
reappeared. So the dbus version doesn't seem to matter. But what
changed during that day (I didn't emerge anything) that could make
it fail again? Prelinking!
I'd run "prelink -u /usr/lib64/libdbusmenu-qt.so.2.6.0" and everything
was back to normal. But prelink has worked before the world update,
and glibc has been updated, too. (The other packages that were updated
are not related to kde or dbus.)
So I think there might be an incompatibility between glibc-2.22-r4's
dynamic linker, prelinking, and dbus. Further investigation needed.

As a temporary workaround, the following might work (not tested):
echo '-b /usr/lib64/libdbusmenu-qt.so*' >> /etc/prelink.conf.d/dbus.conf

[This is on an amd64 box with sys-fs/eudev-3.1.5, sys-devel/gcc-4.9.3,
sys-apps/dbus-1.10.6 (1.10.8-r1), and a patched sys-devel/prelink-20151030]
Comment 6 Egor Y. Egorov 2016-04-13 16:04:46 UTC
(In reply to Alexander Miller from comment #5)
> Actually both dbus versions (1.10.8-r1 and 1.10.6) seem to be affected.
> My current theory is that the issue is triggered by an update to
> sys-libs/glibc-2.22-r4 and is related to prelink. (Can the other
> users confirm this?)
> 
> I haven't had time to dig deeper, but this is what I observed:
> The day after my last world update (which upgraded to dbus-1.10.8-r1)
> I experienced the breakage described in comment #1. Downgrading to
> dbus-1.10.6 seemed to fix the issue, but the next day the problems
> reappeared. So the dbus version doesn't seem to matter. But what
> changed during that day (I didn't emerge anything) that could make
> it fail again? Prelinking!
> I'd run "prelink -u /usr/lib64/libdbusmenu-qt.so.2.6.0" and everything
> was back to normal. But prelink has worked before the world update,
> and glibc has been updated, too. (The other packages that were updated
> are not related to kde or dbus.)
> So I think there might be an incompatibility between glibc-2.22-r4's
> dynamic linker, prelinking, and dbus. Further investigation needed.
> 
> As a temporary workaround, the following might work (not tested):
> echo '-b /usr/lib64/libdbusmenu-qt.so*' >> /etc/prelink.conf.d/dbus.conf
> 
> [This is on an amd64 box with sys-fs/eudev-3.1.5, sys-devel/gcc-4.9.3,
> sys-apps/dbus-1.10.6 (1.10.8-r1), and a patched sys-devel/prelink-20151030]

Good job, Alexander!
I can confirm:
# prelink -u /usr/lib64/libdbusmenu-qt.so.2.6.0
solves this issue with dbus-1.10.8-r1
Comment 7 Stefan Huber 2016-04-13 20:18:27 UTC
(In reply to Alexander Miller from comment #5)
> As a temporary workaround, the following might work (not tested):
> echo '-b /usr/lib64/libdbusmenu-qt.so*' >> /etc/prelink.conf.d/dbus.conf

I believe I can confirm this, too.
Comment 8 Dan Goodliffe 2016-04-13 20:47:19 UTC
Just for my own sanity, am I understanding this correctly by saying the act of re-emerging dbus fixes the problem (albeit temporarily)... the version number is irrelevant?
Comment 9 Egor Y. Egorov 2016-04-14 03:08:16 UTC
I can confirm sys-apps/dbus-1.10.6 affected.
Comment 10 Egor Y. Egorov 2016-04-14 03:11:40 UTC
May be this problem displayed
https://bugzilla.redhat.com/show_bug.cgi?id=1320189
Comment 11 Erik Quaeghebeur 2016-04-14 08:21:42 UTC
(In reply to Dan Goodliffe from comment #8)
> Just for my own sanity, am I understanding this correctly by saying the act
> of re-emerging dbus fixes the problem (albeit temporarily)... the version
> number is irrelevant?

Yes, but dbus doesn't seem to be the (main) culprit here, so e-emerging is not even necessary. To get an immediate fix, use Egor's

# prelink -u /usr/lib64/libdbusmenu-qt.so.*

To get a more permanent fix, use Alexander's

# echo '-b /usr/lib64/libdbusmenu-qt.so*' >> /etc/prelink.conf.d/dbus.conf

I can confirm the former works; the latter is just making this permanent, i.e., meaning that the next (daily) prelink run will not mess things up again.

(This bug should be marked as confirmed.)
Comment 12 Anthony Mendez 2016-04-14 23:42:40 UTC
Same issue with same results.

- Downgrading dbus "fixed" the issue.
- Removed prelink and updated dbus and issue is resolved.
Comment 13 Pacho Ramos gentoo-dev 2016-04-16 10:47:42 UTC
What prelink version are you running?
Comment 14 Egor Y. Egorov 2016-04-16 12:47:39 UTC
sys-devel/prelink-20130503
in my case
Comment 15 Egor Y. Egorov 2016-04-16 13:11:28 UTC
with 20151030 same issue
Comment 16 Alexander Miller 2016-04-16 18:29:10 UTC
The same issue is discussed in bug #579374, too. This should be
marked as a duplicate (or the other way round).
Comment 17 Erik Quaeghebeur 2016-04-17 12:15:25 UTC
(In reply to Egor Y. Egorov from comment #10)
> May be this problem displayed
> https://bugzilla.redhat.com/show_bug.cgi?id=1320189

This links to https://sourceware.org/bugzilla/show_bug.cgi?id=19178, which implies that a fix should be available for glibc-2.22 and that glibc-2.23 should not be affected (fixed upon release).

Did anyone try glibc-2.23?
Comment 18 Dan Goodliffe 2016-04-17 12:27:38 UTC
I have few boxes running ~amd64 and ~x86, which all have glibc-2.23 on and none of them were affected by this. But obviously, they have other versions of many other things too. I can't test the box I have issues with until I get back into work tomorrow.
Comment 19 Egor Y. Egorov 2016-04-17 13:48:37 UTC
(In reply to Erik Quaeghebeur from comment #17)
> (In reply to Egor Y. Egorov from comment #10)
> > May be this problem displayed
> > https://bugzilla.redhat.com/show_bug.cgi?id=1320189
> 
> This links to https://sourceware.org/bugzilla/show_bug.cgi?id=19178, which
> implies that a fix should be available for glibc-2.22 and that glibc-2.23
> should not be affected (fixed upon release).
> 
> Did anyone try glibc-2.23?

I try glibc-2.23. It is affected.
Comment 20 jonathan e. Snow 2016-04-18 19:19:55 UTC
I can confirm. I am running a stable x86 system, and glibc is the most recently upgraded package of the ones under discussion, so I downgraded it to 2.21-r2. 

That worked. 

dbus 1.8.16
prelink 20130503
kernel 4.1.12-gentoo
Comment 21 Alexander Miller 2016-04-29 15:41:42 UTC
Please test the following patch for sys-libs/glibc:
<https://bugs.gentoo.org/attachment.cgi?id=432574>

Don't forget to remove any temporary workarounds and to re-prelink your system after installing the patched glibc.

(Note: dbus is totally unrelated to the issue except for being a dependency of the affected kde apps; unprelinking dbus stuff effectively disables prelinking for kde. See bug #579374 for more details.)
Comment 22 julakali 2016-05-02 20:33:06 UTC
I didn't try any other workarounds, just your patch after I encountered the issue. It works fine for me so far with glibc-2.22-r4 and the given patch. Thank you!
Comment 23 Johannes Huber gentoo-dev 2016-05-02 20:41:03 UTC

*** This bug has been marked as a duplicate of bug 579374 ***