Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 570460

Summary: x11-libs/gtksourceview-2.10.5-r3 : checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kentnl
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: config.log
emerge-history.txt
environment
x11-libs:gtksourceview-2.10.5-r3:20160101-044013.log

Description Toralf Förster gentoo-dev 2016-01-01 10:03:40 UTC
checking for perl >= 5.8.1... 5.20.2
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-libs/gtksourceview-2.10.5-r3/work/gtksourceview-2.10.5/config.log
 * ERROR: x11-libs/gtksourceview-2.10.5-r3::gentoo failed (configure phase):


$ cat ./info.txt
  -----------------------------------------------------------------

  This is an stable amd64 chroot image (named amd64-desktop-stable_20151231-103211) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  Portage 2.2.24 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.21-r1, 4.2.7-hardened x86_64)
=================================================================
System uname: Linux-4.2.7-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164724 total,   1982912 free
KiB Swap:   16777212 total,  16731728 free
Timestamp of repository gentoo: Thu, 31 Dec 2015 23:22:17 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.4::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --deep --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alsa amd64 apache2 avcodec berkdb bluetooth branding bzip2 cairo cdda cdr cgi clang cli compat consolekit cracklib crypt cups curl custom-optimization cxx dbus designer dri drmkms dts dvd dvdr emboss encode exif extraengine fam ffmpeg firefox flac fontconfig fortran fpm ftp gd gdbm gif glamor gles2 gnuplot gpm gtk gtkstyle haptic havege hdf5 hpn iconv icu imlib inifile ipv6 ithreads jadetex javafx javaxml jpeg kerberos kvm lcms libkms libnotify mad melt minizip mmx mmxext mng modules mp3 mp4 mpeg multilib mysql mysqli ncurses nls nptl objc offensive ogg ois opengl openmp pam pango pax_kernel pcre pdf pdo plasma png policykit postgres postproc ppds pulseaudio python qt3support qt4 qt5 readline scripts sddm sdl seccomp semantic-desktop server session sockets spell sqlite sqlite3 sse sse2 sse4 ssh-askpass ssl startup-notification svg swscale system-jpeg system-libvpx szip tcl tcpd theora threads tiff tk tls truetype udev udisks ufed uml unicode upower usb v4l v4l2 vaapi video vorbis wav webkit wxwidgets x264 xa xattr xcb xml xv xvid xz zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-01-01 10:03:42 UTC
Created attachment 421416 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-01-01 10:03:44 UTC
Created attachment 421418 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-01-01 10:03:47 UTC
Created attachment 421420 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-01-01 10:03:49 UTC
Created attachment 421422 [details]
x11-libs:gtksourceview-2.10.5-r3:20160101-044013.log
Comment 5 Toralf Förster gentoo-dev 2016-01-01 10:05:59 UTC
same happened here for x11-themes/gnome-icon-theme-3.12.0 and net-dns/avahi-0.6.31-r10
Comment 6 Toralf Förster gentoo-dev 2016-01-01 10:20:21 UTC
andsys-fs/udisks-2.1.4

FWIW I keyworded here certain packages to test for upcoming ffmpeg-2.8.4 - that shouldn't cause this bug, or ?
Comment 7 Felix Janda 2016-01-01 10:20:59 UTC
And still does after having run perl-cleaner?
Comment 8 Pacho Ramos gentoo-dev 2016-01-01 13:34:59 UTC
I run ffmpeg-2.8.x and all gnome stuff builds ok with it, this looks like the usual perl-cleaner problem

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 9 Toralf Förster gentoo-dev 2016-01-01 14:05:48 UTC
I'll run "perl-cleaner --all" soon, but OTOH this was setup from a recent stable autobuild image so there was no dev-lang/perl upgrade.
But maybe few other perl packages  caused this ?
Comment 10 Toralf Förster gentoo-dev 2016-01-01 15:18:26 UTC
(In reply to Pacho Ramos from comment #8)
> I run ffmpeg-2.8.x and all gnome stuff builds ok with it, this looks like
> the usual perl-cleaner problem
> 
> *** This bug has been marked as a duplicate of bug 41124 ***

indeed - thx Pacho.

Although Perl was not upgraded, it was rebuild due to the changed USE flag settings - seems that even that case isn't handled right all the time by portage, or ?
Comment 11 Pacho Ramos gentoo-dev 2016-01-01 15:33:13 UTC
Umm, if I don't misremember there was a concrete USE flag that needed perl-cleaner to be run after switching, but I don't remember exactly (ithreads maybe?)
Comment 12 Pacho Ramos gentoo-dev 2016-01-01 15:36:15 UTC
Yeah, the warning should have being shown by:
dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit:
                        ewarn "TOGGLED USE-FLAGS WARNING:"
                        ewarn "You changed one of the use-flags ithreads or debug."
                        ewarn "You must rebuild all perl-modules installed."
                        ewarn "Use: perl-cleaner --modules ; perl-cleaner --force --libperl"
Comment 13 Toralf Förster gentoo-dev 2016-01-01 15:48:05 UTC
(In reply to Pacho Ramos from comment #12)
> Yeah, the warning should have being shown by:

Ah thx, 

In IRC I was told few weeks ago (or I misunderstood that) that perl-cleaner shouldn't be run any longer manually - and if - that this points to an issue.
But ok, I reinserted appropriate logic to my script.
Comment 14 Pacho Ramos gentoo-dev 2016-01-01 17:16:49 UTC
I think they were probably referring to the usual scenario of not needing to run it after updating (as subslots can take care of that), but I cannot see how to achieve the same with this case without adding ithreads USE to all perl consumer :/
Comment 15 Kent Fredric (IRC: kent\n) gentoo-dev 2016-10-09 09:57:04 UTC

*** This bug has been marked as a duplicate of bug 596664 ***