Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 569948

Summary: net-wireless/ubertooth-2015.10.1 should support python3
Product: Gentoo Linux Reporter: Anton Bolshakov <blshkv>
Component: Current packagesAssignee: Rick Farina (Zero_Chaos) <zerochaos>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://github.com/gentoo/gentoo/pull/8334
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 649576    
Bug Blocks: 694800    

Description Anton Bolshakov 2015-12-28 01:13:59 UTC
According to the changelog (https://github.com/greatscottgadgets/ubertooth/releases) python3 supported has been added in this version.

Could you please test and revise the ebuild?

Thank you.
Comment 1 Andreas Sturmlechner gentoo-dev 2018-06-26 21:09:51 UTC
Only USE=specan requires python, which is about to be removed.
Comment 2 Larry the Git Cow gentoo-dev 2018-06-27 19:00:54 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=89cd5c260da910b885f9c760b4e7d8b99ab1553d

commit 89cd5c260da910b885f9c760b4e7d8b99ab1553d
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-06-26 21:12:15 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-06-27 19:00:21 +0000

    net-wireless/ubertooth: Drop USE=specan, depends on Qt4
    
    Bug: https://bugs.gentoo.org/569948
    Bug: https://bugs.gentoo.org/649576
    Package-Manager: Portage-2.3.40, Repoman-2.3.9

 .../ubertooth/ubertooth-2017.03.2-r1.ebuild        | 70 ++++++++++++++++++++++
 net-wireless/ubertooth/ubertooth-9999.ebuild       | 42 ++-----------
 2 files changed, 75 insertions(+), 37 deletions(-)
Comment 3 Andreas Sturmlechner gentoo-dev 2020-05-27 18:59:15 UTC
Last version to require py2 dropped in commit 38be64e6.