Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 569516

Summary: media-gfx/graphviz-2.38.0-r1: should require dev-scheme/guile to be installed with USE flag "deprecated"
Product: Gentoo Linux Reporter: Daniel Oliveira <psykon>
Component: [OLD] LibraryAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED DUPLICATE    
Severity: minor CC: wizardedit
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Daniel Oliveira 2015-12-23 16:47:09 UTC
media-gfx/graphviz does not build if dev-scheme/guile is built with "-deprecated".

Reproducible: Always

Steps to Reproduce:
1. Add dev-scheme/guile -deprecated to /etc/portage/package.use
2. Add media-gfx/graphviz guile to /etc/portage/package.use
3. emerge graphviz
Actual Results:  
Build error.

Expected Results:  
media-gfx/graphviz installed.
Comment 1 Rafał Mużyło 2015-12-24 14:15:54 UTC
Build log with the error required.
Comment 2 Austin English (RETIRED) gentoo-dev 2016-06-27 18:38:04 UTC
https://github.com/gentoo/gentoo/pull/1772
Comment 3 Arfrever Frehtes Taifersar Arahesis 2016-07-02 14:42:09 UTC

*** This bug has been marked as a duplicate of bug 491716 ***