Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 567674

Summary: Patch for (yet another) missing include for crda-1.1.3 on musl-hardened.
Product: Gentoo Linux Reporter: Damien Levac <damien.levac>
Component: HardenedAssignee: Gentoo musl team <musl>
Status: UNCONFIRMED ---    
Severity: trivial    
Priority: Normal    
Version: autobuilds   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 430702    
Attachments: Patch that add `#include <linux/limits.h>` to reglib.h

Description Damien Levac 2015-12-06 19:48:41 UTC
Created attachment 418678 [details, diff]
Patch that add `#include <linux/limits.h>` to reglib.h

When trying to emerge crda-1.1.3 with musl, the build fails because reglib.h does not include <linux/limits.h> even though it makes use of PATH_MAX. I have included a patch that fixes the problem.
Comment 1 Felix Janda 2015-12-06 22:56:11 UTC
Please use the POSIX header <limits.h> if it is just for PATH_MAX.
Also, PATH_MAX is not used in reglib.h and would therefore better fit
into reglib.c.

I think it is indirectly fixed in upstream commit
f4c3e3fcae69d90ad3763d2602765104dcb04708. Does version 3.18 work for
you?