Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 566318

Summary: media-gfx/inkscape-0.91 - multiple error after libsigc++-2.6.2 and glibmm-2.46.1 upgrade
Product: Gentoo Linux Reporter: Juergen Rose <rose>
Component: Current packagesAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED FIXED    
Severity: normal CC: atoth, bureau, CasperVector, chalucha, cornicx, daniel, devurandom, email200202, eugene.shalygin, fcoiffie, gem, gentoo, grozin, ikelos, iskatu, jakub.panachida, jgeboski, jlec, jpizarrocallejas, kkrizka, kripton, m+gentoo-bugs, Martin.vGagern, mosaic_loop, patrakov, remi, silvio.gerli, steffen.weber, vityokster, volkov, zlg
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://launchpad.net/bugs/1488079
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 566328    
Attachments: build.log.bz2

Description Juergen Rose 2015-11-20 10:23:47 UTC
'MAKEOPTS=-j1 emerge -v1 inkscape' fails with:

...
e/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/gconf/2 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -fopenmp -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=32 -fopenmp -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=32 -fopenmp -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=32 -I/usr/include/ImageMagick-6  -I/usr/include/libvisio-0.1 -I/usr/include/libxml2 -I/usr/include/librevenge-0.0 -I/usr/include/libcdr-0.1 -I/usr/include/librevenge-0.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include    -I/usr/include/poppler -I/usr/include/poppler/glib -I/usr/include/poppler -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16 -DPOTRACE=\"potrace\" -pthread -I/usr/include/gtkspell-2.0 -I/usr/include/gtkmm-2.4 -I/usr/lib64/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/gtk-unix-print-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gdkmm-2.4 -I/usr/lib64/gdkmm-2.4/include -I/usr/include/giomm-2.4 -I/usr/lib64/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib64/pangomm-1.4/include -I/usr/include/glibmm-2.4 -I/usr/lib64/glibmm-2.4/include -I/usr/include/cairomm-1.0 -I/usr/lib64/cairomm-1.0/include -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -pthread -I/usr/include/cairomm-1.0 -I/usr/lib64/cairomm-1.0/include -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/giomm-2.4 -I/usr/lib64/giomm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib64/glibmm-2.4/include -I/usr/include/libpng16 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include   -DG_DISABLE_DEPRECATED -DGLIBMM_DISABLE_DEPRECATED -DGDKMM_DISABLE_DEPRECATED -DGTK_DISABLE_SINGLE_INCLUDES -DGTK_DISABLE_DEPRECATED -DGTKMM_DISABLE_DEPRECATED -Werror=format-security -Wswitch -Werror=return-type -DGSEAL_ENABLE -DG_DISABLE_SINGLE_INCLUDES -Wall -Wformat -Wformat-security   -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -Wno-unused-parameter -march=amdfam10 -O2 -pipe -fno-strict-aliasing -fopenmp -c -o livarot/PathCutting.o livarot/PathCutting.cpp
In file included from /usr/include/sigc++-2.0/sigc++/signal_base.h:26:0,
                 from /usr/include/sigc++-2.0/sigc++/signal.h:8
                 from /usr/include/sigc++-2.0/sigc++/connection.h:22
                 from ./sp-object.h:51
                 from ./sp-filter.h:18
                 from ./style-internal.h:25
                 from ./style.h:21
                 from livarot/PathCutting.cpp:21
/usr/include/sigc++-2.0/sigc++/trackable.h:40:3:warning: identifier ‘noexcept’ is a keyword in C++11 [-Wc++0x-compat]
   trackable_callback(void* data, func_destroy_notify func) noexcept
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/type_traits:35:0,
                 from /usr/include/sigc++-2.0/sigc++/visit_each.h:22,
                 from /usr/include/sigc++-2.0/sigc++/functors/slot.h:6,
                 from /usr/include/sigc++-2.0/sigc++/signal_base.h:27,
                 from /usr/include/sigc++-2.0/sigc++/signal.h:8,
                 from /usr/include/sigc++-2.0/sigc++/connection.h:22,
                 from ./sp-object.h:51,
                 from ./sp-filter.h:18,
                 from ./style-internal.h:25,
                 from ./style.h:21,
                 from livarot/PathCutting.cpp:21:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/bits/c++0x_warning.h:32:2:error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
 #error This file requires compiler and library support for the \
//
...
Comment 1 Juergen Rose 2015-11-20 10:25:19 UTC
root@impala:/root(48)# emerge --info '=media-gfx/inkscape-0.91::gentoo'
Portage 2.2.25 (python 2.7.10-final-0, default/linux/amd64/13.0, gcc-4.9.3, glibc-2.22-r1, 4.3.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.3.0-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:     8163332 total,   2076140 free
KiB Swap:   50331640 total,  49848688 free
Timestamp of repository gentoo: Fri, 20 Nov 2015 05:30:01 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10-r3::gentoo, 3.4.3-r2::gentoo, 3.5.0-r1::gentoo
dev-util/cmake:           3.4.0-r1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.3::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /usr/portage_impala
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

g-cpan
    location: /var/lib/cpan
    masters: gentoo
    priority: 1

g-octave
    location: /var/lib/g-octave
    masters: gentoo
    priority: 2

sage-on-gentoo
    location: /var/lib/layman/sage-on-gentoo
    masters: gentoo science
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

sunrise
    location: /var/lib/layman/sunrise
    masters: gentoo
    priority: 50

x11
    location: /var/lib/layman/x11
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA NVIDIA-CUDA Nero-AAC-EULA GIMPS"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow 3dnowext 64bit R X Xaw3d a52 aac accessibility acl acpi admin afs alsa amd64 amr ao apache2 apng applet archive armadillo arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cilk cli cmake collada cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples excel exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx ftp fuse gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3tag ide imagemagick imap inotify introspection ipod ipv6 ithreads jabber jadetex java jbig jit john jpeg jpeg2k kate kde kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack latex lcms ldap lensfun libffi libgda libkms libnotify libsamplerate live lm_sensors lua lzma lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mpi-threads mplayer mtp multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg opencv openexr opengl openmp openvg pam pango pcre pda pdf pdl2 perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm pstricks pulseaudio python q16 q32 qemu qhull qt3support qt4 qt5 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl seccomp secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4a ssl stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tbb tcl tcpd tex tex4ht texmacs theora thesaurus threads thunderbird tidy tiff tk tools truetype udev udisks unicode usb utempter v4l v4l2 vaapi vala valgrind vdpau video virt-network virtualbox visio vorbis vpx vtk wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext popcnt sse sse2 sse3 sse4a" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev void" KERNEL="linux" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd SureElec" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nouveau displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-gfx/inkscape-0.91::gentoo was built with the following:
USE="cdr dbus dia exif gnome imagemagick jpeg lcms nls openmp postscript spell visio -inkjar -static-libs -wpg" ABI_X86="64" PYTHON_TARGETS="python2_7"
CFLAGS="-march=amdfam10 -O2 -pipe -fno-strict-aliasing"
CXXFLAGS="-march=amdfam10 -O2 -pipe -fno-strict-aliasing"




root@impala:/root(49)# emerge -pqv '=media-gfx/inkscape-0.91::gentoo'
[ebuild   R   ] media-gfx/inkscape-0.91  USE="cdr dbus dia exif gnome imagemagick jpeg lcms nls openmp postscript spell visio -inkjar -static-libs -wpg" PYTHON_TARGETS="python2_7"
Comment 2 Juergen Rose 2015-11-20 10:26:27 UTC
Created attachment 417456 [details]
build.log.bz2
Comment 3 Pacho Ramos gentoo-dev 2015-11-20 11:56:24 UTC
*** Bug 566310 has been marked as a duplicate of this bug. ***
Comment 4 Pacho Ramos gentoo-dev 2015-11-20 12:00:00 UTC
@maintainer, summary is also in parent bug

You can see for example what Fedora did:
http://pkgs.fedoraproject.org/cgit/inkscape.git/tree/inkscape.spec
# Build in C++11 mode as glibmm headers use C++11 features. This can be dropped
# when GCC in Fedora switches to C++11 by default (with GCC 6, most likely).
export CXXFLAGS="%{optflags} -std=c++11"
Comment 5 Mike Auty gentoo-dev 2015-11-21 02:50:59 UTC
*** Bug 566350 has been marked as a duplicate of this bug. ***
Comment 6 Mike Auty gentoo-dev 2015-11-21 02:52:42 UTC
Jorgicio had a workaround in bug 566350 comment 4 ( https://bugs.gentoo.org/show_bug.cgi?id=566350#c4 ).
Comment 7 Ted Tanberry 2015-11-21 10:27:35 UTC
Even simpler fix:

--- inkscape-0.91.ebuild
+++ inkscape-0.91.ebuild
@@ -115,7 +115,7 @@
 
 src_configure() {
 	# aliasing unsafe wrt #310393
-	append-flags -fno-strict-aliasing
+	append-flags -fno-strict-aliasing -std=gnu++11
 
 	econf \
 		$(use_enable static-libs static) \
Comment 8 Bernd Feige 2015-11-21 14:00:07 UTC
(In reply to Ted Tanberry from comment #7)

Works, thanks!
Comment 9 Ivan Iraci 2015-11-21 15:53:59 UTC
It works for me too.

Thanks!
Comment 10 Gary E. Miller 2015-11-22 21:21:36 UTC
For those, like me, not adept at ebuild patching, I found this worked for me:

# change to patch directory
      cd /usr/portage/media-gfx/inkscape/

# create file my.patch with the patch

# show that I got the patch right
      cat my.patch
--- inkscape-0.91.ebuild
+++ inkscape-0.91.ebuild
@@ -115,7 +115,7 @@
 
 src_configure() {
 	# aliasing unsafe wrt #310393
-	append-flags -fno-strict-aliasing
+	append-flags -fno-strict-aliasing -std=gnu++11
 
 	econf \
 		$(use_enable static-libs static) \

# apply the patch
       patch < my.patch

# run emerge, tell it to ignore digest verification errors
       emerge --digest  =media-gfx/inkscape-0.91
Comment 11 Martin von Gagern 2015-11-23 00:13:44 UTC
(In reply to Gary E. Miller from comment #10)
> For those, like me, not adept at ebuild patching, I found this worked for me:

Easier solution:

# mkdir -p /etc/portage/env/media-gfx
# echo 'CXXFLAGS="${CXXFLAGS} -std=gnu++11"' \
  > /etc/portage/env/media-gfx/inkscape-0.91
Comment 12 Pacho Ramos gentoo-dev 2015-11-24 11:41:23 UTC
*** Bug 566698 has been marked as a duplicate of this bug. ***
Comment 13 email200202 2015-11-25 02:58:06 UTC
I have the same problem on ~amd64.
Comment 14 email200202 2015-11-25 03:45:25 UTC
Martin's workaround worked for me.
Comment 15 Vincent Le Ligeour 2015-11-25 07:24:11 UTC
(In reply to Martin von Gagern from comment #11)

Works for me on ~amd64
Comment 16 Bob Raitz 2015-11-25 09:05:21 UTC
(In reply to Martin von Gagern from comment #11)
> (In reply to Gary E. Miller from comment #10)
> > For those, like me, not adept at ebuild patching, I found this worked for me:
> 
> Easier solution:
> 
> # mkdir -p /etc/portage/env/media-gfx
> # echo 'CXXFLAGS="${CXXFLAGS} -std=gnu++11"' \
>   > /etc/portage/env/media-gfx/inkscape-0.91

Worked like a charm.
Comment 17 Juergen Rose 2015-11-25 10:08:29 UTC
(In reply to Ted Tanberry from comment #7)
> Even simpler fix:
> 
> --- inkscape-0.91.ebuild
> +++ inkscape-0.91.ebuild
> @@ -115,7 +115,7 @@
>  
>  src_configure() {
>  	# aliasing unsafe wrt #310393
> -	append-flags -fno-strict-aliasing
> +	append-flags -fno-strict-aliasing -std=gnu++11
>  
>  	econf \
>  		$(use_enable static-libs static) \

Works here too.
Comment 18 Bernardo Costa 2015-11-30 09:12:52 UTC
(In reply to Vincent Le Ligeour from comment #15)
> (In reply to Martin von Gagern from comment #11)
> 
> Works for me on ~amd64

Also works here, also ~amd64.

Shouldn't the ebuild be modified to include the -std in some way? I realize it could be a hard choice between c++11 or gnu++11, but (if possible) the ebuild could warn if no "env" is found for setting an appropriate std, and force the user to make the choice, rather than failing with a 10000+ line error log.
Comment 19 Miroslav Šulc gentoo-dev 2015-11-30 09:48:50 UTC
the fix works for inkscape-9999 too
Comment 20 Randy Andy 2015-12-02 17:08:08 UTC
Works also for me on ~amd64.

Would be great to see it in the tree asap. 

Many thanks to all.
Comment 21 Matt Whitlock 2015-12-02 19:53:29 UTC
(In reply to Bernardo Costa from comment #18)
> I realize it could be a hard choice between c++11 or gnu++11

If the current build system does not specify a -std, then you must go with -std=gnu++11 because -std=c++11 would disable certain options that GCC enables by default. (G++'s default is -std=gnu++03.)
Comment 22 Ted Tanberry 2015-12-04 08:33:57 UTC
(In reply to Bernardo Costa from comment #18)
> (In reply to Vincent Le Ligeour from comment #15)
> > (In reply to Martin von Gagern from comment #11)
> > 
> > Works for me on ~amd64
> 
> Also works here, also ~amd64.
> 
> Shouldn't the ebuild be modified to include the -std in some way? I realize
> it could be a hard choice between c++11 or gnu++11, but (if possible) the
> ebuild could warn if no "env" is found for setting an appropriate std, and
> force the user to make the choice, rather than failing with a 10000+ line
> error log.

No, it is the build system's task to request a compiler with {c,gnu}++11 features and enable them by adding the appropriate -std= flags. The user should not be required to include -std= in their global CXXFLAGS, which might wreck havoc with packages implicitly relying on being compiled in C++98 mode.
Comment 23 Martin von Gagern 2015-12-04 10:22:54 UTC
> (In reply to Bernardo Costa from comment #18)
>> Shouldn't the ebuild be modified to include the -std in some way?

Yes it should. At least until this can get addressed in a better way. People having to reconfigure things locally along the lines of comment #11 is hardly appropriate since people should be able to simply emerge a package, without jumping through hoops if it can be avoided.

(In reply to Ted Tanberry from comment #22)
> No, it is the build system's task to request a compiler with {c,gnu}++11
> features and enable them by adding the appropriate -std= flags.

Ultimately you are right, ultimately the ebuilds should only have to call configure and make, anything special which is not due to some Gentoo-specific quirk should be reported and handled upstream.

There already is a bug report for this one here upstream:
https://bugs.launchpad.net/inkscape/+bug/1488079
Someone might want to add this to the see-also field. And those with Launchpad accounts may want to report that they are affected by this, to add heat to the issue. Quoting from that bug report:

> Wow... this is actually a much bigger issue, because we deliberately
> haven't yet used any C++11 features directly in Inkscape.

So the problem is not just of inkscape's making, but depends on the ecosystem in which inkscape is being built. Handling such issues in the ebuild makes a lot of sense, although it would still be even better if the inkscape devs got some magic in there to set the right flags automatically. They are working on it.

> The user
> should not be required to include -std= in their global CXXFLAGS, which
> might wreck havoc with packages implicitly relying on being compiled in
> C++98 mode.

Neither the approach suggested in comment #11 and confirmed by several people, nor the Gentoo maintainers adding the flag to this ebuild, would in any way that I can see affect the global (i.e. system-wide, set in make.conf) CXXFLAGS. So I'm not sure what you are getting at here.
Comment 24 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-12-06 21:23:15 UTC
I'm on it. Testing a fix now.
Comment 25 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-12-06 21:58:05 UTC
-std=c++11 added in a revbump.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cef53b6b037f5382b30dd2a8fb7a2f89d4a158d5
Comment 26 tman 2015-12-07 23:23:52 UTC
i don't see the ebuild anywhere after syncing, i still get the same errors because no media-gfx/inkscape/inkscape-0.91-r1.ebuild insight on server even it was uploaded on 

author	Michał Górny <mgorny@gentoo.org>	2015-12-06 20:19:08 (GMT)
committer	Michał Górny <mgorny@gentoo.org>	2015-12-06 21:55:14 (GMT


we have now 8.12.2015...
Comment 27 Kobboi 2015-12-07 23:37:42 UTC
I would check again:

Installed versions:  0.91-r1^t{tbz2}(20:44:11 07-12-15)(cdr dbus exif gnome jpeg lcms nls openmp spell -dia -imagemagick -inkjar -postscript -static-libs -visio -wpg PYTHON_TARGETS="python2_7")
Comment 28 tman 2015-12-08 05:48:48 UTC
i still have this problem and there is no inkscape-0.91-r1.ebuild in tree here, syncing dont help :((
Comment 29 Loop 2016-01-10 03:54:38 UTC
I have tried Martin's solution but without success
Comment 30 Attila Tóth 2016-01-14 05:55:02 UTC
(In reply to Loop from comment #29)
> I have tried Martin's solution but without success

Have you tried Gary's solution in Comment 10?