Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 564018

Summary: =net-misc/ntp-4.2.8_p4 - src_test(): ../../ntpd/libntpd.a(ntp_proto.o):(.toc+0x0): undefined reference to `waitsync_fd_to_close'
Product: Gentoo Linux Reporter: Jeroen Roovers (RETIRED) <jer>
Component: [OLD] Core systemAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED FIXED    
Severity: normal CC: ia64, ppc64, ppc, slyfox, toolchain
Priority: Normal Keywords: PATCH, TESTFAILURE
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://bugs.ntp.org/show_bug.cgi?id=2951
See Also: http://bugs.ntp.org/show_bug.cgi?id=2951
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: net-misc:ntp-4.2.8_p4:20151025-052054.log
net-misc:ntp-4.2.8_p8:20160605-092516.log.xz
0001-net-misc-ntp-fix-tests-on-ia64-and-similar-bug-56401.patch
build.log (4.5.8_p13-r2, ppc64)

Description Jeroen Roovers (RETIRED) gentoo-dev 2015-10-25 05:32:55 UTC
../../ntpd/libntpd.a(ntp_proto.o):(.toc+0x0): undefined reference to `waitsync_fd_to_close'
../../ntpd/ntp_config.o:(.toc+0x0): undefined reference to `ntpdOptions'
../../ntpd/ntp_config.o: In function `get_logmask':
ntp_config.c:(.text.dump_config_tree+0xc4): undefined reference to `keyword'
ntp_config.c:(.text.dump_config_tree+0x110): undefined reference to `keyword'
ntp_config.c:(.text.dump_config_tree+0x224): undefined reference to `keyword'
ntp_config.c:(.text.dump_config_tree+0x2bc): undefined reference to `keyword'
ntp_config.c:(.text.dump_config_tree+0x324): undefined reference to `keyword'
../../ntpd/ntp_config.o:ntp_config.c:(.text.dump_config_tree+0x3b4): more undefined references to `keyword' follow
../../ntpd/ntp_config.o: In function `get_logmask':
ntp_config.c:(.text.dump_config_tree+0x100c): undefined reference to `quote_if_needed'
ntp_config.c:(.text.dump_config_tree+0x101c): undefined reference to `quote_if_needed'
ntp_config.c:(.text.dump_config_tree+0x1238): undefined reference to `keyword'
ntp_config.c:(.text.dump_config_tree+0x12f4): undefined reference to `keyword'
../../ntpd/ntp_config.o: In function `append_gen_fifo':
ntp_config.c:(.text.save_and_apply_config_tree+0x344): undefined reference to `keyword'
ntp_config.c:(.text.save_and_apply_config_tree+0x3a8): undefined reference to `keyword'
ntp_config.c:(.text.save_and_apply_config_tree+0xe0c): undefined reference to `keyword'
../../ntpd/ntp_config.o:ntp_config.c:(.text.save_and_apply_config_tree+0xe3c): more undefined references to `keyword' follow
../../ntpd/ntp_config.o: In function `append_gen_fifo':
ntp_config.c:(.text.save_and_apply_config_tree+0x29b8): undefined reference to `token_name'
ntp_config.c:(.text.save_and_apply_config_tree+0x2dc4): undefined reference to `keyword'
../../ntpd/ntp_config.o: In function `concat_gen_fifos':
ntp_config.c:(.text.config_remotely+0x58): undefined reference to `lex_init_stack'
ntp_config.c:(.text.config_remotely+0x84): undefined reference to `yyparse'
ntp_config.c:(.text.config_remotely+0x8c): undefined reference to `lex_drop_stack'
../../ntpd/ntp_io.o:(.toc+0x8): undefined reference to `listen_to_virtual_ips'
../../ntpd/ntp_io.o:(.toc+0x10): undefined reference to `ntpdOptions'
../../ntpd/libntpd.a(ntp_control.o):(.toc+0x0): undefined reference to `Version'
collect2: error: ld returned 1 exit status
distcc[12402] ERROR: compile (null) on localhost failed
Makefile:960: recipe for target 'test-ntp_signd' failed
make[5]: *** [test-ntp_signd] Error 1
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2015-10-25 05:35:01 UTC
Created attachment 415400 [details]
net-misc:ntp-4.2.8_p4:20151025-052054.log

Sun Oct 25 06:33:31 CET 2015
emerge --info net-misc/ntp
Portage 2.2.20.1 (python 3.4.3-final-0, default/linux/powerpc/ppc64/13.0/64bit-userland, gcc-4.9.3, glibc-2.21-r1, 4.0.5-gentoo ppc64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.0.5-gentoo-ppc64-PPC970FX,_altivec_supported-with-gentoo-2.2
KiB Mem:     8071140 total,   5662720 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of repository gentoo: Sun, 25 Oct 2015 04:15:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 powerpc64-unknown-linux-gnu [enabled]
app-shells/bash:          4.3_p39::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10::gentoo, 3.3.5-r1::gentoo, 3.4.3::gentoo, 3.5.0-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.24-r3::gentoo, 2.25.1-r1::gentoo
sys-devel/gcc:            4.7.4::gentoo, 4.8.4::gentoo, 4.8.5::gentoo, 4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /world/gentoo/portage
    sync-type: rsync
    sync-uri: rsync://rsync.nl.gentoo.org/gentoo-portage
    priority: 0

JeR
    location: /keeps/gentoo/local
    masters: gentoo
    priority: 10000

ACCEPT_KEYWORDS="ppc64"
ACCEPT_LICENSE="*"
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=G5 -mtune=G5 -Wall"
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/ccache/bin /usr/lib/distcc/bin /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -mcpu=G5 -mtune=G5 -Wall"
DISTDIR="/aches/gentoo/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg cgroup compressdebug config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync metadata-transfer multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms sign splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" http://mirror.netcologne.de/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.tiscali.nl/ http://mirror.leaseweb.com/gentoo/ "
LANG="en_GB.utf8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/aches/gentoo/packages/martijn"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa altivec apache2 avahi berkdb botan bzip2 cairo cli consolekit cracklib crypt cups cxx dri drm evdev fontforge fortran fusionsound gadu gdbm gstreamer http2 ibm iconv idn introspection ipv6 jpeg jpeg2k kerberos lcms lensfun lua modules mpi multilib multislot multitarget natspec ncurses nethack nls nptl ocamlopt offensive ofono-headset opengl openmp pam pcre png ppc64 qt3support qt4 r600-llvm-compiler raw readline rubberband scanner sdl session ssl tcl tcmalloc tcpd theora threads tiff tk truetype unicode vpx webp xattr zlib" ABI_PPC="64" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en nl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="modesetting radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-misc/ntp-4.2.8_p4::gentoo was built with the following:
USE="ipv6 readline ssl threads -caps -debug -openntpd (-parse-clocks) -samba (-selinux) -snmp -vim-syntax -zeroconf"
Comment 2 SpanKY gentoo-dev 2015-10-26 03:32:03 UTC
probably related to the ntp signd dupe symbols
Comment 3 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-07-18 11:02:51 UTC
=net-misc/ntp-4.2.8_p4 is no longer in the tree and newer versions have gone stable already.  Is this still open for some reason?
Comment 4 SpanKY gentoo-dev 2016-07-20 04:33:53 UTC
the version in the summary was to reflect the first known failure (older ones didn't have the problem).  if newer versions don't have this problem, we can close the bug.  the fact that newer versions are stable does not itself say the tests are working.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2016-07-20 06:19:10 UTC
Created attachment 441172 [details]
net-misc:ntp-4.2.8_p8:20160605-092516.log.xz
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2016-07-20 06:20:34 UTC
(In reply to Aaron Bauman from comment #3)
> =net-misc/ntp-4.2.8_p4 is no longer in the tree and newer versions have gone
> stable already.  Is this still open for some reason?

I explicitly blocked bug #584954 last June because it is still happening.
Comment 7 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-07-20 11:46:52 UTC
(In reply to Jeroen Roovers from comment #6)
> (In reply to Aaron Bauman from comment #3)
> > =net-misc/ntp-4.2.8_p4 is no longer in the tree and newer versions have gone
> > stable already.  Is this still open for some reason?
> 
> I explicitly blocked bug #584954 last June because it is still happening.

I understand the importance of test failures, but this should not block the security stabilization process.
Comment 8 SpanKY gentoo-dev 2016-07-20 15:45:20 UTC
(In reply to Aaron Bauman from comment #7)

security stabilization is no different from normal stabilization.  if the tests are failing and we think they're important, then security stabilization is blocked.
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2016-07-20 15:50:53 UTC
(In reply to Aaron Bauman from comment #7)

> I understand the importance of test failures, but this should not block the
> security stabilization process.

OK, so you don't understand it.
Comment 10 Sergei Trofimovich (RETIRED) gentoo-dev 2018-12-25 22:47:08 UTC
Also fails on ia64. Looking at the build.log commands almost are identical to amd64 (where it works).

Actually passed flags to gcc are a real benchmark for the toolchain:
  -ffunction-sections -fdata-sections -fPIE -fPIC -Wl,--gc-sections
I suspect one of them to expose toolchain limitation.
Comment 11 Sergei Trofimovich (RETIRED) gentoo-dev 2018-12-26 10:17:57 UTC
Found the trigger:
build fails on all platforms that don't implement
    -ffunction-sections -fdata-sections -Wl,--gc-sections
or have it as a no-op.

Simplest way to reproduce on amd64:
    EXTRA_ECONF=ntp_cv_gc_sections_runs=no FEATURES=test emerge -v1 ntp

If sections are implemented linker does not see unsatisfied dependencies and throws unused parts away. Otherwise final test binaries lack dependencies.
Comment 12 Sergei Trofimovich (RETIRED) gentoo-dev 2019-07-20 11:26:39 UTC
(In reply to Sergei Trofimovich from comment #11)
> Found the trigger:
> build fails on all platforms that don't implement
>     -ffunction-sections -fdata-sections -Wl,--gc-sections
> or have it as a no-op.
> 
> Simplest way to reproduce on amd64:
>     EXTRA_ECONF=ntp_cv_gc_sections_runs=no FEATURES=test emerge -v1 ntp
> 
> If sections are implemented linker does not see unsatisfied dependencies and
> throws unused parts away. Otherwise final test binaries lack dependencies.

Filed https://bugs.ntp.org/show_bug.cgi?id=3601 as an upstream tracking bug.
Comment 13 Sergei Trofimovich (RETIRED) gentoo-dev 2019-09-23 06:52:26 UTC
Created attachment 590666 [details, diff]
0001-net-misc-ntp-fix-tests-on-ia64-and-similar-bug-56401.patch

0001-net-misc-ntp-fix-tests-on-ia64-and-similar-bug-56401.patch is an upstream patch and ebuild update.
Comment 14 Larry the Git Cow gentoo-dev 2019-10-10 22:35:06 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ed9224be036418110ed26afa7bfd839410bb76bb

commit ed9224be036418110ed26afa7bfd839410bb76bb
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2019-09-23 06:50:53 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2019-10-10 22:21:10 +0000

    net-misc/ntp: fix tests on ia64 and similar, bug #564018
    
    Avoid building problematic tests on platforms
    whose linker does not support --gc-sections.
    
    Bug: https://bugs.ntp.org/show_bug.cgi?id=3601
    Closes: https://bugs.gentoo.org/564018
    Package-Manager: Portage-2.3.76, Repoman-2.3.17
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 net-misc/ntp/files/ntp-4.2.8-gc-tests.patch | 41 +++++++++++++++++++++++++++++
 net-misc/ntp/ntp-4.2.8_p13-r2.ebuild        |  1 +
 2 files changed, 42 insertions(+)
Comment 15 ernsteiswuerfel archtester 2020-01-05 17:22:57 UTC
Created attachment 602604 [details]
build.log (4.5.8_p13-r2, ppc64)

Still fails on ppc64.
Comment 16 Sergei Trofimovich (RETIRED) gentoo-dev 2020-01-05 18:10:06 UTC
(In reply to ernsteiswuerfel from comment #15)
> Created attachment 602604 [details]
> build.log (4.5.8_p13-r2, ppc64)
> 
> Still fails on ppc64.

Can you file a new bug?
Comment 17 ernsteiswuerfel archtester 2020-01-05 19:02:53 UTC
(In reply to Sergei Trofimovich from comment #16)
> (In reply to ernsteiswuerfel from comment #15)
> > Created attachment 602604 [details]
> > build.log (4.5.8_p13-r2, ppc64)
> > 
> > Still fails on ppc64.
> 
> Can you file a new bug?

Did that now (bug #704832).