Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 55772

Summary: Had to rebuild XML-Parser to emerge gnome-icon-theme, even though I NEVER upgraded perl
Product: Gentoo Linux Reporter: Sterling Christensen <sterlingchristensen>
Component: [OLD] Core systemAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Sterling Christensen 2004-07-01 03:29:13 UTC
I've looked at the other bugs on XML-Parser and gnome-icon-theme, where people were told to rebuild perl modules whenever they upgrade perl, but I DIDN"T upgrade perl!

All I did was a stage 3 2004.1 install, and then tried to emerge gnome-icon-theme.

Reproducible: Always
Steps to Reproduce:
1. stage 3 2004.1 Gentoo install
2. emerge gnome-icon-theme

Actual Results:  
I get the exact same error message as in bug #52668:

configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
/var/tmp/portage/gnome-icon-theme-1.2.1/work/gnome-icon-theme-1.2.1/missing:
Unknown `--run' option
Try `/var/tmp/portage/gnome-icon-theme-1.2.1/work/gnome-icon-theme-1.2.1/missing
--help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... no
checking for strip... strip
checking whether to enable maintainer-specific portions of Makefiles... no
checking for perl... /usr/bin/perl
configure: error: XML::Parser perl module is required for intltool
                                                                               
                                                                             
!!! ERROR: x11-themes/gnome-icon-theme-1.2.1 failed.
!!! Function econf, Line 365, Exitcode 1
!!! econf failed


Perhaps perl was upgraded without rebuilding modules on the machine used to
generate the stage 3 tarball. My stage 3 install seems to have come that way.
Comment 1 wingstro 2004-08-04 16:19:26 UTC
I think part of the problem is simply dev-perl/XML-Parser needs to be added as a dependency of x11-themes/gnome-icon-theme (in some way).  I did not have dev-perl/XML-Parser installed and was allowed to emerge x11-themes/gnome-icon-theme none-the-less.

Hope this helps :-).
Comment 2 Spider (RETIRED) gentoo-dev 2004-08-04 19:31:54 UTC
this is currently:
DEPEND="sys-devel/gettext
        x11-themes/hicolor-icon-theme
        >=dev-util/intltool-0.29"



Quoting intltool deps:
DEPEND=">=dev-lang/perl-5.6.0"
RDEPEND="dev-perl/XML-Parser
        ${DEPEND}"


Which translates as "Build dependency of gnome-icon-theme includes XML-Parser" 

So, could you please check your emerge.log? (attach it if nothing else) because something was weird with your perl/XML-Parser install
Comment 3 Sterling Christensen 2004-08-07 07:09:03 UTC
My install of XML-Parser came with the stage 3 tarball, so there's nothing in emerge.log about it. If there's something weird with it, I think it's probably a problem with the stage 3 tarball.
Comment 4 Samuli Suominen gentoo-dev 2014-04-09 07:02:24 UTC

*** This bug has been marked as a duplicate of bug 41124 ***